Davin Tjong created SPARK-46581:
-----------------------------------

             Summary: AccumulatorV2 isZero doesn't do what its name implies
                 Key: SPARK-46581
                 URL: https://issues.apache.org/jira/browse/SPARK-46581
             Project: Spark
          Issue Type: Improvement
          Components: Spark Core
    Affects Versions: 3.5.0
            Reporter: Davin Tjong


`AccumulatorV2`'s `isZero` doesn't do what the name or comment implies - it 
actually checks if the accumulator hasn't been updated.

The comment implies that for a `LongAccumulator`, for example, a value of `0` 
would cause `isZero` to be `true`. But if we were to `add(0)`, then the value 
would still be `0` but `isZero` would return `false`.

Propose to rename this to `isUpdated` so the name matches the meaning more 
closely.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscr...@spark.apache.org
For additional commands, e-mail: issues-h...@spark.apache.org

Reply via email to