[ 
https://issues.apache.org/jira/browse/SPARK-12067?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Yanbo Liang updated SPARK-12067:
--------------------------------
    Description: 
* -SPARK-11947 has deprecated DataFrame.isNaN, DataFrame.isNull and replaced by 
DataFrame.isnan, DataFrame.isnull, this PR changed Column.isNaN to 
Column.isnan, Column.isNull to Column.isnull, Column.isNotNull to 
Column.isnotnull.-
* -Add Column.notnull as alias of Column.isnotnull following the pandas naming 
convention.-
* -Add DataFrame.isnotnull and DataFrame.notnull.-

* Add Column.isNaN to PySpark.
* Add isnull, notnull, isnan as alias at Python side in order to be compatible 
with pandas.

  was:
* -SPARK-11947 has deprecated DataFrame.isNaN, DataFrame.isNull and replaced by 
DataFrame.isnan, DataFrame.isnull, this PR changed Column.isNaN to 
Column.isnan, Column.isNull to Column.isnull, Column.isNotNull to 
Column.isnotnull.-
* -Add Column.notnull as alias of Column.isnotnull following the pandas naming 
convention.-
* -Add DataFrame.isnotnull and DataFrame.notnull.-

Add Column.isNaN to PySpark.
Add isnull, notnull, isnan as alias at Python side in order to be compatible 
with pandas.


> Fix usage of isnan, isnull, isnotnull of Column and DataFrame
> -------------------------------------------------------------
>
>                 Key: SPARK-12067
>                 URL: https://issues.apache.org/jira/browse/SPARK-12067
>             Project: Spark
>          Issue Type: Improvement
>          Components: SQL
>            Reporter: Yanbo Liang
>
> * -SPARK-11947 has deprecated DataFrame.isNaN, DataFrame.isNull and replaced 
> by DataFrame.isnan, DataFrame.isnull, this PR changed Column.isNaN to 
> Column.isnan, Column.isNull to Column.isnull, Column.isNotNull to 
> Column.isnotnull.-
> * -Add Column.notnull as alias of Column.isnotnull following the pandas 
> naming convention.-
> * -Add DataFrame.isnotnull and DataFrame.notnull.-
> * Add Column.isNaN to PySpark.
> * Add isnull, notnull, isnan as alias at Python side in order to be 
> compatible with pandas.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscr...@spark.apache.org
For additional commands, e-mail: issues-h...@spark.apache.org

Reply via email to