My first kernel patch, hope I did everything correctly! Instead of calling 
strlen on every iteration of the for loop, just call it once instead and store 
in a variable.

Signed-off-by: Eric Curtin <ericcurti...@gmail.com>

diff --git a/tools/usb/usbip/src/usbip_detach.c 
b/tools/usb/usbip/src/usbip_detach.c
index 05c6d15..9db9d21 100644
--- a/tools/usb/usbip/src/usbip_detach.c
+++ b/tools/usb/usbip/src/usbip_detach.c
@@ -47,7 +47,9 @@ static int detach_port(char *port)
        uint8_t portnum;
        char path[PATH_MAX+1];
 
-       for (unsigned int i = 0; i < strlen(port); i++)
+       unsigned int port_len = strlen(port);
+
+       for (unsigned int i = 0; i < port_len; i++)
                if (!isdigit(port[i])) {
                        err("invalid port %s", port);
                        return -1;

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to