There were two modules in controller mac_cache and mac-learn, both of
them did very similar thing with pretty big overlap. The goal of the
series is to consolidate and merge both of those modules into single
one. That will reduce the duplication and should make it easier for
future updates to MAC binding, FDB or packet buffering functionality.

There is also fix to properly handle tunnel_key change for LSP, LRP,
LR and LS. This was inconsistent and could lead to wrong flows being
still present even after the tunnel key change. This is not a huge
issue because the tunnel_key is rarelyt changed during runtime.

Ales Musil (4):
  northd, controller: Handle tunnel_key change consistently.
  controller: Rename mac_cache to to mac-cache.
  controller: Merge the mac-cache and mac-learn.
  controller: Use datapath key for the mac cache thresholds.

 controller/automake.mk      |   6 +-
 controller/binding.c        |  13 +-
 controller/mac-cache.c      | 745 ++++++++++++++++++++++++++++++++++++
 controller/mac-cache.h      | 210 ++++++++++
 controller/mac-learn.c      | 482 -----------------------
 controller/mac-learn.h      | 145 -------
 controller/mac_cache.c      | 547 --------------------------
 controller/mac_cache.h      | 124 ------
 controller/ovn-controller.c | 214 +++++++----
 controller/pinctrl.c        | 165 ++++----
 controller/statctrl.c       |   7 +-
 controller/statctrl.h       |   2 +-
 northd/northd.c             |   7 +
 tests/ovn.at                |  56 ++-
 14 files changed, 1253 insertions(+), 1470 deletions(-)
 create mode 100644 controller/mac-cache.c
 create mode 100644 controller/mac-cache.h
 delete mode 100644 controller/mac-learn.c
 delete mode 100644 controller/mac-learn.h
 delete mode 100644 controller/mac_cache.c
 delete mode 100644 controller/mac_cache.h

-- 
2.44.0

_______________________________________________
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Reply via email to