[jira] [Commented] (MAILBOX-11) MailboxQuery ignore namespace

2015-06-03 Thread Tellier Benoit (JIRA)

[ 
https://issues.apache.org/jira/browse/MAILBOX-11?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=14570541#comment-14570541
 ] 

Tellier Benoit commented on MAILBOX-11:
---

I think you made a mistake. File that were not commited are :

 create mode 100644 
memory/src/test/java/org/apache/james/mailbox/inmemory/InMemoryMailboxMapperTest.java
 create mode 100644 
store/src/test/java/org/apache/james/mailbox/store/StoreMailboxManagerTest.java

File you commited are :

Added:

james/mailbox/trunk/memory/src/test/java/org/apache/james/mailbox/inmemory/mail/

james/mailbox/trunk/store/src/test/java/org/apache/james/mailbox/store/StoreMailboxManager.java

I can not build on trunk because StoreMailboxManager is duplicated in a 
package, and there is still no tests for both InMemoryMailboxMapper and for 
StoreMailboxManager.

Maybe things can be easier for you if we uses our Github integration tool. Do 
you want us to open the PR on Github corresponding to our uploaded awaiting 
patchs ?

There is several advantages for you :
 - It preserve our Git history.
 - You can do the review on GitHub
 - Once done, you can't forget files, you just need to run one command.

Regards,

Benoit

 MailboxQuery ignore namespace
 -

 Key: MAILBOX-11
 URL: https://issues.apache.org/jira/browse/MAILBOX-11
 Project: James Mailbox
  Issue Type: Bug
 Environment: Linux, JDK 1.6
Reporter: François-Denis Gonthier
Assignee: Eric Charles
 Fix For: 0.6

 Attachments: 
 0001-MAILBOX-11-Add-filters-on-namespace-and-user-for-sea.patch


 MailboxQuery doesn't pay any attention to namespace of the mailbox it is 
 based on. For example, Mozilla Thunderbird might to mailbox search with 
 expressions like #private.%. That expression is passed directly to the 
 isExpressionMatch method of the MailboxQuery class. This has obviously 
 incorrect results.
 Arguments to the isExpressionMatch method should be parsed to separate the 
 namespace from the mailbox name or isExpressionMatch should do the parsing 
 itself. In that case the argument name should be renamed to something like 
 'searchExpression' instead of 'name' which doesn't convey the right meaning.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

-
To unsubscribe, e-mail: server-dev-unsubscr...@james.apache.org
For additional commands, e-mail: server-dev-h...@james.apache.org



Jenkins build is still unstable: james-server-trunk » Apache James :: Server :: POP3 #5270

2015-06-03 Thread Apache Jenkins Server
See 
https://builds.apache.org/job/james-server-trunk/org.apache.james$james-server-protocols-pop3/5270/


-
To unsubscribe, e-mail: server-dev-unsubscr...@james.apache.org
For additional commands, e-mail: server-dev-h...@james.apache.org



Jenkins build is still unstable: james-server-trunk #5270

2015-06-03 Thread Apache Jenkins Server
See https://builds.apache.org/job/james-server-trunk/5270/


-
To unsubscribe, e-mail: server-dev-unsubscr...@james.apache.org
For additional commands, e-mail: server-dev-h...@james.apache.org



svn commit: r1683360 - in /james/hupa/trunk: client/src/test/java/org/apache/hupa/client/mock/ mock/src/main/java/org/apache/hupa/server/guice/ mock/src/main/java/org/apache/hupa/server/mock/ server/s

2015-06-03 Thread dongxu
Author: dongxu
Date: Wed Jun  3 15:07:09 2015
New Revision: 1683360

URL: http://svn.apache.org/r1683360
Log:
remove some warnings for the source code.

Modified:

james/hupa/trunk/client/src/test/java/org/apache/hupa/client/mock/MockMessageSendDisplay.java

james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/guice/AbstractGuiceTestModule.java

james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/mock/MockConstants.java

james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/mock/MockHttpSession.java

james/hupa/trunk/server/src/main/java/org/apache/hupa/server/service/GetMessageDetailsServiceImpl.java

james/hupa/trunk/server/src/test/java/org/apache/hupa/server/integration/StoreBugTest.java

james/hupa/trunk/server/src/test/java/org/apache/hupa/server/utils/TestUtils.java

james/hupa/trunk/widgets/src/main/java/org/apache/hupa/widgets/editor/ColorPicker.java

james/hupa/trunk/widgets/src/main/java/org/apache/hupa/widgets/editor/Editor.java

james/hupa/trunk/widgets/src/main/java/org/apache/hupa/widgets/editor/FontPicker.java

james/hupa/trunk/widgets/src/main/java/org/apache/hupa/widgets/ui/MultiValueSuggestArea.java

Modified: 
james/hupa/trunk/client/src/test/java/org/apache/hupa/client/mock/MockMessageSendDisplay.java
URL: 
http://svn.apache.org/viewvc/james/hupa/trunk/client/src/test/java/org/apache/hupa/client/mock/MockMessageSendDisplay.java?rev=1683360r1=1683359r2=1683360view=diff
==
--- 
james/hupa/trunk/client/src/test/java/org/apache/hupa/client/mock/MockMessageSendDisplay.java
 (original)
+++ 
james/hupa/trunk/client/src/test/java/org/apache/hupa/client/mock/MockMessageSendDisplay.java
 Wed Jun  3 15:07:09 2015
@@ -27,7 +27,6 @@ import org.apache.hupa.widgets.ui.HasEna
 
 import com.google.gwt.event.dom.client.HasClickHandlers;
 import com.google.gwt.event.dom.client.HasFocusHandlers;
-import com.google.gwt.user.client.TakesValue;
 import com.google.gwt.user.client.ui.Focusable;
 import com.google.gwt.user.client.ui.HasHTML;
 import com.google.gwt.user.client.ui.HasText;

Modified: 
james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/guice/AbstractGuiceTestModule.java
URL: 
http://svn.apache.org/viewvc/james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/guice/AbstractGuiceTestModule.java?rev=1683360r1=1683359r2=1683360view=diff
==
--- 
james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/guice/AbstractGuiceTestModule.java
 (original)
+++ 
james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/guice/AbstractGuiceTestModule.java
 Wed Jun  3 15:07:09 2015
@@ -75,7 +75,8 @@ import com.google.inject.name.Named;
  */
 public abstract class AbstractGuiceTestModule extends AbstractModule{
 
-protected static class TestUser extends UserImpl {
+@SuppressWarnings(serial)
+   protected static class TestUser extends UserImpl {
 
 @Inject
 public TestUser(@Named(Username) String username,

Modified: 
james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/mock/MockConstants.java
URL: 
http://svn.apache.org/viewvc/james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/mock/MockConstants.java?rev=1683360r1=1683359r2=1683360view=diff
==
--- 
james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/mock/MockConstants.java
 (original)
+++ 
james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/mock/MockConstants.java
 Wed Jun  3 15:07:09 2015
@@ -33,7 +33,8 @@ public class MockConstants {
 
 public static String SESSION_ID = MockID;
 
-public final static Settings mockSettings = new SettingsImpl() {
+@SuppressWarnings(serial)
+   public final static Settings mockSettings = new SettingsImpl() {
 {
 setInboxFolderName(MockIMAPStore.MOCK_INBOX_FOLDER);
 setSentFolderName(MockIMAPStore.MOCK_SENT_FOLDER);
@@ -69,7 +70,8 @@ public class MockConstants {
 }
 };
 
-public final static User mockUser = new UserImpl() {
+@SuppressWarnings(serial)
+   public final static User mockUser = new UserImpl() {
 {
 setName(MockIMAPStore.MOCK_LOGIN);
 setPassword(MockIMAPStore.MOCK_LOGIN);

Modified: 
james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/mock/MockHttpSession.java
URL: 
http://svn.apache.org/viewvc/james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/mock/MockHttpSession.java?rev=1683360r1=1683359r2=1683360view=diff
==
--- 
james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/mock/MockHttpSession.java
 (original)
+++ 
james/hupa/trunk/mock/src/main/java/org/apache/hupa/server/mock/MockHttpSession.java
 Wed Jun  3 15:07:09 2015
@@ -50,7 +50,7 @@ public class MockHttpSession