Re: RFR: 8324632: Update Zlib Data Compression Library to Version 1.3.1

2024-01-29 Thread Alan Bateman
On Mon, 29 Jan 2024 16:57:00 GMT, Lance Andersen wrote: > Hi all, > > Please review this PR which updates zlib from 1.3 to 1.3.1 in OpenJDK > > The [Zlib Data Compression Library](https://github.com/madler/zlib) has > released Zlib 1.3.1 on January 24, 2024. > > There are a [small number of

Re: RFR: 8321274: Rename ZipEntry.extraAttributes to ZipEntry.externalAttributes

2024-01-29 Thread Jaikiran Pai
On Mon, 4 Dec 2023 15:34:34 GMT, Eirik Bjørsnøs wrote: > Please consider this PR which suggests we rename `ZipEntry.extraAttributes` > to `ZipEntry.externalAttributes`. > > This field was introduced in > [JDK-8218021](https://bugs.openjdk.org/browse/JDK-8218021), originally under > the name

Withdrawn: 8321274: Rename ZipEntry.extraAttributes to ZipEntry.externalAttributes

2024-01-29 Thread duke
On Mon, 4 Dec 2023 15:34:34 GMT, Eirik Bjørsnøs wrote: > Please consider this PR which suggests we rename `ZipEntry.extraAttributes` > to `ZipEntry.externalAttributes`. > > This field was introduced in > [JDK-8218021](https://bugs.openjdk.org/browse/JDK-8218021), originally under > the name

Re: RFR: 8200559: Java agents doing instrumentation need a means to define auxiliary classes [v2]

2024-01-29 Thread Alexander Kriegisch
On Mon, 29 Jan 2024 14:31:10 GMT, Andrew Dinn wrote: > > Bytecode transformation should not be rocket science, but it progressively > > is developing in that direction. > > Hmm? Bytecode transformation of the JDK runtime implementation is a lot more > complicated than your comments seem to

Re: RFR: 8315487: Security Providers Filter [v6]

2024-01-29 Thread Martin Balao
> In addition to the goals, scope, motivation, specification and requirement > notes in [JDK-8315487](https://bugs.openjdk.org/browse/JDK-8315487), we would > like to describe the most relevant decisions taken during the implementation > of this enhancement. These notes are organized by

Re: RFR: 8303374: Implement JEP 455: Primitive Types in Patterns, instanceof, and switch (Preview) [v56]

2024-01-29 Thread Aggelos Biboudis
> This is the proposed patch for Primitive types in patterns, instanceof, and > switch (Preview). > > Draft spec here: https://cr.openjdk.org/~abimpoudis/instanceof/latest/ Aggelos Biboudis has updated the pull request incrementally with one additional commit since the last revision:

RFR: 8324858: [vectorapi] Bounds checking issues when accessing memory segments

2024-01-29 Thread Paul Sandoz
The implementation of method `VectorSpecies::fromMemorySegment`, in `AbstractSpecies::fromMemorySegment`, neglects to perform bounds checks on the offset argument when the method is compiled by C2 (bounds checks are performed when interpreted and by C1). This is an oversight and explicit

Re: RFR: 8303374: Implement JEP 455: Primitive Types in Patterns, instanceof, and switch (Preview) [v55]

2024-01-29 Thread Vicente Romero
On Fri, 26 Jan 2024 18:02:58 GMT, Aggelos Biboudis wrote: >> This is the proposed patch for Primitive types in patterns, instanceof, and >> switch (Preview). >> >> Draft spec here: https://cr.openjdk.org/~abimpoudis/instanceof/latest/ > > Aggelos Biboudis has updated the pull request

Re: RFR: JDK-8263261 Extend String::translateEscapes to support unicode escapes [v14]

2024-01-29 Thread Jim Laskey
> Currently String::translateEscapes does not support unicode escapes, reported > as a IllegalArgumentException("Invalid escape sequence: ..."). > String::translateEscapes should translate unicode escape sequences to provide > full coverage, Jim Laskey has updated the pull request

Re: RFR: JDK-8263261 Extend String::translateEscapes to support unicode escapes [v13]

2024-01-29 Thread ExE Boss
On Fri, 26 Jan 2024 17:36:52 GMT, Jim Laskey wrote: >> Currently String::translateEscapes does not support unicode escapes, >> reported as a IllegalArgumentException("Invalid escape sequence: ..."). >> String::translateEscapes should translate unicode escape sequences to >> provide full

Re: RFR: 8323601: Improve LayoutPath.PathElement::toString [v2]

2024-01-29 Thread Maurizio Cimadamore
On Mon, 29 Jan 2024 17:22:07 GMT, Per Minborg wrote: >> Correct. Additional logic is needed to form a correct C syntax. It would be >> possible to provide a method that does this. > > We could add such a method under another issue > (https://bugs.openjdk.org/browse/JDK-8323746) because it will

Re: RFR: JDK-8263261 Extend String::translateEscapes to support unicode escapes [v13]

2024-01-29 Thread Jim Laskey
On Fri, 26 Jan 2024 17:36:52 GMT, Jim Laskey wrote: >> Currently String::translateEscapes does not support unicode escapes, >> reported as a IllegalArgumentException("Invalid escape sequence: ..."). >> String::translateEscapes should translate unicode escape sequences to >> provide full

Re: RFR: 8323621: JDK build should exclude snippet class in java.lang.foreign [v2]

2024-01-29 Thread Maurizio Cimadamore
On Mon, 29 Jan 2024 14:03:42 GMT, Per Minborg wrote: >> This PR proposes to remove the snippet files in >> `java/lang/foreign/snippet-files` from the build. > > Per Minborg has updated the pull request incrementally with one additional > commit since the last revision: > > Correct path to

Re: RFR: JDK-8263261 Extend String::translateEscapes to support unicode escapes [v13]

2024-01-29 Thread Naoto Sato
On Fri, 26 Jan 2024 17:36:52 GMT, Jim Laskey wrote: >> Currently String::translateEscapes does not support unicode escapes, >> reported as a IllegalArgumentException("Invalid escape sequence: ..."). >> String::translateEscapes should translate unicode escape sequences to >> provide full

Re: RFR: 8324632: Update Zlib Data Compression Library to Version 1.3.1

2024-01-29 Thread Lance Andersen
On Mon, 29 Jan 2024 17:15:25 GMT, Alan Bateman wrote: > @LanceAndersen Can you confirm that there are no changes to the 1.3..1.3.1 > diffs? @AlanBateman, yes that is correct, there are no OpenJDK specific changes, it is a straight port of the zlib 1.3.1 changes to our implementation

Re: RFR: 8323601: Improve LayoutPath.PathElement::toString [v3]

2024-01-29 Thread Per Minborg
> This PR proposes to add an improved Improve > `LayoutPath.PathElement::toString` method simplifying debugging. > > Opinions and suggestions for `static PathElement sequenceElement(long start, > long step)` are welcome. Per Minborg has updated the pull request with a new target base due to a

Re: RFR: 8323601: Improve LayoutPath.PathElement::toString [v2]

2024-01-29 Thread Per Minborg
On Tue, 16 Jan 2024 09:10:04 GMT, Per Minborg wrote: >> src/java.base/share/classes/java/lang/foreign/MemoryLayout.java line 958: >> >>> 956: return new >>> LayoutPath.PathElementImpl(PathKind.DEREF_ELEMENT, >>> 957: LayoutPath::derefElement, >>> 958:

Re: RFR: 8324632: Update Zlib Data Compression Library to Version 1.3.1

2024-01-29 Thread Iris Clark
On Mon, 29 Jan 2024 16:57:00 GMT, Lance Andersen wrote: > Hi all, > > Please review this PR which updates zlib from 1.3 to 1.3.1 in OpenJDK > > The [Zlib Data Compression Library](https://github.com/madler/zlib) has > released Zlib 1.3.1 on January 24, 2024. > > There are a [small number of

Re: RFR: 8324632: Update Zlib Data Compression Library to Version 1.3.1

2024-01-29 Thread Alan Bateman
On Mon, 29 Jan 2024 16:57:00 GMT, Lance Andersen wrote: > Hi all, > > Please review this PR which updates zlib from 1.3 to 1.3.1 in OpenJDK > > The [Zlib Data Compression Library](https://github.com/madler/zlib) has > released Zlib 1.3.1 on January 24, 2024. > > There are a [small number of

Integrated: 8324681: Replace NULL with nullptr in HotSpot jtreg test native code files

2024-01-29 Thread Coleen Phillimore
On Fri, 26 Jan 2024 16:40:32 GMT, Coleen Phillimore wrote: > This mechanically replaces NULL with nullptr in hpp/cpp native files in test > native code. This didn't attempt to change NULL in comments to say null > because nullptr is generally the right thing for the comment to say. It does

Re: RFR: 8324681: Replace NULL with nullptr in HotSpot jtreg test native code files [v5]

2024-01-29 Thread Coleen Phillimore
On Mon, 29 Jan 2024 13:47:10 GMT, Coleen Phillimore wrote: >> This mechanically replaces NULL with nullptr in hpp/cpp native files in test >> native code. This didn't attempt to change NULL in comments to say null >> because nullptr is generally the right thing for the comment to say. It >>

RFR: 8324632: Update Zlib Data Compression Library to Version 1.3.1

2024-01-29 Thread Lance Andersen
Hi all, Please review this PR which updates zlib from 1.3 to 1.3.1 in OpenJDK The [Zlib Data Compression Library](https://github.com/madler/zlib) has released Zlib 1.3.1 on January 24, 2024. There are a [small number of updates](https://github.com/madler/zlib/compare/v1.3.1..v1.3) between 1.3

Re: RFR: 8303374: Implement JEP 455: Primitive Types in Patterns, instanceof, and switch (Preview) [v55]

2024-01-29 Thread Jan Lahoda
On Fri, 26 Jan 2024 18:02:58 GMT, Aggelos Biboudis wrote: >> This is the proposed patch for Primitive types in patterns, instanceof, and >> switch (Preview). >> >> Draft spec here: https://cr.openjdk.org/~abimpoudis/instanceof/latest/ > > Aggelos Biboudis has updated the pull request

Re: RFR: JDK-8263261 Extend String::translateEscapes to support unicode escapes [v13]

2024-01-29 Thread Roger Riggs
On Fri, 26 Jan 2024 17:36:52 GMT, Jim Laskey wrote: >> Currently String::translateEscapes does not support unicode escapes, >> reported as a IllegalArgumentException("Invalid escape sequence: ..."). >> String::translateEscapes should translate unicode escape sequences to >> provide full

Re: RFR: 8200559: Java agents doing instrumentation need a means to define auxiliary classes [v2]

2024-01-29 Thread Andrew Dinn
On Sat, 27 Jan 2024 05:11:28 GMT, Alexander Kriegisch wrote: > Bytecode transformation should not be rocket science, but it progressively is > developing in that direction. Hmm? Bytecode transformation of the JDK runtime implementation is a lot more complicated than your comments seem to

Re: RFR: 8200559: Java agents doing instrumentation need a means to define auxiliary classes [v2]

2024-01-29 Thread Rafael Winterhalter
On Fri, 16 Apr 2021 20:30:15 GMT, Rafael Winterhalter wrote: >> To allow agents the definition of auxiliary classes, an API is needed to >> allow this. Currently, this is often achieved by using `sun.misc.Unsafe` or >> `jdk.internal.misc.Unsafe` ever since the `defineClass` method was removed

Re: RFR: 8324681: Replace NULL with nullptr in HotSpot jtreg test native code files [v5]

2024-01-29 Thread Coleen Phillimore
On Mon, 29 Jan 2024 13:47:10 GMT, Coleen Phillimore wrote: >> This mechanically replaces NULL with nullptr in hpp/cpp native files in test >> native code. This didn't attempt to change NULL in comments to say null >> because nullptr is generally the right thing for the comment to say. It >>

Re: RFR: 8200559: Java agents doing instrumentation need a means to define auxiliary classes [v2]

2024-01-29 Thread Andrew Dinn
On Sun, 28 Jan 2024 22:33:01 GMT, Rafael Winterhalter wrote: > What stops people from supplying a fake instance? Wouldn't you need to "test > run" the instance first? Not necessarily. When the generated API implementation relies on the capabilities of class `Instrumentation` -- such as

Re: RFR: 8200559: Java agents doing instrumentation need a means to define auxiliary classes [v2]

2024-01-29 Thread Alan Bateman
On Mon, 29 Jan 2024 14:09:40 GMT, Andrew Dinn wrote: > What stops people from supplying a fake instance? Wouldn't you need to "test > run" the instance first? In passing, Instrumentation was a candidate to be sealed at one point as the only implementations should be in the java.instrument

Re: RFR: 8323621: JDK build should exclude snippet class in java.lang.foreign [v2]

2024-01-29 Thread Per Minborg
> This PR proposes to remove the snippet files in > `java/lang/foreign/snippet-files` from the build. Per Minborg has updated the pull request incrementally with one additional commit since the last revision: Correct path to excluded directory - Changes: - all:

Re: RFR: 8323621: JDK build should exclude snippet class in java.lang.foreign [v2]

2024-01-29 Thread Per Minborg
On Mon, 15 Jan 2024 13:27:25 GMT, Magnus Ihse Bursie wrote: >> If possible, we should simply exclude all files in directories that have `-` >> (minus sign) in their name; this is the intentional design to prevent javac >> from compiling those classes as package names cannot include `-`. > > I

Re: RFR: 8324681: Replace NULL with nullptr in HotSpot jtreg test native code files [v5]

2024-01-29 Thread Coleen Phillimore
> This mechanically replaces NULL with nullptr in hpp/cpp native files in test > native code. This didn't attempt to change NULL in comments to say null > because nullptr is generally the right thing for the comment to say. It does > attempt to change NULL to "null" rather than "nullptr" in

Re: RFR: 8323159: Consider adding some text re. memory zeroing in Arena::allocate [v5]

2024-01-29 Thread Per Minborg
On Sun, 28 Jan 2024 00:57:24 GMT, ExE Boss wrote: >> Per Minborg has updated the pull request incrementally with two additional >> commits since the last revision: >> >> - Update copyright year >> - Add test for zero-out > > test/jdk/java/foreign/TestScope.java line 150: > >> 148: } >>