Re: RFR: JDK-8325189: Enable this-escape javac warning in java.base

2024-02-03 Thread Alan Bateman
On Fri, 2 Feb 2024 23:36:41 GMT, Joe Darcy wrote: > After the "this-escape" lint warning was added to javac (JDK-8015831), the > base module was not updated to be able to compile with this warning enabled. > This PR makes the necessary changes to allow the base module to build with > the

Re: The common ForkJoinPool does not have any ForkJoinWorkerThread while tasks are submitted to the queue

2024-02-03 Thread Xiao Yu
Hi Jaikiran, Thanks a lot for replying. Our application is a client that communicates to the server for request/response. The client creates a secure (TLS) connection to the server, that is, on top of the SocketChannel, we implement a Wrapper class called SSLDataChannel for reading and writing.

Re: RFR: 8321274: Rename ZipEntry.extraAttributes to ZipEntry.externalAttributes [v2]

2024-02-03 Thread Eirik Bjørsnøs
On Fri, 2 Feb 2024 20:43:54 GMT, Lance Andersen wrote: > I think the proposed change above makes things clearer. Perhaps also make the > same change in zipfs as well while you are at it? I have pushed the rename to "ZipEntry.externalFileAttributes". Also renamed

Re: RFR: 8321274: Rename ZipEntry.extraAttributes to ZipEntry.externalAttributes [v3]

2024-02-03 Thread Eirik Bjørsnøs
> Please consider this PR which suggests we rename `ZipEntry.extraAttributes` > to `ZipEntry.externalAttributes`. > > This field was introduced in > [JDK-8218021](https://bugs.openjdk.org/browse/JDK-8218021), originally under > the name `ZipEntry.posixPerms`. >

Re: RFR: 8325169: Reduce String::indexOf overheads [v3]

2024-02-03 Thread Claes Redestad
> This patch streamlines and specializes various `String::indexOf` methods. > Mainly avoids the need for clamping and doing checks that are redundant in > almost all cases, moving the checks to the API boundary where they are > needed. > > This improves performance both at peak and during

Re: RFR: 8325169: Reduce String::indexOf overheads [v2]

2024-02-03 Thread Claes Redestad
On Fri, 2 Feb 2024 20:53:14 GMT, Claes Redestad wrote: >> This patch streamlines and specializes various `String::indexOf` methods. >> Mainly avoids the need for clamping and doing checks that are redundant in >> almost all cases, moving the checks to the API boundary where they are >>

Re: RFR: 8323746: Add PathElement hashCode and equals [v2]

2024-02-03 Thread ExE Boss
On Fri, 2 Feb 2024 07:41:16 GMT, Per Minborg wrote: >> This PR proposes to implement `hashCode()` and `equals()` methods for >> implementations of `PathElement`. >> >> In doing so, the previous `PathElementImpl` was removed and replaced in >> favor of distinct `record` implementations, each

Re: RFR: 8325152: Clarify specification of java.io.RandomAccessFile.setLength [v2]

2024-02-03 Thread Alan Bateman
On Fri, 2 Feb 2024 16:48:12 GMT, Brian Burkhalter wrote: >> Modify the specification verbiage of `java.io.RandomAccessFile.setLength` to >> account for the effect of the method on the file offset as returned by >> `getFilePointer`. > > Brian Burkhalter has updated the pull request

Re: RFR: 8323746: Add PathElement hashCode and equals [v2]

2024-02-03 Thread Maurizio Cimadamore
On Fri, 2 Feb 2024 07:41:16 GMT, Per Minborg wrote: >> This PR proposes to implement `hashCode()` and `equals()` methods for >> implementations of `PathElement`. >> >> In doing so, the previous `PathElementImpl` was removed and replaced in >> favor of distinct `record` implementations, each