Re: nxp imx8m CSI drivers

2020-07-28 Thread Martin Kepplinger
On 09.07.20 11:32, Martin Kepplinger wrote: > hi linux-media people, > > TL-DR: when exactly is "sd->entity.function == MEDIA_ENT_F_VID_MUX"? > > > I try to use the camera on our librem5-devkit (imx8mq): I try to use > only mainline drivers except for "mx

nxp imx8m CSI drivers

2020-07-09 Thread Martin Kepplinger
hi linux-media people, TL-DR: when exactly is "sd->entity.function == MEDIA_ENT_F_VID_MUX"? I try to use the camera on our librem5-devkit (imx8mq): I try to use only mainline drivers except for "mxc-mipi-csi2_yav" taken from linux-imx (which we can prepare to submit if a PoC works. This is the

[PATCH] tools: hv: hv_kvp_daemon: fix usage of realloc()

2017-09-13 Thread Martin Kepplinger
realloc() returns NULL in case it fails. Since we don't save the pointer in question elsewhere, we leak memory by assigning NULL to the original memory in the heap. realloc() doesn't free memory in case of failure, so let's do it manually. Signed-off-by: Martin Kepplinger <mart...@posteo

[PATCH v3] staging: vboxvideo: Kconfig: Fix typos in help text

2017-07-24 Thread Martin Kepplinger
This fixes typos in vboxvideo's help text. Most notably, "to builtin this module" becomes "to build this driver built-in to the kernel". Signed-off-by: Martin Kepplinger <mart...@posteo.de> --- revision history v3: Avoid a repetition of "t

[PATCH v2] staging: vboxvideo: Kconfig: Fix typos in help text

2017-07-24 Thread Martin Kepplinger
This fixes typos in vboxvideo's help text. Most notably, "to builtin this module" becomes "to build this driver built-in to the kernel". Signed-off-by: Martin Kepplinger <mart...@posteo.de> --- Thanks Dan. I actually also had the feeling that even though it's

[PATCH] staging: vboxvideo: Kconfig: Fix typos in help text

2017-07-24 Thread Martin Kepplinger
This fixes typos in vboxvideo's help text. Signed-off-by: Martin Kepplinger <mart...@posteo.de> --- drivers/staging/vboxvideo/Kconfig | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/vboxvideo/Kconfig b/drivers/staging/vboxvideo/Kconfig index a52746

[PATCH v6] add support for Freescale's MMA8653FC 10 bit accelerometer

2015-03-27 Thread Martin Kepplinger
From: Martin Kepplinger martin.kepplin...@theobroma-systems.com The MMA8653FC is a low-power, three-axis, capacitive micromachined accelerometer with 10 bits of resolution with flexible user-programmable options. Embedded interrupt functions enable overall power savings, by relieving the host

Re: [PATCH] staging: vt6656: Fix possible leak in vnt_download_firmware()

2015-02-12 Thread Martin Kepplinger
; + goto free_fw; for (ii = 0; ii fw-size; ii += FIRMWARE_CHUNK_SIZE) { length = min_t(int, fw-size - ii, FIRMWARE_CHUNK_SIZE); looks good to me, although somebody else should review it too. feel free to add Reviewed-by: Martin Kepplinger mart...@posteo.de if applicable

[PATCH] rtl8192u: remove typedef

2014-09-07 Thread Martin Kepplinger
remove a typedef that is not even really used. Signed-off-by: Martin Kepplinger mart...@posteo.de --- builds in next-20140905. drivers/staging/rtl8192u/r8192U_core.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8192u/r8192U_core.c b/drivers

[PATCHv2] staging: rtl8192u: checkpatch: do not use C99 // comments

2014-08-10 Thread Martin Kepplinger
at it. Signed-off-by: Martin Kepplinger mart...@posteo.de --- Yes, there were changes in the meantime. This applies to -next20140808 and builds. thanks. drivers/staging/rtl8192u/r8192U_core.c | 757 +--- 1 file changed, 408 insertions(+), 349 deletions(-) diff --git a/drivers

[PATCHv2] staging: media: as102: replace custom dprintk() with dev_dbg()

2014-08-04 Thread Martin Kepplinger
remove dprintk() and replace it with dev_dbg() in order to use the common kernel coding style. Signed-off-by: Martin Kepplinger mart...@posteo.de --- Thanks Dan. And since it continues to succeed if (dev == NULL), differntiate if (dev) or not. drivers/staging/media/as102/as102_drv.c | 15

[PATCHv3] staging: media: as102: replace custom dprintk() with dev_dbg()

2014-08-04 Thread Martin Kepplinger
remove dprintk() and replace it with dev_dbg() or pr_debug() in order to use the common kernel coding style. Signed-off-by: Martin Kepplinger mart...@posteo.de --- Thanks for looking at it. So this doesn't add anything and actually does what it says. If I haven't understood what you meant

[PATCH] staging: media: as102: replace custom dprintk() with dev_dbg()

2014-08-03 Thread Martin Kepplinger
remove dprintk() and replace it with dev_dbg() in order to use the common kernel coding style. Signed-off-by: Martin Kepplinger mart...@posteo.de --- I don't have the device but this builds. I think this is ok when it gets reviewed. applies to -next20140801 drivers/staging/media/as102

[PATCH] staging: rtl8192u: checkpatch: do not use C99 // comments

2014-08-03 Thread Martin Kepplinger
-by: Martin Kepplinger mart...@posteo.de --- This changes only a part of rtl8192u's comments. When this is desired, one can go about and change the rest of the driver. build-tested. applies to -next20140801 drivers/staging/rtl8192u/r8180_93cx6.c | 12 +- drivers/staging/rtl8192u/r8192U_core.c | 757

[PATCH] staging: lustre: use NULL instead of 0 for non-integers

2014-08-03 Thread Martin Kepplinger
This fixes sparse errors where 0 is used for non-integers. Signed-off-by: Martin Kepplinger mart...@posteo.de --- applies to -next20140802 drivers/staging/lustre/lnet/lnet/api-ni.c |4 +- drivers/staging/lustre/lustre/fld/fld_request.c|2 +- drivers/staging/lustre/lustre

[PATCH v2] staging: vt6655: preserve address space in ethtool_ioctl()

2014-06-17 Thread Martin Kepplinger
Fix the sparse error: cast removes address space of expression and add __user annotation to the driver's ethtool_ioctl(). Signed-off-by: Martin Kepplinger mart...@posteo.de --- Beyond that, how would you include socket.c's ethtool_ioctl() here? thanks for looking at these tiny changes. drivers

[PATCH v3] staging: vt6655: preserve address space in ethtool_ioctl()

2014-06-17 Thread Martin Kepplinger
Fix the sparse error: cast removes address space of expression and add __user annotation to the driver's ethtool_ioctl(). Signed-off-by: Martin Kepplinger mart...@posteo.de --- I think I forgot to change the declaration on top. drivers/staging/vt6655/device_main.c |6 +++--- 1 file changed

[PATCH v2] staging: vt6655: remove unnecessary typedef struct.

2014-06-16 Thread Martin Kepplinger
Remove a totally unnecessary typedef and rename it to lowercase. This is more readable now. Signed-off-by: Martin Kepplinger mart...@posteo.de --- so in that way, one could change the more heavily used typedefs as well. thanks for your review. drivers/staging/vt6655/card.c |2 +- drivers

[PATCH] staging: vt6655: remove unnecessary typedef struct.

2014-06-13 Thread Martin Kepplinger
Remove a totally unnecessary typedef. This is more readable now. Signed-off-by: Martin Kepplinger mart...@posteo.de --- applies to next-20140611 drivers/staging/vt6655/card.c |2 +- drivers/staging/vt6655/device.h |6 +++--- drivers/staging/vt6655/wmgr.c |2 +- 3 files changed

[PATCH][RESEND] staging: winbond: use dev_err() instead of printk()

2014-05-19 Thread Martin Kepplinger
For obvious error messages, use dev_err() in order to provide userspace with more useful information and use the common kernel coding style. Signed-off-by: Martin Kepplinger mart...@posteo.de --- i just waited a week or so. this applies to next-20140516. greetings from Linuxdays Vienna, Austria

[PATCH] staging: media: as102: replace custom dprintk() with dev_dbg()

2014-05-17 Thread Martin Kepplinger
don't reinvent dev_dbg(). use the common kernel coding style. Signed-off-by: Martin Kepplinger mart...@posteo.de --- this applies to next-20140516. drivers/staging/media/as102/as102_drv.c | 11 +++ 1 file changed, 7 insertions(+), 4 deletions(-) diff --git a/drivers/staging/media

[PATCHv2] staging: media: as102: replace custom dprintk() with dev_dbg()

2014-05-17 Thread Martin Kepplinger
don't reinvent dev_dbg(). remove dprintk() in as102_drv.c. use the common kernel coding style. Signed-off-by: Martin Kepplinger mart...@posteo.de --- this applies to next-20140516. any more suggestions? more cleanup can be done when dprintk() is completely gone. drivers/staging/media/as102

[PATCH] staging: winbond: use dev_err() instead of printk()

2014-05-08 Thread Martin Kepplinger
For obvious error messages, use dev_err() in order to provide userspace with more useful information and use the common kernel coding style. Signed-off-by: Martin Kepplinger mart...@posteo.de --- this applies to v3.15-rc4 greetings from Linuxdays Vienna, Austria drivers/staging/winbond

[PATCH] staging: rtl8192u: initialize array in C compliant way

2014-05-06 Thread Martin Kepplinger
Don't list elements to initialize. Remaining elements of a partly initialized array are set to zero. Sparse complained here. Signed-off-by: Martin Kepplinger mart...@posteo.de --- drivers/staging/rtl8192u/ieee80211/rtl819x_TSProc.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

[PATCH] staging: dgnc: fix compile warning frame size is larger than 1024 bytes

2014-05-06 Thread Martin Kepplinger
fix following warning by dynamically allocating memory: dgnc_tty.c:583:1: warning: the frame size of 1060 bytes is larger than 1024 bytes [-Wframe-larger-than=] Signed-off-by: Martin Kepplinger mart...@posteo.de --- This is more of a question. Is this a desired solution to fixing such a frame

Re: [PATCH] staging: dgnc: fix compile warning frame size is larger than 1024 bytes

2014-05-06 Thread Martin Kepplinger
Am 2014-05-06 15:33, schrieb Dan Carpenter: On Tue, May 06, 2014 at 02:41:37PM +0200, Martin Kepplinger wrote: fix following warning by dynamically allocating memory: dgnc_tty.c:583:1: warning: the frame size of 1060 bytes is larger than 1024 bytes [-Wframe-larger-than=] Signed-off

[RESEND PATCH] staging: dgnc: use dev_err() instead of printk()

2014-05-05 Thread Martin Kepplinger
Use dev_err() instead of printk() and remove dgnc: from the message. This should provide userspace with more useful information and use the common kernel coding style. Signed-off-by: Martin Kepplinger mart...@posteo.de --- drivers/staging/dgnc/dgnc_sysfs.c |2 +- 1 file changed, 1 insertion

Re: [RESEND PATCH] staging: dgnc: use dev_err() instead of printk()

2014-05-05 Thread Martin Kepplinger
Am 2014-05-05 13:35, schrieb Dan Carpenter: On Mon, May 05, 2014 at 12:29:39PM +0200, Martin Kepplinger wrote: Use dev_err() instead of printk() and remove dgnc: from the message. This should provide userspace with more useful information and use the common kernel coding style. Whenever I

Re: [RESEND PATCH] staging: dgnc: use dev_err() instead of printk()

2014-05-05 Thread Martin Kepplinger
Am 2014-05-05 14:36, schrieb Dan Carpenter: On Mon, May 05, 2014 at 01:59:25PM +0200, Martin Kepplinger wrote: Am 2014-05-05 13:35, schrieb Dan Carpenter: On Mon, May 05, 2014 at 12:29:39PM +0200, Martin Kepplinger wrote: Use dev_err() instead of printk() and remove dgnc: from the message

[RESEND PATCH] staging: vt6656: make spin_lock_irq() human readable

2014-05-05 Thread Martin Kepplinger
Don't require FIRMWAREbDownload() to, first off, unlock a held lock. Thus do all locking in main_usb.c and hold it for a insignificantly shorter period of time. This makes the affected area significantly more readable though. Signed-off-by: Martin Kepplinger mart...@posteo.de --- I resend https

[PATCH v2] staging: rtl8821ae: mark pci_mem_start (and _end) as __iomem

2014-05-04 Thread Martin Kepplinger
Shared addresses can be marked as such. Signed-off-by: Martin Kepplinger mart...@posteo.de --- I guess that's what you meant. Thanks for your feedback! drivers/staging/rtl8821ae/wifi.h |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8821ae/wifi.h b

[PATCH] staging: rtl8821ae: mark pointer in pci_iounmap as __iomem

2014-05-03 Thread Martin Kepplinger
pci_iounmap is used that way in drivers/net/wireless/rtlwifi and this fixes sparse warnings. Signed-off-by: Martin Kepplinger mart...@posteo.de --- drivers/staging/rtl8821ae/pci.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8821ae/pci.c b/drivers

[PATCH] staging: rtl8187se: fix pointer and return statement's syntax

2014-04-09 Thread Martin Kepplinger
Use the common kernel coding style. Signed-off-by: Martin Kepplinger mart...@posteo.de --- noise from the eudyptula challenge. applies to next-20140408 as well as linus' current tree. drivers/staging/rtl8187se/ieee80211/ieee80211_tx.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions