On Wed, Feb 16, 2022 at 09:09:27PM -0600, Paul A. Clarke wrote:
> I see a couple of issues in my commit message, which I'll fix up before
> merging...

The uglification changes went in one spot too far and uglified also
the anem of function, posix_memalign should be called like that and
not a non-existent function instead of it.

Committed to trunk as obvious.

2022-02-18  Jakub Jelinek  <ja...@redhat.com>

        PR target/104257
        PR target/104598
        * config/rs6000/mm_malloc.h (_mm_malloc): Call posix_memalign
        rather than __posix_memalign.

--- gcc/config/rs6000/mm_malloc.h.jj    2022-02-18 12:38:05.729397896 +0100
+++ gcc/config/rs6000/mm_malloc.h       2022-02-18 17:16:52.251239933 +0100
@@ -47,7 +47,7 @@ _mm_malloc (size_t __size, size_t __alig
     return malloc (__size);
   if (__alignment < __vec_align)
     __alignment = __vec_align;
-  if (__posix_memalign (&__ptr, __alignment, __size) == 0)
+  if (posix_memalign (&__ptr, __alignment, __size) == 0)
     return __ptr;
   else
     return NULL;


        Jakub

Reply via email to