Re: [PATCH v18 3/3] vfio/nvgrace-gpu: Add vfio pci variant module for grace hopper

2024-02-19 Thread Zhi Wang
644 > index ..3ca8c187897a > --- /dev/null > +++ b/drivers/vfio/pci/nvgrace-gpu/Makefile > @@ -0,0 +1,3 @@ > +# SPDX-License-Identifier: GPL-2.0-only > +obj-$(CONFIG_NVGRACE_GPU_VFIO_PCI) += nvgrace-gpu-vfio-pci.o > +nvgrace-gpu-vfio-pci-y := main.o >

Re: [PATCH v17 3/3] vfio/nvgrace-gpu: Add vfio pci variant module for grace hopper

2024-02-07 Thread Zhi Wang
On Tue, 6 Feb 2024 04:31:23 +0530 wrote: > From: Ankit Agrawal > > NVIDIA's upcoming Grace Hopper Superchip provides a PCI-like device > for the on-chip GPU that is the logical OS representation of the > internal proprietary chip-to-chip cache coherent interconnect. > > The device is peculiar

Re: [PATCH] drm/gvt : fix error message typo

2018-10-05 Thread Zhi Wang
Hi: Thanks for the patches. :) Several places needs to be improved: 1. The prefix of the patch should be: "drm/i915/gvt:". 2. You can just cc the maintainers of gvt since the gvt is a sub-module of i915. 3. Better refine the tittle of the patch and also the commit message. An informative

Re: [PATCH] drm/gvt : fix error message typo

2018-10-05 Thread Zhi Wang
Hi: Thanks for the patches. :) Several places needs to be improved: 1. The prefix of the patch should be: "drm/i915/gvt:". 2. You can just cc the maintainers of gvt since the gvt is a sub-module of i915. 3. Better refine the tittle of the patch and also the commit message. An informative

Re: [PATCH RFC 0/4] Per-task PTI activation

2018-01-09 Thread Zhi Wang
Is is possible to put per-task PTI control interface into cgroup or other interfaces?  Enabling/disabling per-task PTI should be a decision from the system administrator not the application itself. On 2018/1/9 18:02, Willy Tarreau wrote: Hi Eric, On Tue, Jan 09, 2018 at 09:31:27AM -0600,

Re: [PATCH RFC 0/4] Per-task PTI activation

2018-01-09 Thread Zhi Wang
Is is possible to put per-task PTI control interface into cgroup or other interfaces?  Enabling/disabling per-task PTI should be a decision from the system administrator not the application itself. On 2018/1/9 18:02, Willy Tarreau wrote: Hi Eric, On Tue, Jan 09, 2018 at 09:31:27AM -0600,

Re: [PATCH] drm/i915/gvt: use ARRAY_SIZE

2017-10-23 Thread Zhi Wang
Thanks, applied! On 10/16/17 10:32, Jérémy Lefaure wrote: Using the ARRAY_SIZE macro improves the readability of the code. Also, it's useless to use a variable to store this constant calculated at compile time. Found with Coccinelle with the following semantic patch: @r depends on (org ||

Re: [PATCH] drm/i915/gvt: use ARRAY_SIZE

2017-10-23 Thread Zhi Wang
Thanks, applied! On 10/16/17 10:32, Jérémy Lefaure wrote: Using the ARRAY_SIZE macro improves the readability of the code. Also, it's useless to use a variable to store this constant calculated at compile time. Found with Coccinelle with the following semantic patch: @r depends on (org ||

Re: [PATCH] drm/i915/gvt: Clean up dead code in cmd_parser

2017-10-23 Thread Zhi Wang
Thanks, applied! :) On 10/16/17 06:32, Christos Gkekas wrote: Delete variables 'gma_bottom' that are set but never used. Signed-off-by: Christos Gkekas --- drivers/gpu/drm/i915/gvt/cmd_parser.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git

Re: [PATCH] drm/i915/gvt: Clean up dead code in cmd_parser

2017-10-23 Thread Zhi Wang
Thanks, applied! :) On 10/16/17 06:32, Christos Gkekas wrote: Delete variables 'gma_bottom' that are set but never used. Signed-off-by: Christos Gkekas --- drivers/gpu/drm/i915/gvt/cmd_parser.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git

Re: [kra...@redhat.com: Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf operations]

2017-06-23 Thread Zhi Wang
if we can extend that channel and notify the userspace application that guest framebuffer changed via that channel. So userspace application even doesn't need to call the ioctl periodically. :) If VM runs a single-buffered application. Thanks, Zhi. On Fri, 2017-06-23 at 15:49 +0800, Zhi Wang

Re: [kra...@redhat.com: Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf operations]

2017-06-23 Thread Zhi Wang
if we can extend that channel and notify the userspace application that guest framebuffer changed via that channel. So userspace application even doesn't need to call the ioctl periodically. :) If VM runs a single-buffered application. Thanks, Zhi. On Fri, 2017-06-23 at 15:49 +0800, Zhi Wang

Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf operations

2017-06-23 Thread Zhi Wang
Hi: Thanks for the discussions! If the userspace application has already maintained a LRU list, it looks like we don't need generation anymore, as userspace application will lookup the guest framebuffer from the LRU list by "offset". No matter how, it would know if this is a new guest

Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf operations

2017-06-23 Thread Zhi Wang
Hi: Thanks for the discussions! If the userspace application has already maintained a LRU list, it looks like we don't need generation anymore, as userspace application will lookup the guest framebuffer from the LRU list by "offset". No matter how, it would know if this is a new guest

Re: [PATCH] mm: mempool: Factor out mempool_refill()

2015-12-15 Thread Zhi Wang
would have much more available elements to allocate. After the refactor, mempool_refill() can also executes with mempool_resize() /mempool_alloc/mempool_free() or another mempool_refill(). Signed-off-by: Zhi Wang Who is going to call that function? Adding a new interace usually comes with a user,

Re: [PATCH] mm: mempool: Factor out mempool_refill()

2015-12-15 Thread Zhi Wang
would have much more available elements to allocate. After the refactor, mempool_refill() can also executes with mempool_resize() /mempool_alloc/mempool_free() or another mempool_refill(). Signed-off-by: Zhi Wang <zhi.a.w...@intel.com> Who is going to call that function? Adding a new interace usua

[PATCH] mm: mempool: Factor out mempool_refill()

2015-12-12 Thread Zhi Wang
the refactor, mempool_refill() can also executes with mempool_resize() /mempool_alloc/mempool_free() or another mempool_refill(). Signed-off-by: Zhi Wang --- include/linux/mempool.h | 1 + mm/mempool.c| 61 - 2 files changed, 46 insertions

[PATCH] mm: mempool: Factor out mempool_refill()

2015-12-12 Thread Zhi Wang
the refactor, mempool_refill() can also executes with mempool_resize() /mempool_alloc/mempool_free() or another mempool_refill(). Signed-off-by: Zhi Wang <zhi.a.w...@intel.com> --- include/linux/mempool.h | 1 + mm/mempool.c| 61 - 2

[PATCH] mm: mempool: Factor out mempool_refill()

2015-12-11 Thread Zhi Wang
the refactor, mempool_refill() can also executes with mempool_resize() /mempool_alloc/mempool_free() or another mempool_refill(). Signed-off-by: Zhi Wang --- include/linux/mempool.h | 1 + mm/mempool.c| 61 - 2 files changed, 46 insertions

[PATCH] mm: mempool: Factor out mempool_refill()

2015-12-11 Thread Zhi Wang
the refactor, mempool_refill() can also executes with mempool_resize() /mempool_alloc/mempool_free() or another mempool_refill(). Signed-off-by: Zhi Wang <zhi.a.w...@intel.com> --- include/linux/mempool.h | 1 + mm/mempool.c| 61 - 2

[PATCH] mm: mempool: Factor out mempool_refill()

2015-12-10 Thread Zhi Wang
the refactor, mempool_refill() can also executes with mempool_resize() /mempool_alloc/mempool_free() or another mempool_refill(). Signed-off-by: Zhi Wang --- include/linux/mempool.h | 1 + mm/mempool.c| 61 - 2 files changed, 46 insertions

[PATCH] mm: mempool: Factor out mempool_refill()

2015-12-10 Thread Zhi Wang
the refactor, mempool_refill() can also executes with mempool_resize() /mempool_alloc/mempool_free() or another mempool_refill(). Signed-off-by: Zhi Wang <zhi.a.w...@intel.com> --- include/linux/mempool.h | 1 + mm/mempool.c| 61 - 2