Re: [PATCH] modules: Drop the .export_symbol section from the final modules

2024-05-06 Thread Ainux Wang
Hi, everyone: Could someone review this patch? Best regards, Ainux Wang. 于2024年4月17日周三 13:35写道: > > From: Wang Yao > > Commit ddb5cdbafaaa ("kbuild: generate KSYMTAB entries by modpost") > forget drop the .export_symbol section from the final modules. > > Signed-off-by: Wang Yao > --- >

[PATCH 1/1] livepatch: Rename KLP_* to KLP_TRANSITION_*

2024-05-06 Thread zhangwarden
From: Wardenjohn The original macros of KLP_* is about the state of the transition. Rename macros of KLP_* to KLP_TRANSITION_* to fix the confusing description of klp transition state. Signed-off-by: Wardenjohn --- include/linux/livepatch.h | 6 ++-- init/init_task.c | 2 +-

[PATCH 0/1] *** Rename KLP_* to KLP_TRANSITION_* ***

2024-05-06 Thread zhangwarden
From: Wardenjohn This is the v3 of commit " livepatch: Rename KLP_* to KLP_TRANSITION_* " with the suggestion of @Josh v1 -> v2 : Use KLP_TRANSITION_* to replace marcos KLP_* v2 -> v3 : Remove the unnecessary comment and fix one typo in the code. Wardenjohn (1): livepatch: Rename KLP_* to

Re: [PATCH 0/1] *** Replace KLP_* to KLP_TRANSITION_* ***

2024-05-06 Thread Josh Poimboeuf
On Tue, May 07, 2024 at 10:56:09AM +0800, zhang warden wrote: > > > > On May 7, 2024, at 10:41, Josh Poimboeuf wrote: > > > > On Tue, May 07, 2024 at 10:21:40AM +0800, zhang warden wrote: > >> > >> > >>> > >>> transition state. With this marcos renamed, comments are not > >>> necessary at

Re: [PATCH v13 12/14] x86/sgx: Turn on per-cgroup EPC reclamation

2024-05-06 Thread Haitao Huang
On Mon, 06 May 2024 19:10:42 -0500, Huang, Kai wrote: On 1/05/2024 7:51 am, Haitao Huang wrote: static void sgx_reclaim_pages_global(struct mm_struct *charge_mm) { - sgx_reclaim_pages(_global_lru, charge_mm); + if (IS_ENABLED(CONFIG_CGROUP_MISC)) +

Re: [PATCH v8 4/6] LoongArch: KVM: Add vcpu search support from physical cpuid

2024-05-06 Thread maobibo
On 2024/5/7 上午10:05, Huacai Chen wrote: On Tue, May 7, 2024 at 9:40 AM maobibo wrote: On 2024/5/6 下午10:17, Huacai Chen wrote: On Mon, May 6, 2024 at 6:05 PM maobibo wrote: On 2024/5/6 下午5:40, Huacai Chen wrote: On Mon, May 6, 2024 at 5:35 PM maobibo wrote: On 2024/5/6 下午4:59,

Re: [PATCH 0/1] *** Replace KLP_* to KLP_TRANSITION_* ***

2024-05-06 Thread zhang warden
> On May 7, 2024, at 10:41, Josh Poimboeuf wrote: > > On Tue, May 07, 2024 at 10:21:40AM +0800, zhang warden wrote: >> >> >>> >>> transition state. With this marcos renamed, comments are not >>> necessary at this point. >>> >> Sorry for my careless, the comment still remains in the code.

Re: [PATCH 0/1] *** Replace KLP_* to KLP_TRANSITION_* ***

2024-05-06 Thread Josh Poimboeuf
On Tue, May 07, 2024 at 10:21:40AM +0800, zhang warden wrote: > > > > > > transition state. With this marcos renamed, comments are not > > necessary at this point. > > > Sorry for my careless, the comment still remains in the code. However, > comment in the code do no harms here. Maybe it can

Re: [PATCH 0/1] *** Replace KLP_* to KLP_TRANSITION_* ***

2024-05-06 Thread zhang warden
> > transition state. With this marcos renamed, comments are not > necessary at this point. > Sorry for my careless, the comment still remains in the code. However, comment in the code do no harms here. Maybe it can be kept.

[PATCH 1/1] livepatch: Rename KLP_* to KLP_TRANSITION_*

2024-05-06 Thread zhangwarden
From: Wardenjohn The original macros of KLP_* is about the state of the transition. Rename macros of KLP_* to KLP_TRANSITION_* to fix the confusing description of klp transition state. Signed-off-by: Wardenjohn --- include/linux/livepatch.h | 6 ++-- init/init_task.c | 2 +-

[PATCH 0/1] *** Replace KLP_* to KLP_TRANSITION_* ***

2024-05-06 Thread zhangwarden
From: Wardenjohn As the previous described, renaming variables is not a good idead becase it will break userspace. This patch rename macros of KLP_* to KLP_TRANSITION_* to fix the confusing description of the klp transition state. With this marcos renamed, comments are not necessary at this

Re: [PATCH v8 4/6] LoongArch: KVM: Add vcpu search support from physical cpuid

2024-05-06 Thread Huacai Chen
On Tue, May 7, 2024 at 9:40 AM maobibo wrote: > > > > On 2024/5/6 下午10:17, Huacai Chen wrote: > > On Mon, May 6, 2024 at 6:05 PM maobibo wrote: > >> > >> > >> > >> On 2024/5/6 下午5:40, Huacai Chen wrote: > >>> On Mon, May 6, 2024 at 5:35 PM maobibo wrote: > > > > On 2024/5/6

Re: [PATCH v8 4/6] LoongArch: KVM: Add vcpu search support from physical cpuid

2024-05-06 Thread maobibo
On 2024/5/6 下午10:17, Huacai Chen wrote: On Mon, May 6, 2024 at 6:05 PM maobibo wrote: On 2024/5/6 下午5:40, Huacai Chen wrote: On Mon, May 6, 2024 at 5:35 PM maobibo wrote: On 2024/5/6 下午4:59, Huacai Chen wrote: On Mon, May 6, 2024 at 4:18 PM maobibo wrote: On 2024/5/6 下午3:06,

Re: [PATCH v13 12/14] x86/sgx: Turn on per-cgroup EPC reclamation

2024-05-06 Thread Huang, Kai
On 1/05/2024 7:51 am, Haitao Huang wrote: static void sgx_reclaim_pages_global(struct mm_struct *charge_mm) { - sgx_reclaim_pages(_global_lru, charge_mm); + if (IS_ENABLED(CONFIG_CGROUP_MISC)) + sgx_cgroup_reclaim_pages(misc_cg_root(), charge_mm); + else

Re: [PATCH] ftrace: Remove unused global 'ftrace_direct_func_count'

2024-05-06 Thread Dr. David Alan Gilbert
* li...@treblig.org (li...@treblig.org) wrote: > From: "Dr. David Alan Gilbert" > > Commit 8788ca164eb4b ("ftrace: Remove the legacy _ftrace_direct API") > stopped setting the 'ftrace_direct_func_count' variable, but left > it around. Clean it up. > > Signed-off-by: Dr. David Alan Gilbert

[PATCH] ftrace: Remove unused global 'ftrace_direct_func_count'

2024-05-06 Thread linux
From: "Dr. David Alan Gilbert" Commit 8788ca164eb4b ("ftrace: Remove the legacy _ftrace_direct API") stopped setting the 'ftrace_direct_func_count' variable, but left it around. Clean it up. Signed-off-by: Dr. David Alan Gilbert --- include/linux/ftrace.h | 2 -- kernel/trace/fgraph.c | 11

Re: [PATCH v9 2/5] remoteproc: k3-m4: Add a remoteproc driver for M4F subsystem

2024-05-06 Thread Mathieu Poirier
Good day, I have started reviewing this patchset. Comments will be scattered over multiple days and as such, I will explicitly inform you when am done with the review. On Fri, Apr 26, 2024 at 02:18:08PM -0500, Andrew Davis wrote: > From: Martyn Welch > > The AM62x and AM64x SoCs of the TI K3

Re: [PATCH] remoteproc: k3-r5: Jump to error handling labels in start/stop errors

2024-05-06 Thread Mathieu Poirier
On Mon, May 06, 2024 at 07:48:49PM +0530, Beleswar Padhi wrote: > In case of errors during core start operation from sysfs, the driver > directly returns with the -EPERM error code. Fix this to ensure that > mailbox channels are freed on error before returning by jumping to the > 'put_mbox' error

Re: [PATCH v8 13/17] x86/ftrace: enable dynamic ftrace without CONFIG_MODULES

2024-05-06 Thread Steven Rostedt
On Sun, 5 May 2024 17:25:56 +0300 Mike Rapoport wrote: > From: "Mike Rapoport (IBM)" > > Dynamic ftrace must allocate memory for code and this was impossible > without CONFIG_MODULES. > > With execmem separated from the modules code, execmem_text_alloc() is > available regardless of

Re: [PATCH v8 06/17] mm: introduce execmem_alloc() and execmem_free()

2024-05-06 Thread Steven Rostedt
On Sun, 5 May 2024 17:25:49 +0300 Mike Rapoport wrote: > diff --git a/arch/x86/kernel/ftrace.c b/arch/x86/kernel/ftrace.c > index 70139d9d2e01..c8ddb7abda7c 100644 > --- a/arch/x86/kernel/ftrace.c > +++ b/arch/x86/kernel/ftrace.c > @@ -25,6 +25,7 @@ > #include > #include > #include >

Re: [PATCH v13 11/14] x86/sgx: Abstract check for global reclaimable pages

2024-05-06 Thread Haitao Huang
Hi Kai Sorry there seems to be some delay in receiving my emails. On Thu, 02 May 2024 18:23:06 -0500, Huang, Kai wrote: On 1/05/2024 7:51 am, Haitao Huang wrote: From: Kristen Carlson Accardi For the global reclaimer to determine if any page available for reclamation at the global level,

Re: ftrace_direct_func_count ?

2024-05-06 Thread Dr. David Alan Gilbert
* Steven Rostedt (rost...@goodmis.org) wrote: > On Sat, 4 May 2024 13:35:26 + > "Dr. David Alan Gilbert" wrote: > > > Hi, > > I've just posted a patch 'ftrace: Remove unused list > > 'ftrace_direct_funcs'' > > that clears out some old code, but while at it I noticed the global > >

Re: ftrace_direct_func_count ?

2024-05-06 Thread Steven Rostedt
On Sat, 4 May 2024 13:35:26 + "Dr. David Alan Gilbert" wrote: > Hi, > I've just posted a patch 'ftrace: Remove unused list 'ftrace_direct_funcs'' > that clears out some old code, but while at it I noticed the global > 'ftrace_direct_func_count'. > > As far as I can tell, it's never

Re: [PATCH] mm: Remove mm argument from mm_get_unmapped_area()

2024-05-06 Thread Liam R. Howlett
* Rick Edgecombe [240506 12:08]: > Recently the get_unmapped_area() pointer on mm_struct was removed in > favor of direct callable function that can determines which of two > handlers to call based on an mm flag. This function, > mm_get_unmapped_area(), checks the flag of the mm passed as an

Re: [PATCH] mm: Remove mm argument from mm_get_unmapped_area()

2024-05-06 Thread Christoph Hellwig
On Mon, May 06, 2024 at 09:07:47AM -0700, Rick Edgecombe wrote: > if (flags & MAP_FIXED) { > /* Ok, don't mess with it. */ > - return mm_get_unmapped_area(current->mm, NULL, orig_addr, len, > pgoff, flags); > + return current_get_unmapped_area(NULL,

[PATCH] mm: Remove mm argument from mm_get_unmapped_area()

2024-05-06 Thread Rick Edgecombe
Recently the get_unmapped_area() pointer on mm_struct was removed in favor of direct callable function that can determines which of two handlers to call based on an mm flag. This function, mm_get_unmapped_area(), checks the flag of the mm passed as an argument. Dan Williams pointed out (see link)

Re: [PATCH v4 2/2] ipvs: allow some sysctls in non-init user namespaces

2024-05-06 Thread Julian Anastasov
Hello, On Mon, 6 May 2024, Alexander Mikhalitsyn wrote: > Let's make all IPVS sysctls writtable even when > network namespace is owned by non-initial user namespace. > > Let's make a few sysctls to be read-only for non-privileged users: > - sync_qlen_max > - sync_sock_size > -

Re: [PATCH v4 1/2] ipvs: add READ_ONCE barrier for ipvs->sysctl_amemthresh

2024-05-06 Thread Julian Anastasov
Hello, On Mon, 6 May 2024, Alexander Mikhalitsyn wrote: > Cc: Julian Anastasov > Cc: Simon Horman > Cc: Pablo Neira Ayuso > Cc: Jozsef Kadlecsik > Cc: Florian Westphal > Suggested-by: Julian Anastasov > Signed-off-by: Alexander Mikhalitsyn Looks good to me for net-next,

[PATCH] tracing: Fix trace_pid_list_free() kernel-doc

2024-05-06 Thread Jeff Johnson
pid_list. + * @pid_list: The pid list to free. * * Frees the memory for a pid_list that was allocated. */ --- base-commit: dd5a440a31fae6e459c0d627162825505361 change-id: 20240506-trace_pid_list_free-kdoc-e2bf15be84ee

[PATCH] remoteproc: k3-r5: Jump to error handling labels in start/stop errors

2024-05-06 Thread Beleswar Padhi
In case of errors during core start operation from sysfs, the driver directly returns with the -EPERM error code. Fix this to ensure that mailbox channels are freed on error before returning by jumping to the 'put_mbox' error handling label. Similarly, jump to the 'out' error handling label to

Re: [PATCH v8 4/6] LoongArch: KVM: Add vcpu search support from physical cpuid

2024-05-06 Thread Huacai Chen
On Mon, May 6, 2024 at 6:05 PM maobibo wrote: > > > > On 2024/5/6 下午5:40, Huacai Chen wrote: > > On Mon, May 6, 2024 at 5:35 PM maobibo wrote: > >> > >> > >> > >> On 2024/5/6 下午4:59, Huacai Chen wrote: > >>> On Mon, May 6, 2024 at 4:18 PM maobibo wrote: > > > > On 2024/5/6

Re: [PATCH net-next v3 2/2] ipvs: allow some sysctls in non-init user namespaces

2024-05-06 Thread Aleksandr Mikhalitsyn
On Fri, May 3, 2024 at 3:06 PM Julian Anastasov wrote:> > > Hello, > > On Thu, 18 Apr 2024, Alexander Mikhalitsyn wrote: > > > Let's make all IPVS sysctls writtable even when > > network namespace is owned by non-initial user namespace. > > > > Let's make a few sysctls to be read-only for

[PATCH v4 2/2] ipvs: allow some sysctls in non-init user namespaces

2024-05-06 Thread Alexander Mikhalitsyn
Let's make all IPVS sysctls writtable even when network namespace is owned by non-initial user namespace. Let's make a few sysctls to be read-only for non-privileged users: - sync_qlen_max - sync_sock_size - run_estimation - est_cpulist - est_nice I'm trying to be conservative with this to

[PATCH v4 1/2] ipvs: add READ_ONCE barrier for ipvs->sysctl_amemthresh

2024-05-06 Thread Alexander Mikhalitsyn
Cc: Julian Anastasov Cc: Simon Horman Cc: Pablo Neira Ayuso Cc: Jozsef Kadlecsik Cc: Florian Westphal Suggested-by: Julian Anastasov Signed-off-by: Alexander Mikhalitsyn --- net/netfilter/ipvs/ip_vs_ctl.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git

Re: [PATCH RT 0/1] Linux v4.19.312-rt134-rc2

2024-05-06 Thread Daniel Wagner
Hi Sebastian, On 06.05.24 12:46, Daniel Wagner wrote: Dear RT Folks, This is the RT stable review cycle of patch 4.19.312-rt134-rc2. Please scream at me if I messed something up. Please test the patches too. My announce script is not attaching any conflict resolve diffs (eventually, I'll

Re: [PATCHv4 bpf-next 2/7] uprobe: Add uretprobe syscall to speed up return probe

2024-05-06 Thread Jiri Olsa
On Fri, May 03, 2024 at 08:35:24PM +, Edgecombe, Rick P wrote: > On Fri, 2024-05-03 at 22:17 +0200, Jiri Olsa wrote: > > when uretprobe is created, kernel overwrites the return address on user > > stack to point to user space trampoline, so the setup is in kernel hands > > I mean for uprobes

[PATCH RT 1/1] Linux 4.19.312-rt134

2024-05-06 Thread Daniel Wagner
v4.19.312-rt134-rc2 stable review patch. If anyone has any objections, please let me know. --- Signed-off-by: Daniel Wagner --- localversion-rt | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/localversion-rt b/localversion-rt index c2c7e0fb6685..6067da4c8c99 100644

[PATCH RT 0/1] Linux v4.19.312-rt134-rc2

2024-05-06 Thread Daniel Wagner
Dear RT Folks, This is the RT stable review cycle of patch 4.19.312-rt134-rc2. Please scream at me if I messed something up. Please test the patches too. The -rc release is also available on kernel.org https://git.kernel.org/pub/scm/linux/kernel/git/rt/linux-stable-rt.git on the

Re: [PATCH v8 4/6] LoongArch: KVM: Add vcpu search support from physical cpuid

2024-05-06 Thread maobibo
On 2024/5/6 下午5:40, Huacai Chen wrote: On Mon, May 6, 2024 at 5:35 PM maobibo wrote: On 2024/5/6 下午4:59, Huacai Chen wrote: On Mon, May 6, 2024 at 4:18 PM maobibo wrote: On 2024/5/6 下午3:06, Huacai Chen wrote: Hi, Bibo, On Mon, May 6, 2024 at 2:36 PM maobibo wrote: On

Re: [PATCH v8 4/6] LoongArch: KVM: Add vcpu search support from physical cpuid

2024-05-06 Thread Huacai Chen
On Mon, May 6, 2024 at 5:35 PM maobibo wrote: > > > > On 2024/5/6 下午4:59, Huacai Chen wrote: > > On Mon, May 6, 2024 at 4:18 PM maobibo wrote: > >> > >> > >> > >> On 2024/5/6 下午3:06, Huacai Chen wrote: > >>> Hi, Bibo, > >>> > >>> On Mon, May 6, 2024 at 2:36 PM maobibo wrote: > > >

Re: [PATCH v8 4/6] LoongArch: KVM: Add vcpu search support from physical cpuid

2024-05-06 Thread maobibo
On 2024/5/6 下午4:59, Huacai Chen wrote: On Mon, May 6, 2024 at 4:18 PM maobibo wrote: On 2024/5/6 下午3:06, Huacai Chen wrote: Hi, Bibo, On Mon, May 6, 2024 at 2:36 PM maobibo wrote: On 2024/5/6 上午9:49, Huacai Chen wrote: Hi, Bibo, On Sun, Apr 28, 2024 at 6:05 PM Bibo Mao wrote:

Re: [PATCH v8 4/6] LoongArch: KVM: Add vcpu search support from physical cpuid

2024-05-06 Thread Huacai Chen
On Mon, May 6, 2024 at 4:18 PM maobibo wrote: > > > > On 2024/5/6 下午3:06, Huacai Chen wrote: > > Hi, Bibo, > > > > On Mon, May 6, 2024 at 2:36 PM maobibo wrote: > >> > >> > >> > >> On 2024/5/6 上午9:49, Huacai Chen wrote: > >>> Hi, Bibo, > >>> > >>> On Sun, Apr 28, 2024 at 6:05 PM Bibo Mao wrote:

Re: [PATCH] livepatch.h: Add comment to klp transition state

2024-05-06 Thread Petr Mladek
On Mon 2024-05-06 10:04:26, zhang warden wrote: > > > > On May 6, 2024, at 05:00, Josh Poimboeuf wrote: > > > > On Mon, Apr 29, 2024 at 03:26:28PM +0800, zhangwar...@gmail.com wrote: > >> From: Wardenjohn > >> > >> livepatch.h use KLP_UNDEFINED\KLP_UNPATCHED\KLP_PATCHED for klp transition >

Re: [PATCH v8 4/6] LoongArch: KVM: Add vcpu search support from physical cpuid

2024-05-06 Thread maobibo
On 2024/5/6 下午3:06, Huacai Chen wrote: Hi, Bibo, On Mon, May 6, 2024 at 2:36 PM maobibo wrote: On 2024/5/6 上午9:49, Huacai Chen wrote: Hi, Bibo, On Sun, Apr 28, 2024 at 6:05 PM Bibo Mao wrote: Physical cpuid is used for interrupt routing for irqchips such as ipi/msi/extioi interrupt

Re: [PATCH v3 1/2] virtiofs: use pages instead of pointer for kernel direct IO

2024-05-06 Thread Hou Tao
On 4/26/2024 10:39 PM, Hou Tao wrote: > From: Hou Tao > > When trying to insert a 10MB kernel module kept in a virtio-fs with cache > disabled, the following warning was reported: > > [ cut here ] > WARNING: CPU: 1 PID: 404 at mm/page_alloc.c:4551 .. > Modules

Re: [PATCH v8 4/6] LoongArch: KVM: Add vcpu search support from physical cpuid

2024-05-06 Thread Huacai Chen
Hi, Bibo, On Mon, May 6, 2024 at 2:36 PM maobibo wrote: > > > > On 2024/5/6 上午9:49, Huacai Chen wrote: > > Hi, Bibo, > > > > On Sun, Apr 28, 2024 at 6:05 PM Bibo Mao wrote: > >> > >> Physical cpuid is used for interrupt routing for irqchips such as > >> ipi/msi/extioi interrupt controller. And

Re: [PATCH v8 6/6] LoongArch: Add pv ipi support on guest kernel side

2024-05-06 Thread Huacai Chen
On Mon, May 6, 2024 at 3:00 PM maobibo wrote: > > > > On 2024/5/6 上午9:53, Huacai Chen wrote: > > Hi, Bibo, > > > > On Sun, Apr 28, 2024 at 6:05 PM Bibo Mao wrote: > >> > >> PARAVIRT option and pv ipi is added on guest kernel side, function > >> pv_ipi_init() is to add ipi sending and ipi

Re: [PATCH v8 6/6] LoongArch: Add pv ipi support on guest kernel side

2024-05-06 Thread maobibo
On 2024/5/6 上午9:53, Huacai Chen wrote: Hi, Bibo, On Sun, Apr 28, 2024 at 6:05 PM Bibo Mao wrote: PARAVIRT option and pv ipi is added on guest kernel side, function pv_ipi_init() is to add ipi sending and ipi receiving hooks. This function firstly checks whether system runs on VM mode. If

Re: [PATCH v8 4/6] LoongArch: KVM: Add vcpu search support from physical cpuid

2024-05-06 Thread maobibo
On 2024/5/6 上午9:49, Huacai Chen wrote: Hi, Bibo, On Sun, Apr 28, 2024 at 6:05 PM Bibo Mao wrote: Physical cpuid is used for interrupt routing for irqchips such as ipi/msi/extioi interrupt controller. And physical cpuid is stored at CSR register LOONGARCH_CSR_CPUID, it can not be changed

Re: [PATCH v8 0/6] LoongArch: Add pv ipi support on LoongArch VM

2024-05-06 Thread maobibo
On 2024/5/6 上午9:45, Huacai Chen wrote: Hi, Bibo, I have done an off-list discussion with some KVM experts, and they think user-space have its right to know PV features, so cpucfg solution is acceptable. And I applied this series with some modifications at

[PATCH] kernel/module: disable cfi for do_mod_ctors

2024-05-06 Thread Joey Jiao
CFI failure when both CONFIG_CONSTRUCTORS and CFI_CLANG enabled. CFI failure at do_init_module+0x100/0x384 (target: tsan.module_ctor+0x0/0xa98 [module_name_xx]; expected type: 0xa540670c) Disable cfi for do_mod_ctors to avoid cfi check on mod->ctors[i](). Signed-off-by: Joey Jiao ---