Re: [PATCH v3 04/11] otg-fsm: move usb_bus_start_enum into otg-fsm-ops

2015-07-13 Thread Roger Quadros
Peter, On 13/07/15 04:58, Peter Chen wrote: On Wed, Jul 08, 2015 at 01:19:30PM +0300, Roger Quadros wrote: This is to prevent missing symbol build error if OTG is enabled (built-in) and HCD core (CONFIG_USB) is module. We may let the OTG-DRD/OTG-FSM depends on CONFIG_USB to fix it.

Re: [PATCH v3] phy: rcar-gen2 usb: Add Host/Function switching for USB0

2015-07-13 Thread Sergei Shtylyov
Hello. On 7/13/2015 12:04 PM, Phil Edworthy wrote: Instead of statically selecting the PHY connection to either the USBHS (Function) or PCI0 (Host) IP blocks, this change allows the dts to specifiy gpio pins for the vbus and id signals. Additional These GPIOs don't have anything to do

[PATCH v3 2/5] usb: gadget: midi: avoid redundant f_midi_set_alt() call

2015-07-13 Thread Robert Baldyga
Function midi registers two interfaces with single set_alt() function which means that f_midi_set_alt() is called twice when configuration is set. That means that endpoint initialization and ep request allocation is done two times. To avoid this problem we do such things only once, for interface

[PATCH v3 5/5] usb: gadget: atmel_usba_udc: add missing ret value check

2015-07-13 Thread Robert Baldyga
Add missing return value check. In case of error print debug message and return error code. Signed-off-by: Robert Baldyga r.bald...@samsung.com Acked-by: Nicolas Ferre nicolas.fe...@atmel.com Acked-by: Michal Nazarewicz min...@mina86.com --- drivers/usb/gadget/udc/atmel_usba_udc.c | 4 1

[PATCH v3 3/5] usb: isp1760: udc: add missing usb_ep_set_maxpacket_limit()

2015-07-13 Thread Robert Baldyga
Since maxpacket_limit was introduced all UDC drivers should use usb_ep_set_maxpacket_limit() function instead of setting maxpacket value manually. ep.maxpacket_limit contains actual maximum maxpacket value supported by hardware which is needed by epautoconf. Signed-off-by: Robert Baldyga

[PATCH v3 0/5] usb: gadget: miscellaneous fixes

2015-07-13 Thread Robert Baldyga
Hello, This patch set contains few small bugfixes found in usb gadget functions and UDC drivers. The most important is the [1] as it fixes bug causing BUG_ON() in f_fs driver. Remaining patches contain minor fixes. [1] usb: gadget: ffs: call functionfs_unbind() if _ffs_func_bind() fails Best

[PATCH v3 1/5] usb: gadget: ffs: call functionfs_unbind() if _ffs_func_bind() fails

2015-07-13 Thread Robert Baldyga
Function ffs_do_functionfs_bind() calls functionfs_bind() which allocates usb request and increments refcounts. These things needs to be cleaned up by if further steps of initialization fail by calling functionfs_unbind(). Signed-off-by: Robert Baldyga r.bald...@samsung.com Acked-by: Michal

Re: [PATCH v3 00/11] USB: OTG/DRD Core functionality

2015-07-13 Thread Roger Quadros
Hi, On 10/07/15 10:58, Li Jun wrote: On Wed, Jul 08, 2015 at 01:19:26PM +0300, Roger Quadros wrote: Hi, This series centralizes OTG/Dual-role functionality in the kernel. As of now I've got Dual-role functionality working pretty reliably on dra7-evm and am437x-gp-evm. xhci side of things

[PATCH v3 4/5] staging: emxx_udc: add missing usb_ep_set_maxpacket_limit()

2015-07-13 Thread Robert Baldyga
Since maxpacket_limit was introduced all UDC drivers should use usb_ep_set_maxpacket_limit() function instead of setting maxpacket value manually. ep.maxpacket_limit contains actual maximum maxpacket value supported by hardware which is needed by epautoconf. Signed-off-by: Robert Baldyga

RE: [PATCH v3] phy: rcar-gen2 usb: Add Host/Function switching for USB0

2015-07-13 Thread Phil Edworthy
Hi Sergei, On 10 July 2015 17:36, Sergei wrote: Hello. On 07/07/2015 02:55 PM, Phil Edworthy wrote: Instead of statically selecting the PHY connection to either the USBHS (Function) or PCI0 (Host) IP blocks, this change allows the dts to specifiy gpio pins for the vbus and id signals.

Re: [PATCH] USB: sierra: add 1199:68AB device ID

2015-07-13 Thread Dirk Behme
On 13.07.2015 09:39, Lars Melin wrote: On 2015-07-13 12:44, Dirk Behme wrote: Add support for USB descriptor 0x1199, 0x68AB. Signed-off-by: Dirk Behme dirk.be...@de.bosch.com --- drivers/usb/serial/sierra.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/drivers/usb/serial/sierra.c

BIGES CONTRACTE,

2015-07-13 Thread Musa Mohamed Ali
Greetings my friend, Good Day. I know this message might meet you in utmost surprise; however, it's just my urgent need for a foreign partner that made me to contact you for this mutual benefiting business when searching for a good, reliable and trust worthy person. My name is Musa Mohamed Ali,

Re: Cannot use the logitech k520 (046d:c52b) to unlock my luks disk at boot time

2015-07-13 Thread Jiri Kosina
On Mon, 13 Jul 2015, Glasswall Information Point wrote: And to clarify the confusion about the modprobe story, and the keyboard. I know normally after disk drivers have been loaded by initramfs you can load modules for hid input. But is this case you cannot because off FULL-disk

Re: [PATCH v3 01/11] usb: otg-fsm: Add documentation for struct otg_fsm

2015-07-13 Thread Roger Quadros
On 13/07/15 04:21, Peter Chen wrote: On Wed, Jul 08, 2015 at 01:19:27PM +0300, Roger Quadros wrote: struct otg_fsm is the interface to the OTG state machine. Document the input, output and internal state variables. Definations are taken from Table 7-2 and Table 7-4 of the USB OTG EH

[PATCH/RFC] usb: gadget: udc: core: Fix argument of dma_map_single for IOMMU

2015-07-13 Thread Yoshihiro Shimoda
The dma_map_single and dma_unmap_single should set gadget-dev.parent instead of gadget-dev in the first argument because the parent has a udc controller's device pointer. Otherwise, iommu functions are not called in ARM environment. Signed-off-by: Yoshihiro Shimoda

Re: [PATCH v3 07/11] usb: otg: add OTG core

2015-07-13 Thread Roger Quadros
On 13/07/15 05:14, Peter Chen wrote: On Wed, Jul 08, 2015 at 01:19:33PM +0300, Roger Quadros wrote: The OTG core instantiates the OTG Finite State Machine per OTG controller and manages starting/stopping the host and gadget controllers based on the bus state. It provides APIs for the

Re: [PATCH v2 2/5] dt-bindings: Add a binding for Mediatek xHCI host controller

2015-07-13 Thread chunfeng yun
hi Roger, On Fri, 2015-07-10 at 11:31 +0300, Roger Quadros wrote: Hi, On 08/07/15 12:41, Chunfeng Yun wrote: add a DT binding documentation of xHCI host controller for the MT8173 SoC from Mediatek. Signed-off-by: Chunfeng Yun chunfeng@mediatek.com ---

[PATCH V4 1/1] usb:serial:f81534 add F81532/534 driver

2015-07-13 Thread Peter Hung
This driver is for Fintek F81532/F81534 USB to Serial Ports IC. Features: 1. F81534 is 1-to-4 F81532 is 1-to-2 serial ports IC 2. Support Baudrate from B50 to B150 (excluding B100). 3. The RTS signal can be transformed their behavior with configuration by default ioctl

Re: [PATCH v2 2/5] dt-bindings: Add a binding for Mediatek xHCI host controller

2015-07-13 Thread chunfeng yun
hi Roger, On Fri, 2015-07-10 at 11:31 +0300, Roger Quadros wrote: Hi, On 08/07/15 12:41, Chunfeng Yun wrote: add a DT binding documentation of xHCI host controller for the MT8173 SoC from Mediatek. Signed-off-by: Chunfeng Yun chunfeng@mediatek.com ---

Re: [PATCH v3 00/11] USB: OTG/DRD Core functionality

2015-07-13 Thread Li Jun
On Mon, Jul 13, 2015 at 01:24:05PM +0300, Roger Quadros wrote: Hi, On 10/07/15 10:58, Li Jun wrote: On Wed, Jul 08, 2015 at 01:19:26PM +0300, Roger Quadros wrote: Hi, This series centralizes OTG/Dual-role functionality in the kernel. As of now I've got Dual-role functionality working

Re: [PATCH v2 4/5] xhci: mediatek: support MTK xHCI host controller

2015-07-13 Thread John Crispin
Hi there is a cross dependency between the modules. xhci-mtk.ko requires xhci.ko to be loaded. however this will look for xhci_mtk_add_ep_quirk() which is part of xhci-mtk. the modules will build but are not run time loadable. John On 08/07/2015 11:41, Chunfeng Yun wrote: MTK xhci host

RE: [PATCH v3] phy: rcar-gen2 usb: Add Host/Function switching for USB0

2015-07-13 Thread Phil Edworthy
Hi Sergei, On 13 July 2015 11:17, Sergei wrote: Hello. On 7/13/2015 12:04 PM, Phil Edworthy wrote: Instead of statically selecting the PHY connection to either the USBHS (Function) or PCI0 (Host) IP blocks, this change allows the dts to specifiy gpio pins for the vbus and id signals.

Re: [PATCH v3 00/11] USB: OTG/DRD Core functionality

2015-07-13 Thread Peter Chen
On Mon, Jul 13, 2015 at 12:14:43PM -0700, Andrew Bresticker wrote: Hi Roger, On Wed, Jul 8, 2015 at 3:19 AM, Roger Quadros rog...@ti.com wrote: Usage model: --- - The OTG controller device is assumed to be the parent of the host and gadget controller. It must call

Re: [PATCH v7 0/4] Fix idle port disconnects and firmware downloading

2015-07-13 Thread Peter Berger
On Sun, 2015-06-28 at 13:28 -0500, Peter E. Berger wrote: From: Peter E. Berger pber...@brimson.com I found that when using newer Edgeport devices such as the EP/416, idle ports are regularly bounced (disconnected and then reconnected). I discussed this with the manufacturer (Digi

Re: [PATCH v2 3/3] usb: dwc3: gadget: return error if command sent to DEPCMD register fails

2015-07-13 Thread Felipe Balbi
Hi, On Mon, Jul 13, 2015 at 05:50:49PM +, John Youn wrote: On 7/11/2015 12:29 PM, Felipe Balbi wrote: Hi, On Sat, Jul 11, 2015 at 05:17:32PM +, Subbaraya Sundeep Bhatta wrote: Hi Felipe, Just an update on this. I'm trying to get this working with our latest IP with dwc3

Re: [PATCH v3 00/11] USB: OTG/DRD Core functionality

2015-07-13 Thread Andrew Bresticker
Hi Roger, On Wed, Jul 8, 2015 at 3:19 AM, Roger Quadros rog...@ti.com wrote: Usage model: --- - The OTG controller device is assumed to be the parent of the host and gadget controller. It must call usb_otg_register() before populating the host and gadget devices so that the OTG

Re: [PATCH v3] phy: rcar-gen2 usb: Add Host/Function switching for USB0

2015-07-13 Thread Sergei Shtylyov
On 07/13/2015 07:55 PM, Phil Edworthy wrote: Instead of statically selecting the PHY connection to either the USBHS (Function) or PCI0 (Host) IP blocks, this change allows the dts to specifiy gpio pins for the vbus and id signals. Additional These GPIOs don't have anything to do with

RE: [PATCH v3] phy: rcar-gen2 usb: Add Host/Function switching for USB0

2015-07-13 Thread Phil Edworthy
Hi Sergei, On 13 July 2015 18:10, Sergei wrote: On 07/13/2015 07:55 PM, Phil Edworthy wrote: Instead of statically selecting the PHY connection to either the USBHS (Function) or PCI0 (Host) IP blocks, this change allows the dts to specifiy gpio pins for the vbus and id signals.

Re: [PATCH] USB: pl2303: Rewrite pl2303_encode_baud_rate_divisor

2015-07-13 Thread Frank Schäfer
Am 08.07.2015 um 12:51 schrieb Michał Pecio: This commit fixes the following issues: 1. The 9th bit of buf was believed to be the LSB of divisor's exponent, but the hardware interprets it as MSB (9th bit) of the mantissa. The exponent is actually one bit shorter and applies to base 4, not

[PATCH v6] usb: renesas_usbhs: Allow an OTG PHY driver to provide VBUS

2015-07-13 Thread Phil Edworthy
These changes allow a PHY driver to trigger a VBUS interrupt and to provide the value of VBUS. Signed-off-by: Phil Edworthy phil.edwor...@renesas.com --- v6: - Rename vbus_indirect_value to vbus_active v5: - Avoid race when vbus_is_indirect may or may not be read before the phy has

RE: [PATCH v5] usb: renesas_usbhs: Allow an OTG PHY driver to provide VBUS

2015-07-13 Thread Phil Edworthy
Hi Laurent, On 09 July 2015 02:03, Laurent wrote: Hi Phil, On Wednesday 08 July 2015 08:08:27 Phil Edworthy wrote: On 08 July 2015 00:08, Laurent wrote: On Tuesday 07 July 2015 12:52:43 Phil Edworthy wrote: These changes allow a PHY driver to trigger a VBUS interrupt and to

RE: [PATCH v6] usb: renesas_usbhs: Allow an OTG PHY driver to provide VBUS

2015-07-13 Thread Phil Edworthy
Hi Laurent, On 13 July 2015 16:51, Laurent wrote: Hi Phil, Thank you for the patch. On Monday 13 July 2015 16:30:18 Phil Edworthy wrote: These changes allow a PHY driver to trigger a VBUS interrupt and to provide the value of VBUS. Signed-off-by: Phil Edworthy

Re: [PATCH] USB: pl2303: Rewrite pl2303_encode_baud_rate_divisor

2015-07-13 Thread Johan Hovold
On Mon, Jul 13, 2015 at 06:08:50PM +0200, Michał Pecio wrote: Commit 57ce61aad748 might be helpful... ;) Good luck, Frank Pretty much the same thing I have done, except that I didn't notice that 0 = 512 :) Apparently, 57ce61aad748 fell victim of a mass-revert caused by some

Re: [PATCH/RFC] usb: gadget: udc: core: Fix argument of dma_map_single for IOMMU

2015-07-13 Thread Geert Uytterhoeven
Hi Greg, On Mon, Jul 13, 2015 at 6:19 PM, Greg KH gre...@linuxfoundation.org wrote: On Mon, Jul 13, 2015 at 06:10:05PM +0900, Yoshihiro Shimoda wrote: The dma_map_single and dma_unmap_single should set gadget-dev.parent instead of gadget-dev in the first argument because the parent has a udc

Re: [PATCH v6] usb: renesas_usbhs: Allow an OTG PHY driver to provide VBUS

2015-07-13 Thread Laurent Pinchart
Hi Phil, Thank you for the patch. On Monday 13 July 2015 16:30:18 Phil Edworthy wrote: These changes allow a PHY driver to trigger a VBUS interrupt and to provide the value of VBUS. Signed-off-by: Phil Edworthy phil.edwor...@renesas.com I don't see any further show stopper for this patch,

Re: [PATCH/RFC] usb: gadget: udc: core: Fix argument of dma_map_single for IOMMU

2015-07-13 Thread Greg KH
On Mon, Jul 13, 2015 at 06:10:05PM +0900, Yoshihiro Shimoda wrote: The dma_map_single and dma_unmap_single should set gadget-dev.parent instead of gadget-dev in the first argument because the parent has a udc controller's device pointer. Otherwise, iommu functions are not called in ARM

Re: [PATCH v3] phy: rcar-gen2 usb: Add Host/Function switching for USB0

2015-07-13 Thread Sergei Shtylyov
On 07/13/2015 06:02 PM, Phil Edworthy wrote: Instead of statically selecting the PHY connection to either the USBHS (Function) or PCI0 (Host) IP blocks, this change allows the dts to specifiy gpio pins for the vbus and id signals. Additional These GPIOs don't have anything to do with

RE: [PATCH v3] phy: rcar-gen2 usb: Add Host/Function switching for USB0

2015-07-13 Thread Phil Edworthy
Hi Sergei, On 13 July 2015 17:37, Sergei wrote: On 07/13/2015 06:02 PM, Phil Edworthy wrote: Instead of statically selecting the PHY connection to either the USBHS (Function) or PCI0 (Host) IP blocks, this change allows the dts to specifiy gpio pins for the vbus and id signals.

RE: [PATCH] xhci: Workaround to get D3 working in Intel xHCI

2015-07-13 Thread Mani, Rajmohan
Thanks Benson. To be accurate, Mathias mentioned consolidating this patch into the PME quirk would be simpler and smaller. Raj -Original Message- From: ble...@google.com [mailto:ble...@google.com] On Behalf Of Benson Leung Sent: Monday, July 13, 2015 4:08 PM To: Mani, Rajmohan Cc:

Re: [PATCH] USB: pl2303: Rewrite pl2303_encode_baud_rate_divisor

2015-07-13 Thread Michał Pecio
Commit 57ce61aad748 might be helpful... ;) Good luck, Frank Pretty much the same thing I have done, except that I didn't notice that 0 = 512 :) Apparently, 57ce61aad748 fell victim of a mass-revert caused by some underdebugged issues. Is it known what they were? Is there any chance of

Re: [PATCH] xhci: Workaround to get D3 working in Intel xHCI

2015-07-13 Thread Benson Leung
Thanks Rajmohan. Comments inline. On Thu, Jul 9, 2015 at 6:17 PM, rajmohan.m...@intel.com wrote: From: Rajmohan Mani rajmohan.m...@intel.com The xHCI in Intel CherryView / Braswell Platform requires a driver workaround to get xHCI D3 working. Without this workaround, xHCI might not enter

RE: [PATCH] xhci: Workaround to get D3 working in Intel xHCI

2015-07-13 Thread Mani, Rajmohan
Hi Benson, Please see responses inline. -Original Message- From: ble...@google.com [mailto:ble...@google.com] On Behalf Of Benson Leung Sent: Monday, July 13, 2015 3:45 PM To: Mani, Rajmohan Cc: Nyman, Mathias; linux-usb@vger.kernel.org; ejcar...@chromium.org Subject: Re: [PATCH] xhci:

Re: [PATCH] xhci: Workaround to get D3 working in Intel xHCI

2015-07-13 Thread Benson Leung
On Mon, Jul 13, 2015 at 4:03 PM, Mani, Rajmohan rajmohan.m...@intel.com wrote: I implemented the original patch exactly the way you mentioned that would i) use a new quirk ii) do the vendor / device check within xhci_pci_quirks() and iii) do this in a separate function. When I sent this out

Re: [PATCH v7 00/23] usb gadget update for OTG 2.0

2015-07-13 Thread Li Jun
On Thu, Jul 09, 2015 at 03:18:37PM +0800, Li Jun wrote: ... This is a follow-up of Macpaul Lin's previous patchset to resolve usb gadget driver working with OTG 2.0, and set otg features by not only usb driver config but also usb hardware property in DT, main changes: 1. Add

RE: [PATCH/RFC] usb: gadget: udc: core: Fix argument of dma_map_single for IOMMU

2015-07-13 Thread Yoshihiro Shimoda
Hi Geert-san, Sent: Tuesday, July 14, 2015 1:52 AM Hi Greg, On Mon, Jul 13, 2015 at 6:19 PM, Greg KH gre...@linuxfoundation.org wrote: On Mon, Jul 13, 2015 at 06:10:05PM +0900, Yoshihiro Shimoda wrote: The dma_map_single and dma_unmap_single should set gadget-dev.parent instead of

Re: [PATCH v3 04/11] otg-fsm: move usb_bus_start_enum into otg-fsm-ops

2015-07-13 Thread Peter Chen
On Mon, Jul 13, 2015 at 01:13:54PM +0300, Roger Quadros wrote: Peter, On 13/07/15 04:58, Peter Chen wrote: On Wed, Jul 08, 2015 at 01:19:30PM +0300, Roger Quadros wrote: This is to prevent missing symbol build error if OTG is enabled (built-in) and HCD core (CONFIG_USB) is module.

Re: Cannot use the logitech k520 (046d:c52b) to unlock my luks disk at boot time

2015-07-13 Thread Glasswall Information Point
Harddrive != Hardware I did indeed misread that. But still, I think initramfs should include keyboards, else its impossible to boot if you have full disk encryption. Andthe driver cannot be modprobed at boot time, because its not on the initial ram-drive. Op 09-07-15 om 15:22 schreef Jiri

Re: Cannot use the logitech k520 (046d:c52b) to unlock my luks disk at boot time

2015-07-13 Thread Glasswall Information Point
And to clarify the confusion about the modprobe story, and the keyboard. I know normally after disk drivers have been loaded by initramfs you can load modules for hid input. But is this case you cannot because off FULL-disk encryption, and the disk is decrypted after you enter the password

Re: [PATCH] USB: sierra: add 1199:68AB device ID

2015-07-13 Thread Lars Melin
On 2015-07-13 12:44, Dirk Behme wrote: Add support for USB descriptor 0x1199, 0x68AB. Signed-off-by: Dirk Behme dirk.be...@de.bosch.com --- drivers/usb/serial/sierra.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/drivers/usb/serial/sierra.c b/drivers/usb/serial/sierra.c index

Re: [PATCH v3 3/3] usb: phy: hold wakeupsource when USB is enumerated in peripheral mode

2015-07-13 Thread Sumit Semwal
Hi Peter, On 8 June 2015 at 14:02, Peter Chen peter.c...@freescale.com wrote: On Mon, Jun 08, 2015 at 12:37:00PM +0530, Sumit Semwal wrote: H Peter, Felipe, On 14 January 2015 at 06:56, Peter Chen peter.c...@freescale.com wrote: On Tue, Jan 13, 2015 at 10:18:02AM -0600, Felipe Balbi wrote:

Re: [PATCH v3 3/3] usb: phy: hold wakeupsource when USB is enumerated in peripheral mode

2015-07-13 Thread Peter Chen
On Mon, Jul 13, 2015 at 01:26:23PM +0530, Sumit Semwal wrote: Hi Peter, On 8 June 2015 at 14:02, Peter Chen peter.c...@freescale.com wrote: On Mon, Jun 08, 2015 at 12:37:00PM +0530, Sumit Semwal wrote: H Peter, Felipe, On 14 January 2015 at 06:56, Peter Chen peter.c...@freescale.com