Re: [PATCH 92/92]Documentation/powerpc/booting-without-of.txt update web address.

2010-07-21 Thread Michael Neuling
The patch below fixes a broken web address. Signed-off-by: Justin P. Mattock justinmatt...@gmail.com --- Documentation/powerpc/booting-without-of.txt |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/Documentation/powerpc/booting-without-of.txt

one more question about dts

2010-07-21 Thread hacklu
my board is mpc8247,and i write it's dts by imitating mpc8272's dts how can i set the localbus address? local...@f0010100 { compatible = fsl,mpc8272-localbus, fsl,pq2-localbus; #address-cells = 2; #size-cells = 1;

Re: [PATCH 92/92]Documentation/powerpc/booting-without-of.txt update web address.

2010-07-21 Thread Justin P. Mattock
On 07/20/2010 11:07 PM, Michael Neuling wrote: The patch below fixes a broken web address. Signed-off-by: Justin P. Mattockjustinmatt...@gmail.com --- Documentation/powerpc/booting-without-of.txt |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git

Re: [PATCH] DTS: Adding device tree source for the STx GP3 SSA MPC8555-based board.

2010-07-21 Thread Kumar Gala
+ soc8...@e000 { + #address-cells = 1; + #size-cells = 1; + device_type = soc; + compatible = simple-bus; + ranges = 0x0 0xe000 0x10; + bus-frequency = 0; + + ecm-...@0 { +

Re: [PATCH] DTS: Adding device tree source for the STx GP3 SSA MPC8555-based board.

2010-07-21 Thread Bradley Hughes
On Wed, Jul 21, 2010 at 10:24 AM, Kumar Gala ga...@kernel.crashing.org wrote: +     soc8...@e000 { +             #address-cells = 1; +             #size-cells = 1; +             device_type = soc; +             compatible = simple-bus; +             ranges = 0x0 0xe000 0x10; +  

Re: [lm-sensors] [PATCH] hwmon: (tmp421) Add nfactor support (2nd attempt)

2010-07-21 Thread Andre Prendel
On Tue, Jul 20, 2010 at 08:59:52AM -0700, Guenter Roeck wrote: On Tue, Jul 20, 2010 at 11:09:53AM -0400, Andre Prendel wrote: On Thu, May 20, 2010 at 09:35:56PM +0200, Andre Prendel wrote: On Thu, May 20, 2010 at 03:07:05PM -0400, Jeff Angielski wrote: In any event, here it is again:

Re: [PATCH] DTS: Adding device tree source for the STx GP3 SSA MPC8555-based board.

2010-07-21 Thread Kumar Gala
On Jul 21, 2010, at 11:52 AM, Bradley Hughes wrote: On Wed, Jul 21, 2010 at 10:24 AM, Kumar Gala ga...@kernel.crashing.org wrote: + soc8...@e000 { + #address-cells = 1; + #size-cells = 1; + device_type = soc; + compatible =

Re: [PATCH 7/8] v3 Define memory_block_size_bytes() for ppc/pseries

2010-07-21 Thread Brian King
On 07/19/2010 10:59 PM, Nathan Fontenot wrote: +static u32 get_memblock_size(void) +{ + struct device_node *np; + unsigned int memblock_size = 0; + + np = of_find_node_by_path(/ibm,dynamic-reconfiguration-memory); + if (np) { + const unsigned int *size; This

[PATCH 0/2] tqm85xx: enable PCMCIA bridge on ST85xx baseboards.

2010-07-21 Thread Dmitry Eremin-Solenikov
Baseboards for tqm85xx modules (STK85xx) bear TI PCI1520 PCMCIA controllers. These two patches enables one to fully use this controller in Linux. ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

[PATCH 1/2] tqm85xx: update PCI interrupt-map attribute

2010-07-21 Thread Dmitry Eremin-Solenikov
Update PCI IRQ mapping on TQM85xx platforms: include INTC and INTD on PCI-X slot and add INTA/INTB mapping for PCMCIA bridge. Signed-off-by: Dmitry Eremin-Solenikov dbarysh...@gmail.com --- arch/powerpc/boot/dts/tqm8540.dts |9 - arch/powerpc/boot/dts/tqm8541.dts |

[PATCH 2/2] tqm85xx: add a quirk for ti1520 PCMCIA bridge

2010-07-21 Thread Dmitry Eremin-Solenikov
By default ti1520 bridge expects an input clock on CLOCK pin (to control power chip). However on this boards CLOCK should be generated by PCI1520 itself. Add a quirk that enables internal 16 KHz clock generation on this pin. Signed-off-by: Dmitry Eremin-Solenikov dbarysh...@gmail.com ---

[PATCH v2 0/2] kexec/crash support on mpc85xx parts

2010-07-21 Thread Matthew McClintock
The patch series is meant to fix a few issues with kexec/crash working on mpc85xx parts v1: initial version v2: Fix a typo when decremeting a wait condition twice leading to never showing when we fail waiting for extra cpus to shutdown Moved around code so the crash and kexec shutdown code

[PATCH v2 1/2] powerpc/85xx: kexec for SMP 85xx BookE systems

2010-07-21 Thread Matthew McClintock
Adds support for kexec on 85xx machines for the BookE platform. Including support for SMP machines Based off work from Maxim Uvarov muva...@mvista.com Signed-off-by: Matthew McClintock m...@freescale.com --- arch/powerpc/Kconfig | 10 +++--- arch/powerpc/platforms/85xx/smp.c |

[PATCH v2 2/2] powerpc/crashdump: Fix issues with kexec and 36bit physical addr

2010-07-21 Thread Matthew McClintock
Fix sizes of variables so correct values are exported via /proc. Cast variable in comparison to avoid compiler error. Signed-off-by: Matthew McClintock m...@freescale.com --- arch/powerpc/kernel/crash_dump.c|4 ++-- arch/powerpc/kernel/machine_kexec.c | 10 +- 2 files changed,

Re: [PATCH 0/8] sdhci: Move real work out of an atomic context

2010-07-21 Thread Andrew Morton
On Wed, 14 Jul 2010 17:07:28 +0400 Anton Vorontsov avoront...@mvista.com wrote: Hi all, Currently the sdhci driver does everything in the atomic context. And what is worse, PIO transfers are made from the IRQ handler. This causes huge latencies (up to 120 ms). On some P2020 SOCs, DMA and

[PATCH v2 0/2] Adding DTS for the STx GP3-SSA MPC8555 board

2010-07-21 Thread Bradley Hughes
This version uses fsl,mpc8555... instead of fsl,85... notation. There is also an 8541 version of this board so DTS for this board is specific to the 8555 processor. Another patch is coming to fix-up other DTS that use old notation. Signed-off-by: Bradley Hughes bhug...@silicontkx.com ---

[PATCH v2 1/2] DTS: Change deprecated binding for 85xx-based boards

2010-07-21 Thread Bradley Hughes
The fsl,85... style compatible binding was to be deprecated some time ago. This patch corrects existing occurrences of the incorrect binding. The memory-controller and l2-cache-controller are the only affected nodes. Signed-off-by: Bradley Hughes bhug...@silicontkx.com ---

[PATCH v2 2/2] EDAC: Remove deprecated bindings for MPC85xx

2010-07-21 Thread Bradley Hughes
The fsl,85... style bindings for the l2-cache-controller and memory-controller were intended to be deprected as of 2.6.30 per comment in drivers/edac/mpc85xx_edac.c. Previous patch in this series updates all DTS to use the fsl,mpc85... style binding for these two nodes, allowing us to finally

[PATCH] powerpc: rename immap_86xx.h to fsl_guts.h, and add 85xx support

2010-07-21 Thread Timur Tabi
The immap_86xx.h header file only defines one data structure: the global utilities register set found on Freescale PowerPC SOCs. Rename this file to fsl_guts.h to reflect its true purpose, and extend it to cover the GUTS register set on 85xx chips. Signed-off-by: Timur Tabi ti...@freescale.com

Re: [PATCH v2] edac: mpc85xx: Add support for new MPCxxx/Pxxxx EDAC controllers

2010-07-21 Thread Andrew Morton
On Fri, 16 Jul 2010 15:12:24 -0500 Scott Wood scottw...@freescale.com wrote: On Thu, 15 Jul 2010 22:25:07 +0400 Anton Vorontsov avoront...@mvista.com wrote: Simply add proper IDs into the device table. Signed-off-by: Anton Vorontsov avoront...@mvista.com --- It appears that the

Re: [PATCH v2 0/2] Adding DTS for the STx GP3-SSA MPC8555 board

2010-07-21 Thread Wolfgang Denk
Dear Bradley Hughes, In message aanlktimmb_pshxaidvbffdbcqhrly13qiz9g2ez1v...@mail.gmail.com you wrote: This version uses fsl,mpc8555... instead of fsl,85... notation. Such comments should go below the --- line. There is also an 8541 version of this board so DTS for this board is specific

Re: [PATCH v2] edac: mpc85xx: Add support for new MPCxxx/Pxxxx EDAC controllers

2010-07-21 Thread Scott Wood
On Wed, 21 Jul 2010 15:39:33 -0700 Andrew Morton a...@linux-foundation.org wrote: On Fri, 16 Jul 2010 15:12:24 -0500 Scott Wood scottw...@freescale.com wrote: drivers/edac/mpc85xx_edac.c |8 1 files changed, 8 insertions(+), 0 deletions(-) diff --git

[PATCH 1/5] drivercore/of: Add OF style matching to platform bus

2010-07-21 Thread Grant Likely
As part of the merge between platform bus and of_platform bus, add the ability to do of-style matching to the platform bus. Signed-off-by: Grant Likely grant.lik...@secretlab.ca CC: Greg Kroah-Hartman gre...@suse.de CC: Michal Simek mon...@monstr.eu CC: Grant Likely grant.lik...@secretlab.ca CC:

[PATCH 3/5] of/platform: remove all of_bus_type and of_platform_bus_type references

2010-07-21 Thread Grant Likely
Both of_bus_type and of_platform_bus_type are just #define aliases for the platform bus. This patch removes all references to them and switches to the of_register_platform_driver()/of_unregister_platform_driver() API for registering. Subsequent patches will convert each user of

[PATCH 4/5] of: remove asm/of_platform.h

2010-07-21 Thread Grant Likely
Only thing left in it is of_instantiate_rtc() which can be moved to asm/prom.h on PowerPC and is unused in microblaze. Signed-off-by: Grant Likely grant.lik...@secretlab.ca --- arch/microblaze/include/asm/of_platform.h | 19 --- arch/powerpc/include/asm/of_platform.h| 16

[PATCH 1/2] MPC85xx: add definitions for PCI error detection soc part

2010-07-21 Thread Dmitry Eremin-Solenikov
Add definitions for PCI error detection device to be handled by (already existing) mpc85xx_edac.c driver. Signed-off-by: Dmitry Eremin-Solenikov dbarysh...@gmail.com --- arch/powerpc/boot/dts/mpc8536ds.dts|7 +++ arch/powerpc/boot/dts/mpc8536ds_36b.dts|7 +++

Re: [PATCH 1/5] drivercore/of: Add OF style matching to platform bus

2010-07-21 Thread Greg KH
On Wed, Jul 21, 2010 at 05:39:54PM -0600, Grant Likely wrote: As part of the merge between platform bus and of_platform bus, add the ability to do of-style matching to the platform bus. Signed-off-by: Grant Likely grant.lik...@secretlab.ca CC: Greg Kroah-Hartman gre...@suse.de CC: Michal

Re: [alsa-devel] [PATCH] powerpc: rename immap_86xx.h to fsl_guts.h, and add 85xx support

2010-07-21 Thread Timur Tabi
On Wed, Jul 21, 2010 at 5:05 PM, Timur Tabi ti...@freescale.com wrote: The immap_86xx.h header file only defines one data structure: the global utilities register set found on Freescale PowerPC SOCs.  Rename this file to fsl_guts.h to reflect its true purpose, and extend it to cover the GUTS

[PATCH v4 0/2] powerpc: add support for new hcall H_BEST_ENERGY

2010-07-21 Thread Vaidyanathan Srinivasan
Hi Ben, The following series adds a kernel module for powerpc pseries platforms in order to export platform energy management capabilities. The module exports data from a new hypervisor call H_BEST_ENERGY. Some of the comments and suggestions made on the previous iteration of the patch has been

[PATCH v4 1/2] powerpc: cleanup APIs for cpu/thread/core mappings

2010-07-21 Thread Vaidyanathan Srinivasan
These APIs take logical cpu number as input Change cpu_first_thread_in_core() to cpu_leftmost_thread_sibling() Change cpu_last_thread_in_core() to cpu_rightmost_thread_sibling() These APIs convert core number (index) to logical cpu/thread numbers Add cpu_first_thread_of_core(int core) Changed

[PATCH v4 2/2] powerpc: add support for new hcall H_BEST_ENERGY

2010-07-21 Thread Vaidyanathan Srinivasan
Create sysfs interface to export data from H_BEST_ENERGY hcall that can be used by administrative tools on supported pseries platforms for energy management optimizations. /sys/device/system/cpu/pseries_(de)activate_hint_list and

Re: [PATCH v3 2/2] powerpc: add support for new hcall H_BEST_ENERGY

2010-07-21 Thread Vaidyanathan Srinivasan
* Michael Neuling mi...@neuling.org [2010-06-28 16:11:06]: [snip] These hints are abstract number given by the hypervisor based on the extended knowledge the hypervisor has regarding the current system topology and resource mappings. The activate and the deactivate part is for the two

[PATCH] powerpc: print cores passed to firmware in decimal

2010-07-21 Thread Michael Neuling
Currently we look pretty stupid when printing out the number of cores passed to FW Max number of cores passed to firmware: 0x0080 So I've change this to print in decimal: Max number of cores passed to firmware: 128 (NR_CPUS = 256) This required adding a prom_print_dec()

Re: [PATCH 0/5] Eliminate of_platform_bus_type

2010-07-21 Thread David Miller
From: Grant Likely grant.lik...@secretlab.ca Date: Wed, 21 Jul 2010 17:39:49 -0600 David, you'll also want to take a look at patches 4 5 to see if you agree with my decisions on where I move symbols in the header files. Looks fine to me. ___

Re: [PATCH 2/5] of: Merge of_platform_bus_type with platform_bus_type

2010-07-21 Thread David Miller
From: Grant Likely grant.lik...@secretlab.ca Date: Wed, 21 Jul 2010 17:40:00 -0600 of_platform_bus was being used in the same manner as the platform_bus. The only difference being that of_platform_bus devices are generated from data in the device tree, and platform_bus devices are usually

Re: [PATCH 3/5] of/platform: remove all of_bus_type and of_platform_bus_type references

2010-07-21 Thread David Miller
From: Grant Likely grant.lik...@secretlab.ca Date: Wed, 21 Jul 2010 17:40:05 -0600 Both of_bus_type and of_platform_bus_type are just #define aliases for the platform bus. This patch removes all references to them and switches to the

Re: [PATCH 4/5] of: remove asm/of_platform.h

2010-07-21 Thread David Miller
From: Grant Likely grant.lik...@secretlab.ca Date: Wed, 21 Jul 2010 17:40:10 -0600 Only thing left in it is of_instantiate_rtc() which can be moved to asm/prom.h on PowerPC and is unused in microblaze. Signed-off-by: Grant Likely grant.lik...@secretlab.ca Acked-by: David S. Miller

Re: [PATCH 5/5] of: remove asm/of_device.h

2010-07-21 Thread David Miller
From: Grant Likely grant.lik...@secretlab.ca Date: Wed, 21 Jul 2010 17:40:15 -0600 It is mostly unused now. Sparc has a few defines left in it, but they can be moved to other headers. Removing this header means that new architectures adding CONFIG_OF support don't need to also add this