Re: [PATCH 09/13] powerpc: Disable KMSAN checks on functions which walk the stack

2024-01-09 Thread Nicholas Miehlbradt
On 14/12/2023 8:00 pm, Christophe Leroy wrote: Le 14/12/2023 à 06:55, Nicholas Miehlbradt a écrit : Functions which walk the stack read parts of the stack which cannot be instrumented by KMSAN e.g. the backchain. Disable KMSAN sanitization of these functions to prevent false positives.

Re: [PATCH 12/13] powerpc/string: Add KMSAN support

2024-01-09 Thread Nicholas Miehlbradt
On 14/12/2023 8:25 pm, Christophe Leroy wrote: Le 14/12/2023 à 06:55, Nicholas Miehlbradt a écrit : KMSAN expects functions __mem{set,cpy,move} so add aliases pointing to the respective functions. Disable use of architecture specific memset{16,32,64} to ensure that metadata is correctly

Re: [PATCH 10/13] powerpc: Define KMSAN metadata address ranges for vmalloc and ioremap

2024-01-09 Thread Nicholas Miehlbradt
On 14/12/2023 8:17 pm, Christophe Leroy wrote: Le 14/12/2023 à 06:55, Nicholas Miehlbradt a écrit : Splits the vmalloc region into four. The first quarter is the new vmalloc region, the second is used to store shadow metadata and the third is used to store origin metadata. The fourth

[PATCH 3/3] treewide: Update LLVM Bugzilla links

2024-01-09 Thread Nathan Chancellor
LLVM moved their issue tracker from their own Bugzilla instance to GitHub issues. While all of the links are still valid, they may not necessarily show the most up to date information around the issues, as all updates will occur on GitHub, not Bugzilla. Another complication is that the Bugzilla

[PATCH 1/3] selftests/bpf: Update LLVM Phabricator links

2024-01-09 Thread Nathan Chancellor
reviews.llvm.org was LLVM's Phabricator instances for code review. It has been abandoned in favor of GitHub pull requests. While the majority of links in the kernel sources still work because of the work Fangrui has done turning the dynamic Phabricator instance into a static archive, there are

[PATCH 2/3] arch and include: Update LLVM Phabricator links

2024-01-09 Thread Nathan Chancellor
reviews.llvm.org was LLVM's Phabricator instances for code review. It has been abandoned in favor of GitHub pull requests. While the majority of links in the kernel sources still work because of the work Fangrui has done turning the dynamic Phabricator instance into a static archive, there are

[PATCH 0/3] Update LLVM Phabricator and Bugzilla links

2024-01-09 Thread Nathan Chancellor
/bpf/prog_tests/xdpwall.c | 2 +- .../selftests/bpf/progs/test_core_reloc_type_id.c | 2 +- 23 files changed, 40 insertions(+), 40 deletions(-) --- base-commit: 0dd3ee31125508cd67f7e7172247f05b7fd1753a change-id: 20240109-update-llvm-links-d03f9d649e1e Best regards, -- Nathan Chancellor

Re: [PATCH] powerpc/Makefile: Remove bits related to the previous use of -mcmodel=large

2024-01-09 Thread Segher Boessenkool
On Tue, Jan 09, 2024 at 03:15:35PM +, Christophe Leroy wrote: > > CFLAGS-$(CONFIG_PPC64)+= $(call cc-option,-mcall-aixdesc) > > endif > > endif > > -CFLAGS-$(CONFIG_PPC64) += $(call cc-option,-mcmodel=medium,$(call > > cc-option,-mminimal-toc)) > > +CFLAGS-$(CONFIG_PPC64) +=

Re: [PATCH 1/4] arm: ptdump: Rename CONFIG_DEBUG_WX to CONFIG_ARM_DEBUG_WX

2024-01-09 Thread Florian Fainelli
On 1/9/24 04:14, Christophe Leroy wrote: CONFIG_DEBUG_WX is a core option defined in mm/Kconfig.debug To avoid any future conflict, rename ARM version into CONFIG_ARM_DEBUG_WX. Signed-off-by: Christophe Leroy Looks fine, you might also want to s/CONFIG_DEBUG_WX/CONFIG_ARM_DEBUG_WX/ in

Re: [PATCH] powerpc/Makefile: Remove bits related to the previous use of -mcmodel=large

2024-01-09 Thread Christophe Leroy
Le 09/01/2024 à 14:34, Naveen N Rao a écrit : > All supported compilers today (gcc v5.1+ and clang v11+) have support for > -mcmodel=medium. As such, NO_MINIMAL_TOC is no longer being set. Remove > NO_MINIMAL_TOC as well as the fallback to -mminimal-toc. > > Signed-off-by: Naveen N Rao

Re: [PATCH 3/3] ASoC: dt-bindings: fsl,micfil: Add compatible string for i.MX95 platform

2024-01-09 Thread Daniel Baluta
On Tue, Jan 9, 2024 at 9:58 AM Chancel Liu wrote: > > Add compatible string "fsl,imx95-micfil" for i.MX95 platform. > > Signed-off-by: Chancel Liu > --- > .../devicetree/bindings/sound/fsl,micfil.yaml | 15 +++ > 1 file changed, 11 insertions(+), 4 deletions(-) > > diff --git

Re: [PATCH 4/4] ptdump: add check_wx_pages debugfs attribute

2024-01-09 Thread Heiko Carstens
On Tue, Jan 09, 2024 at 01:14:38PM +0100, Christophe Leroy wrote: > Add a writable attribute in debugfs to trigger a > W^X pages check at any time. > > To trigger the test, just echo any numeric value into > /sys/kernel/debug/check_wx_pages > > The result is provided into dmesg. > >

[PATCH] powerpc/Makefile: Remove bits related to the previous use of -mcmodel=large

2024-01-09 Thread Naveen N Rao
All supported compilers today (gcc v5.1+ and clang v11+) have support for -mcmodel=medium. As such, NO_MINIMAL_TOC is no longer being set. Remove NO_MINIMAL_TOC as well as the fallback to -mminimal-toc. Signed-off-by: Naveen N Rao --- arch/powerpc/Makefile | 6 +-

Re: [PATCH 2/4] arm64, powerpc, riscv, s390, x86: Refactor CONFIG_DEBUG_WX

2024-01-09 Thread Alexandre Ghiti
Hi Christophe, On 09/01/2024 13:14, Christophe Leroy wrote: All architectures using the core ptdump functionality also implement CONFIG_DEBUG_WX, and they all do it more or less the same way, with a function called debug_checkwx() that is called by mark_rodata_ro(), which is a substitute to

[PATCH 4/4] ptdump: add check_wx_pages debugfs attribute

2024-01-09 Thread Christophe Leroy
Add a writable attribute in debugfs to trigger a W^X pages check at any time. To trigger the test, just echo any numeric value into /sys/kernel/debug/check_wx_pages The result is provided into dmesg. Signed-off-by: Christophe Leroy --- mm/ptdump.c | 19 +++ 1 file changed, 19

[PATCH 3/4] powerpc,s390: Define ptdump_check_wx() regardless of CONFIG_DEBUG_WX

2024-01-09 Thread Christophe Leroy
Following patch will use ptdump_check_wx() regardless of CONFIG_DEBUG_WX, so define it at all times of powerpc and s390 just like other architectures. Though keep the WARN_ON_ONCE() only when CONFIG_DEBUG_WX is set. Signed-off-by: Christophe Leroy --- arch/powerpc/mm/ptdump/ptdump.c | 7 +++

[PATCH 2/4] arm64, powerpc, riscv, s390, x86: Refactor CONFIG_DEBUG_WX

2024-01-09 Thread Christophe Leroy
All architectures using the core ptdump functionality also implement CONFIG_DEBUG_WX, and they all do it more or less the same way, with a function called debug_checkwx() that is called by mark_rodata_ro(), which is a substitute to ptdump_check_wx() when CONFIG_DEBUG_WX is set and a no-op

[PATCH 1/4] arm: ptdump: Rename CONFIG_DEBUG_WX to CONFIG_ARM_DEBUG_WX

2024-01-09 Thread Christophe Leroy
CONFIG_DEBUG_WX is a core option defined in mm/Kconfig.debug To avoid any future conflict, rename ARM version into CONFIG_ARM_DEBUG_WX. Signed-off-by: Christophe Leroy --- arch/arm/Kconfig.debug| 2 +- arch/arm/include/asm/ptdump.h | 6 +++--- 2 files changed, 4 insertions(+), 4

[PATCH 0/4] Refactor CONFIG_DEBUG_WX and check_wx_pages debugfs attribute

2024-01-09 Thread Christophe Leroy
Refer old discussion at https://lore.kernel.org/lkml/20200422152656.GF676@willie-the-truck/T/#m802eaf33efd6f8d575939d157301b35ac0d4a64f And https://github.com/KSPP/linux/issues/35 This series refactors CONFIG_DEBUG_WX for the 5 architectures implementing CONFIG_GENERIC_PTDUMP First rename stuff

Re: [PATCH] powerpc: Fix preserved memory size for int-vectors

2024-01-09 Thread Christophe Leroy
Le 09/01/2024 à 04:38, GUO Zihua a écrit : > [Vous ne recevez pas souvent de courriers de guozi...@huawei.com. Découvrez > pourquoi ceci est important à https://aka.ms/LearnAboutSenderIdentification ] > > The first 32k of memory is reserved for interrupt vectors, however for > powerpc64 this

Re: [PATCH] powerpc/ps3_defconfig: Disable PPC64_BIG_ENDIAN_ELF_ABI_V2

2024-01-09 Thread Geert Uytterhoeven
Hi Geoff, On Wed, 27 Dec 2023, Geoff Levand wrote: On 12/27/23 10:27, Michael Ellerman wrote: Geoff Levand writes: Commit 8c5fa3b5c4df3d071dab42b04b971df370d99354 (powerpc/64: Make ELFv2 the default for big-endian builds), merged in Linux-6.5-rc1 changes the calling ABI in a way that

[PATCH 3/3] ASoC: dt-bindings: fsl,micfil: Add compatible string for i.MX95 platform

2024-01-09 Thread Chancel Liu
Add compatible string "fsl,imx95-micfil" for i.MX95 platform. Signed-off-by: Chancel Liu --- .../devicetree/bindings/sound/fsl,micfil.yaml | 15 +++ 1 file changed, 11 insertions(+), 4 deletions(-) diff --git a/Documentation/devicetree/bindings/sound/fsl,micfil.yaml