[PATCH 2.6.19-rc2] [REVISED] net/ipv4/multipath_wrandom.c: check kmalloc() return value.

2006-10-23 Thread Amit Choudhary
Description: Check the return value of kmalloc() in function wrandom_set_nhinfo(), in file net/ipv4/multipath_wrandom.c. Signed-off-by: Amit Choudhary [EMAIL PROTECTED] diff --git a/net/ipv4/multipath_wrandom.c b/net/ipv4/multipath_wrandom.c index 92b0482..bcdb1f1 100644 ---

Re: [PATCH 2.6.19-rc2] [REVISED] net/ipv4/multipath_wrandom.c: check kmalloc() return value.

2006-10-23 Thread James Morris
On Sun, 22 Oct 2006, Amit Choudhary wrote: Description: Check the return value of kmalloc() in function wrandom_set_nhinfo(), in file net/ipv4/multipath_wrandom.c. Signed-off-by: Amit Choudhary [EMAIL PROTECTED] Acked-by: James Morris [EMAIL PROTECTED] @@ -242,6 +242,9 @@ static void

Re: [PATCH 1/4][CRYPTO][IPsec] pass the flags to the internal tfm allocation

2006-10-23 Thread Kazunori MIYAZAWA
On Sun, 22 Oct 2006 14:53:57 +1000 Herbert Xu [EMAIL PROTECTED] wrote: On Wed, Oct 18, 2006 at 11:26:06AM +0900, Kazunori MIYAZAWA wrote: XCBC needs to allocate the tfm as CBC mode to use xor function in the tfm. I'm sorry but this isn't going to fly. The mode argument is obsolete and

Re: [PATCH 1/4][CRYPTO][IPsec] pass the flags to the internal tfm allocation

2006-10-23 Thread Herbert Xu
On Mon, Oct 23, 2006 at 07:08:39PM +0900, Kazunori MIYAZAWA wrote: I send the patch which does not use the CBC mode. I chose the short term solution and copied the function. Thanks Miyazawa-san! This patch does not need the patch of [PATCH 1/4]. Should I re-send [PATCH 3/4] and [PATCH

Re: [PATCH REPOST 1/2] NET: Accurate packet scheduling for ATM/ADSL (kernel)

2006-10-23 Thread Russell Stuart
On Thu, 2006-10-19 at 16:38 +0200, Patrick McHardy wrote: I still think this patch shouldn't go in. There's no point in doing the same thing twice, and I haven't heard a compelling argument why it has to be done in a way that only helps qdiscs using rtabs while ignoring statistics and

Re: [PATCH 2.6.19-rc2] [REVISED] net/ipv4/multipath_wrandom.c: check kmalloc() return value.

2006-10-23 Thread Patrick McHardy
Amit Choudhary wrote: Description: Check the return value of kmalloc() in function wrandom_set_nhinfo(), in file net/ipv4/multipath_wrandom.c. Signed-off-by: Amit Choudhary [EMAIL PROTECTED] diff --git a/net/ipv4/multipath_wrandom.c b/net/ipv4/multipath_wrandom.c index 92b0482..bcdb1f1

Re: [patch 1/2]d80211: hardware TKIP support for ipw3945

2006-10-23 Thread Jiri Benc
On Fri, 20 Oct 2006 17:19:36 +0800, Hong Liu wrote: --- a/include/net/d80211.h +++ b/include/net/d80211.h @@ -176,6 +176,7 @@ struct ieee80211_tx_control { */ int icv_len:8; /* Length of the ICV/MIC field in octets */ int iv_len:8; /* Length of the IV field

Re: [PATCH REPOST 1/2] NET: Accurate packet scheduling for ATM/ADSL (kernel)

2006-10-23 Thread Patrick McHardy
Russell Stuart wrote: On Thu, 2006-10-19 at 16:38 +0200, Patrick McHardy wrote: I still think this patch shouldn't go in. There's no point in doing the same thing twice, and I haven't heard a compelling argument why it has to be done in a way that only helps qdiscs using rtabs while ignoring

Re: [patch 1/2]d80211: hardware TKIP support for ipw3945

2006-10-23 Thread Johannes Berg
On Mon, 2006-10-23 at 14:40 +0200, Jiri Benc wrote: I don't like extending ieee80211_tx_control by 16 more bytes. The driver is required to store a copy of each ieee80211_tx_control (because it's copied to ieee80211_tx_status). I don't have a better idea, though. Anybody? A pointer that goes

[PATCH 2.6.18] defxx: Big-endian hosts support

2006-10-23 Thread Maciej W. Rozycki
The PDQ DMA engine requires a different byte-swapping mode for big-endian hosts; also the MAC address which is read from a register through PIO has to be byte-swapped. These changes have been verified with DEFPA-DC (PCI) boards and a Broadcom BCM91250A (MIPS CPU based) host. Signed-off-by:

Re: [patch 1/2]d80211: hardware TKIP support for ipw3945

2006-10-23 Thread Jiri Benc
On Mon, 23 Oct 2006 14:48:00 +0200, Johannes Berg wrote: On Mon, 2006-10-23 at 14:40 +0200, Jiri Benc wrote: I don't like extending ieee80211_tx_control by 16 more bytes. The driver is required to store a copy of each ieee80211_tx_control (because it's copied to ieee80211_tx_status). I

Re: [patch 1/2]d80211: hardware TKIP support for ipw3945

2006-10-23 Thread Stuffed Crust
On Mon, Oct 23, 2006 at 02:40:28PM +0200, Jiri Benc wrote: int icv_len:8; /* Length of the ICV/MIC field in octets */ int iv_len:8; /* Length of the IV field in octets */ + u8 rc4key[16]; /* generated RC4 key for hw TKIP */ I don't like extending ieee80211_tx_control by 16 more

Re: [PATCH 2.6.18] defxx: Big-endian hosts support

2006-10-23 Thread Christoph Hellwig
On Mon, Oct 23, 2006 at 01:53:17PM +0100, Maciej W. Rozycki wrote: + data = cpu_to_le32(data); This is rather ugly and not provable by static typechecking. Please always use spearate variables/structs for device and host endian values, and run the resulting driver through sparse to make

Re: [PATCH 0/8] e100, e1000: Fixes for netdev-2.6#upstream-fixes

2006-10-23 Thread Auke Kok
Jeff Garzik wrote: Kok, Auke wrote: Hi, The following fixes targeted to netdev-2.6#upstream-fixes are available through git: git pull git://lost.foo-projects.org/~ahkok/git/netdev-2.6 upstream-fixes hrm. since another e100 fixes got applied, can you either (a) update the above URL for

Re: [patch 1/2]d80211: hardware TKIP support for ipw3945

2006-10-23 Thread David Kimdon
On Mon, Oct 23, 2006 at 02:40:28PM +0200, Jiri Benc wrote: On Fri, 20 Oct 2006 17:19:36 +0800, Hong Liu wrote: --- a/include/net/d80211.h +++ b/include/net/d80211.h @@ -176,6 +176,7 @@ struct ieee80211_tx_control { */ int icv_len:8; /* Length of the ICV/MIC field

Re: [PATCH] atm: fix horizon init section usage

2006-10-23 Thread Randy.Dunlap
David Miller wrote: From: Randy.Dunlap [EMAIL PROTECTED] Date: Sun, 22 Oct 2006 21:32:20 -0700 David Miller wrote: From: Randy Dunlap [EMAIL PROTECTED] Date: Sun, 22 Oct 2006 19:13:09 -0700 From: Randy Dunlap [EMAIL PROTECTED] hrz_init() is called from the probe function, which is

Re: [patch 1/2]d80211: hardware TKIP support for ipw3945

2006-10-23 Thread Jiri Benc
On Mon, 23 Oct 2006 08:29:31 -0700, David Kimdon wrote: We could be more selective about what the driver is required to return in ieee80211_tx_status, the rc4key isn't particularily interesting to ieee80211_tx_status(). I expect there are other uninteresting fields (tx_rate, rts_cts_rate,

Re: 2.6.18.1 hangs after resuming from apm suspend

2006-10-23 Thread Rafael J. Wysocki
On Monday, 23 October 2006 09:47, Christian stahl wrote: After upgrading from 2.6.16.20 to 2.6.18.1 my Siemens Scenic Mobile 750AGP Notebook hangs after resuming from suspend. However resuming from suspend works properly if: - the prism 2.5 WLAN card is removed before suspending - the

Re: [PATCH] bcm43xx-softmac: add PCI-E code

2006-10-23 Thread Michael Buesch
On Monday 23 October 2006 15:22, Daniel Drake wrote: Michael Buesch wrote: Please try 2.6.18.1 or wireless-2.6. 2.6.18.1 (with the PCI-E patch) crashes on modprobe: bcm43xx driver ACPI: PCI Interrupt Link [LK1E] enabled at IRQ 11 ACPI: PCI Interrupt :03:00.0[A] - Link [LK1E] -

Re: [PATCH] bcm43xx-softmac: add PCI-E code

2006-10-23 Thread Daniel Drake
Michael Buesch wrote: Please try 2.6.18.1 or wireless-2.6. wireless-2.6.git has the same problems as the earlier reports on 2.6.19-rc2: ifconfig up,down,up fails, plus it's hard to get connectivity. Daniel - To unsubscribe from this list: send the line unsubscribe netdev in the body of a

Re: [PATCH] bcm43xx-softmac: add PCI-E code

2006-10-23 Thread Daniel Drake
Michael Buesch wrote: Yeah, try to find out why. I can only repeat myself: No developer has got a PCI-E card. If there are problems, everybody has to find out by himself why it does not work. Try to find out why it can not determine the CHIP-ID. Any point diagnosing this when this does not

Re: [PATCH] bcm43xx-softmac: add PCI-E code

2006-10-23 Thread Michael Buesch
On Monday 23 October 2006 16:35, Daniel Drake wrote: Michael Buesch wrote: Yeah, try to find out why. I can only repeat myself: No developer has got a PCI-E card. If there are problems, everybody has to find out by himself why it does not work. Try to find out why it can not determine

[PATCH 1/3] ethtool: marvell register dump

2006-10-23 Thread Stephen Hemminger
This is a consolidation of earlier marvell register decode patches to ethtool. Signed-off-by: Stephen Hemminger [EMAIL PROTECTED] --- marvell.c | 106 - 1 files changed, 77 insertions(+), 29 deletions(-) diff --git a/marvell.c

Re: [patch 3/6] 2.6.18: sb1250-mac: Phylib IRQ handling fixes

2006-10-23 Thread Maciej W. Rozycki
On Fri, 20 Oct 2006, Andy Fleming wrote: I've been trying to figure out this problem since you posted this, and I'm not sure I understand it fully (And I apologize profusely for the horror that is the PHY interrupt handling code. I'd love to rewrite it if there's some First of all I don't

[PATCH 2/3] ethtool: flie option to register dump

2006-10-23 Thread Stephen Hemminger
Add ability to take old raw dumps from a file and decode them. It is kind of limited because you still need to have same device as the raw file, but useful for maintainers to decode raw dumps. Signed-off-by: Stephen Hemminger [EMAIL PROTECTED] --- ethtool.8 | 13 - ethtool.c |

[PATCH 3/3] ethtool: allow force hex in register dump

2006-10-23 Thread Stephen Hemminger
Sometimes the device decode logic just gets in the way so add a force hex option to register dump. Signed-off-by: Stephen Hemminger [EMAIL PROTECTED] --- ethtool.8 |1 + ethtool.c | 11 +++ 2 files changed, 8 insertions(+), 4 deletions(-) diff --git a/ethtool.8 b/ethtool.8 index

[PATCH 1/1] r8169: perform a PHY reset before any other operation at boot time

2006-10-23 Thread Francois Romieu
Realtek's 8139/810x (0x8136) PCI-E comes with a touchy PHY. A big heavy reset seems to calm it down. Fix for http://bugzilla.kernel.org/show_bug.cgi?id=7378. Signed-off-by: Francois Romieu [EMAIL PROTECTED] Signed-off-by: Darren Salt [EMAIL PROTECTED] --- drivers/net/r8169.c | 18

[no subject]

2006-10-23 Thread Sachin K
subscribe - To unsubscribe from this list: send the line unsubscribe netdev in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH REPOST 1/2] NET: Accurate packet scheduling for ATM/ADSL (kernel)

2006-10-23 Thread Russell Stuart
On Mon, 2006-10-23 at 14:39 +0200, Patrick McHardy wrote: The implementation may be different, but the intention and the result is the same. I probably would mind less if it wouldn't affect userspace compatibility, but we need to carry this stuff for ever even if we add another implementation

[RFC] [PATCH 0/3] Add Regulatory Domain support to d80211

2006-10-23 Thread Luis R. Rodriguez
The following patches extend 802.11 regulatory domain support of the d80211 wireless stack through two modules: 1. ieee80211_regdomains 2. iso3166-1 These modules provide an interface for management of regulatory domains. Stack support has not been completed as it requires changes which should

Re: [RFC] [PATCH 1/3] adds iso3166-1 support

2006-10-23 Thread Luis R. Rodriguez
iso3166-1 ISO 3166-1, as part of the ISO 3166 standard, provides codes for the names of countries and dependent areas. It was first published in 1974 by the International Organization for Standardization (ISO) and defines three different codes for each area: * ISO 3166-1 alpha-2, a two-letter

Re: [RFC] [PATCH 3/3] Kconfig update for regulatory domain

2006-10-23 Thread Luis R. Rodriguez
These are the current Kconfig changes needed to introduce ieee80211_regdomains to d80211. Each in-kernel regulatory domain is made available as optional. Each country which currently complies to each regulatory domain is listed on the help menu for each available regulatory domain. The mapping

Re: [RFC] [PATCH 0/3] Add Regulatory Domain support to d80211

2006-10-23 Thread Johannes Berg
On Mon, 2006-10-23 at 18:41 -0400, Luis R. Rodriguez wrote: The current setup on d80211.h makes regulatory domains device specific. I believe this should be changed to be stack-specific -- that is, all drivers adhere to the restrictions set by the stack's current regulatory domain. There

RFC: Removing busy-spin in pktgen.

2006-10-23 Thread Ben Greear
I'm planning to re-merge my long-lost pktgen branch with the kernel tree's pktgen. I believe the main difference is that my out-of-tree pktgen does not do the busy-spin, but waits on a queue for the net-device to wake it's tx-queue when over-driving a NIC. To implement this, I added a hook in

How to grab a block of binary data w/out using ioctls?

2006-10-23 Thread Ben Greear
Since IOCTLs are out of favor these days, what would be a preferred way to get a block of binary data out of the kernel? I just want to grab a stats structure (well-aligned 32 and 64-bit counters and fixed-length strings) for a pktgen interface. Can you do this with seq-files somehow? Thanks,

Re: [RFC] [PATCH 3/3] Kconfig update for regulatory domain

2006-10-23 Thread David Kimdon
This last chunk is broken: . . . Hunk #2 FAILED at 90. --- wireless-dev-old/net/d80211/Kconfig 2006-10-23 13:56:11.0 -0400 +++ wireless-dev/net/d80211/Kconfig 2006-10-23 17:04:12.0 -0400 @@ -16,8 +90,6 @@ config D80211_LEDS This option enables a few LED

Re: How to grab a block of binary data w/out using ioctls?

2006-10-23 Thread Randy Dunlap
On Mon, 23 Oct 2006 17:44:24 -0700 Ben Greear wrote: Since IOCTLs are out of favor these days, what would be a preferred way to get a block of binary data out of the kernel? I just want to grab a stats structure (well-aligned 32 and 64-bit counters and fixed-length strings) for a pktgen

Re: [PKT_SCHED] netem: Orphan SKB when adding to queue.

2006-10-23 Thread Randy Dunlap
On Mon, 23 Oct 2006 19:08:17 +0200 Patrick McHardy wrote: Linux Kernel Mailing List wrote: commit 4e8a5201506423e0241202de1349422af4260296 tree e562a6cdbee37e3805551af92b264fa93d722c4b parent 6a43487f43fbd4e03c606dcb62b98374a3af88fc author David S. Miller [EMAIL PROTECTED] 1161576033

Re: How to grab a block of binary data w/out using ioctls?

2006-10-23 Thread Jeff Garzik
On Mon, Oct 23, 2006 at 09:54:48PM -0700, Randy Dunlap wrote: Similarly, sysfs is desirable in some circumstances, but not for blocks of binary data. sysfs specifically has APIs for binary data... Jeff - To unsubscribe from this list: send the line unsubscribe netdev in the body of

Re: How to grab a block of binary data w/out using ioctls?

2006-10-23 Thread Randy.Dunlap
Jeff Garzik wrote: On Mon, Oct 23, 2006 at 09:54:48PM -0700, Randy Dunlap wrote: Similarly, sysfs is desirable in some circumstances, but not for blocks of binary data. sysfs specifically has APIs for binary data... Ack that, sorry about that. -- ~Randy - To unsubscribe from this list:

Re: [RFC] [PATCH 3/3] Kconfig update for regulatory domain

2006-10-23 Thread Luis R. Rodriguez
On 10/23/06, David Kimdon [EMAIL PROTECTED] wrote: This last chunk is broken: . . . Hunk #2 FAILED at 90. You can ignore this hunk. --- wireless-dev-old/net/d80211/Kconfig 2006-10-23 13:56:11.0 -0400 +++ wireless-dev/net/d80211/Kconfig 2006-10-23 17:04:12.0 -0400

Re: [RFC] [PATCH 0/3] Add Regulatory Domain support to d80211

2006-10-23 Thread Luis R. Rodriguez
On 10/23/06, Johannes Berg [EMAIL PROTECTED] wrote: On Mon, 2006-10-23 at 18:41 -0400, Luis R. Rodriguez wrote: The current setup on d80211.h makes regulatory domains device specific. I believe this should be changed to be stack-specific -- that is, all drivers adhere to the restrictions set

[PATCH] wireless-2.6 zd1211rw check against regulatory domain rather than hardcoded value of 11

2006-10-23 Thread Holden Karau
From: Holden Karau [EMAIL PROTECTED] http://www.holdenkarau.com I have made a small patch for the zd1211rw driver which uses the boundry channels of the regulatory domain, rather than the hard coded values of 1 11. Signed-off-by: Holden Karau [EMAIL PROTECTED] http://www.holdenkarau.com --- I'm

[PATCH 5/5] netpoll: interface cleanup

2006-10-23 Thread Stephen Hemminger
Trivial cleanup of netpoll interface. Use constants for size, to make usage clear. Signed-off-by: Stephen Hemminger [EMAIL PROTECTED] --- netpoll.orig/include/linux/netpoll.h +++ netpoll/include/linux/netpoll.h @@ -12,15 +12,14 @@ #include linux/rcupdate.h #include linux/list.h -struct

[PATCH 2/5] netpoll: cleanup queued transmit

2006-10-23 Thread Stephen Hemminger
This patch changes the queued transmit path of netpoll, to use similar logic to the non-queued path. We don't want netpoll messages going into NIT and network qdisc logic. Signed-off-by: Stephen Hemminger [EMAIL PROTECTED] --- netpoll.orig/net/core/netpoll.c +++ netpoll/net/core/netpoll.c @@

[PATCH 3/5] netpoll: cleanup transmit retry logic

2006-10-23 Thread Stephen Hemminger
Change netpoll transmit logic so: * retries are per attempt not global. don't want to start drop packets just because of temporary blockage. * acquire xmit_lock correctly * if device is not available just drop * always queue if send fails, don't drop Signed-off-by: Stephen Hemminger [EMAIL

[PATCH 4/5] netpoll: move drop hook inline

2006-10-23 Thread Stephen Hemminger
Rather than have separate drop callback hook, just put the logic inline in netpoll. The code is cleaner and netconsole is the only user of netpoll. Signed-off-by: Stephen Hemminger [EMAIL PROTECTED] --- netpoll.orig/drivers/net/netconsole.c +++ netpoll/drivers/net/netconsole.c @@ -60,7 +60,6 @@

[PATCH 1/5] netpoll: use sk_buff_head for txq

2006-10-23 Thread Stephen Hemminger
This is the 3rd version of the netpoll patches. The first patch switches from open-coded skb list to using a skb_buff_head. It also flushes packets from queue when device is removed from netpoll. Signed-off-by: Stephen Hemminger [EMAIL PROTECTED] --- netpoll.orig/net/core/netpoll.c +++

Re: [PATCH] sky2: 88E803X transmit lockup

2006-10-23 Thread Daniel J Blueman
Stephen Hemminger wrote: The reason sky2 driver was locking up on transmit on the Yukon-FE chipset is that it was misconfiguring the internal RAM buffer so the transmitter and receiver were sharing the same space. The code assumed there was 16K of RAM on Yukon-FE (taken from vendor driver

Re: [PATCH] bcm43xx-softmac: add PCI-E code

2006-10-23 Thread Daniel Drake
Michael Buesch wrote: Yes. 2.6.19-rc is still older code than 2.6.18.1. The stuff from 2.6.18.1 (which is the same as wireless-2.6) will be merged into 2.6.19-rc soon. 2.6.18.1 produced the oops in the earlier mail wireless-2.6 did *not* produce the oops, instead I get the behavior of plain

Re: [PATCH] wireless-2.6 zd1211rw check against regulatory domain rather than hardcoded value of 11

2006-10-23 Thread Daniel Drake
Holden Karau wrote: From: Holden Karau [EMAIL PROTECTED] http://www.holdenkarau.com I have made a small patch for the zd1211rw driver which uses the boundry channels of the regulatory domain, rather than the hard coded values of 1 11. Signed-off-by: Holden Karau [EMAIL PROTECTED]