Re: [PATCH net-next 10/10] bnxt_en: add support for port_attr_get and and get_phys_port_name

2017-07-26 Thread Or Gerlitz
On Tue, Jul 25, 2017 at 7:45 AM, Jakub Kicinski wrote: > This is even worse. We already have two naming conventions in the > kernel, mlx5 uses "%d" for legacy reasons. nfp uses pf%dvf%d for vfs, To make it clear, in mlx5 this is used only for the offloads/switchdev mode and

Re: [PATCH net-next 10/10] bnxt_en: add support for port_attr_get and and get_phys_port_name

2017-07-25 Thread Jakub Kicinski
On Tue, 25 Jul 2017 15:25:19 +0530, Sathya Perla wrote: > >> Suggested naming convention is "swXpYsZ", where X is the switch name or > >> ID, Y > >> is the port name or ID, and Z is the sub-port name or ID. For example, > >> sw1p1s0 > >> would be sub-port 0 on port 1 on switch 1. > > > > So

Re: [PATCH net-next 10/10] bnxt_en: add support for port_attr_get and and get_phys_port_name

2017-07-25 Thread Sathya Perla
On Tue, Jul 25, 2017 at 10:15 AM, Jakub Kicinski wrote: ... >> +static int bnxt_get_phys_port_name(struct net_device *dev, char *buf, >> +size_t len) >> +{ >> + struct bnxt *bp = netdev_priv(dev); >> + int rc; >> + >> + /* The PF and

Re: [PATCH net-next 10/10] bnxt_en: add support for port_attr_get and and get_phys_port_name

2017-07-24 Thread Jakub Kicinski
On Mon, 24 Jul 2017 12:34:29 -0400, Michael Chan wrote: > From: Sathya Perla > > This patch adds support for the switchdev_port_attr_get() and > ndo_get_phys_port_name() methods for the PF and the VF-reps. > Using this support a user application can deduce that the PF

Re: [PATCH net-next 10/10] bnxt_en: add support for port_attr_get and and get_phys_port_name

2017-07-24 Thread David Miller
From: Jakub Kicinski Date: Mon, 24 Jul 2017 21:06:17 -0700 > On Tue, 25 Jul 2017 10:44:49 +0800, kbuild test robot wrote: >>drivers/net/ethernet/broadcom/bnxt/bnxt.c: In function 'bnxt_init_one': >> >> drivers/net/ethernet/broadcom/bnxt/bnxt.c:7897:5: error: 'struct >> >>

Re: [PATCH net-next 10/10] bnxt_en: add support for port_attr_get and and get_phys_port_name

2017-07-24 Thread Jakub Kicinski
On Tue, 25 Jul 2017 10:44:49 +0800, kbuild test robot wrote: >drivers/net/ethernet/broadcom/bnxt/bnxt.c: In function 'bnxt_init_one': > >> drivers/net/ethernet/broadcom/bnxt/bnxt.c:7897:5: error: 'struct > >> net_device' has no member named 'switchdev_ops'; did you mean > >> 'netdev_ops'?

Re: [PATCH net-next 10/10] bnxt_en: add support for port_attr_get and and get_phys_port_name

2017-07-24 Thread kbuild test robot
Hi Sathya, [auto build test ERROR on net-next/master] url: https://github.com/0day-ci/linux/commits/Michael-Chan/bnxt_en-Update-firmware-interface-spec-to-1-8-0/20170725-094835 config: x86_64-randconfig-x016-201730 (attached as .config) compiler: gcc-6 (Debian 6.2.0-3) 6.2.0 20160901

[PATCH net-next 10/10] bnxt_en: add support for port_attr_get and and get_phys_port_name

2017-07-24 Thread Michael Chan
From: Sathya Perla This patch adds support for the switchdev_port_attr_get() and ndo_get_phys_port_name() methods for the PF and the VF-reps. Using this support a user application can deduce that the PF (when in the ESWITCH_SWDEV mode) and it's VF-reps form a switch.