pgsql: Fix a leftover reference to backend_id in comment

2024-03-04 Thread Heikki Linnakangas
Fix a leftover reference to backend_id in comment Commit 024c521117 replaced backend_id with proc_number. Reported-by: Alexander Lakhin Branch -- master Details --- https://git.postgresql.org/pg/commitdiff/55cdba2647ed6bbe1126c6b6d8f53e8602ec05a1 Modified Files --

pgsql: Fix buildfarm failures from 2af07e2f74.

2024-03-04 Thread Jeff Davis
Fix buildfarm failures from 2af07e2f74. Use GUC_ACTION_SAVE rather than GUC_ACTION_SET, necessary for working with parallel query. Now that the call requires more arguments, wrap the call in a new function to avoid code duplication and offer a place for a comment. Discussion:

pgsql: Fix incorrectly reported stats kind in "can't happen" ERROR

2024-03-04 Thread David Rowley
Fix incorrectly reported stats kind in "can't happen" ERROR The error message(s) were reporting the stats kind of 'f', which is not correct as that's for the "dependencies" statistics kind. Reported-by: Horst Reiterer Reviewed-by: Richard Guo Discussion:

pgsql: Fix incorrectly reported stats kind in "can't happen" ERROR

2024-03-04 Thread David Rowley
Fix incorrectly reported stats kind in "can't happen" ERROR The error message(s) were reporting the stats kind of 'f', which is not correct as that's for the "dependencies" statistics kind. Reported-by: Horst Reiterer Reviewed-by: Richard Guo Discussion:

pgsql: Fix incorrectly reported stats kind in "can't happen" ERROR

2024-03-04 Thread David Rowley
Fix incorrectly reported stats kind in "can't happen" ERROR The error message(s) were reporting the stats kind of 'f', which is not correct as that's for the "dependencies" statistics kind. Reported-by: Horst Reiterer Reviewed-by: Richard Guo Discussion:

pgsql: Fix incorrectly reported stats kind in "can't happen" ERROR

2024-03-04 Thread David Rowley
Fix incorrectly reported stats kind in "can't happen" ERROR The error message(s) were reporting the stats kind of 'f', which is not correct as that's for the "dependencies" statistics kind. Reported-by: Horst Reiterer Reviewed-by: Richard Guo Discussion:

pgsql: Fix incorrectly reported stats kind in "can't happen" ERROR

2024-03-04 Thread David Rowley
Fix incorrectly reported stats kind in "can't happen" ERROR The error message(s) were reporting the stats kind of 'f', which is not correct as that's for the "dependencies" statistics kind. Reported-by: Horst Reiterer Reviewed-by: Richard Guo Discussion:

pgsql: Fix incorrectly reported stats kind in "can't happen" ERROR

2024-03-04 Thread David Rowley
Fix incorrectly reported stats kind in "can't happen" ERROR The error message(s) were reporting the stats kind of 'f', which is not correct as that's for the "dependencies" statistics kind. Reported-by: Horst Reiterer Reviewed-by: Richard Guo Discussion:

Re: pgsql: Fix search_path to a safe value during maintenance operations.

2024-03-04 Thread Jeff Davis
On Mon, 2024-03-04 at 21:15 -0500, Tom Lane wrote: > Jeff Davis writes: > > Fix search_path to a safe value during maintenance operations. > > The buildfarm seems pretty unhappy with this. Looks like I need to use GUC_ACTION_SAVE. I will remedy it shortly. Regards, Jeff Davis

Re: pgsql: Fix search_path to a safe value during maintenance operations.

2024-03-04 Thread Tom Lane
Jeff Davis writes: > Fix search_path to a safe value during maintenance operations. The buildfarm seems pretty unhappy with this. regards, tom lane

pgsql: Fix search_path to a safe value during maintenance operations.

2024-03-04 Thread Jeff Davis
Fix search_path to a safe value during maintenance operations. While executing maintenance operations (ANALYZE, CLUSTER, REFRESH MATERIALIZED VIEW, REINDEX, or VACUUM), set search_path to 'pg_catalog, pg_temp' to prevent inconsistent behavior. Functions that are used for functional indexes, in

pgsql: Add macro for customizing an archiving WARNING message.

2024-03-04 Thread Nathan Bossart
Add macro for customizing an archiving WARNING message. Presently, if an archive module's check_configured_cb callback returns false, a generic WARNING message is emitted, which unfortunately provides no actionable details about the reason why the module is not configured. This commit introduces

pgsql: Explicitly list dependent types as extension members in pg_depen

2024-03-04 Thread Tom Lane
Explicitly list dependent types as extension members in pg_depend. Auto-generated array types, multirange types, and relation rowtypes are treated as dependent objects: they can't be dropped separately from the base object, nor can they have their own ownership or permissions. We previously felt

pgsql: pg_verifybackup: Refactor parse_manifest_file.

2024-03-04 Thread Robert Haas
pg_verifybackup: Refactor parse_manifest_file. Return a pointer to the manifest_data instead of individual pointers to relevant data stored within the manifest_data object. The previous approach scales poorly if we add more things to the backup manifest, as has been proposed. Amul Sul, reviewed

Re: pgsql: Remove the adminpack contrib extension

2024-03-04 Thread Tom Lane
Daniel Gustafsson writes: > The deviation between database names on crake found in the follow-up commit is > a bit concerning. Too much magic hidden away from the codetree makes it hard > to get tests right on the first try. Yeah, I didn't understand that at all. I have a non-reporting

pgsql: Fix pgindent damage.

2024-03-04 Thread Robert Haas
Fix pgindent damage. Apparently, I neglected to pgindent the prior commit. Per buildfarm. Branch -- master Details --- https://git.postgresql.org/pg/commitdiff/dd7ea37c435e10f9c5aa3fb257a05c08814a4ad2 Modified Files -- src/backend/backup/basebackup_incremental.c | 4 ++--

Re: pgsql: Remove the adminpack contrib extension

2024-03-04 Thread Daniel Gustafsson
> On 4 Mar 2024, at 17:34, Tom Lane wrote: > > Daniel Gustafsson writes: >> I see that my fix didn't solve it for 11 and 9.x on crake and drongo, will >> rebuild more old trees and test to find the correct fix. > > The oldest branches didn't make that DB, so you need an "IF EXISTS". > I pushed

pgsql: Fix incremental backup interaction with XLOG_DBASE_CREATE_FILE_C

2024-03-04 Thread Robert Haas
Fix incremental backup interaction with XLOG_DBASE_CREATE_FILE_COPY. After XLOG_DBASE_CREATE_FILE_COPY, a correct incremental backup needs to copy in full everything with the database and tablespace OID mentioned in that record; but that record doesn't specifically mention the blocks, or even the

pgsql: Further further fix pg_upgrade crossversion test for adminpack.

2024-03-04 Thread Tom Lane
Further further fix pg_upgrade crossversion test for adminpack. Apparently, buildfarm animal crake has the adminpack regression DB named as "regression_adminpack" in some branches. Not clear why I didn't see that when testing here. In any case, drop that too. Discussion:

pgsql: Fix initdb's -c option to treat the GUC name case-insensitively.

2024-03-04 Thread Tom Lane
Fix initdb's -c option to treat the GUC name case-insensitively. The backend treats GUC names case-insensitively, so this code should too. This avoids ending up with a confusing set of redundant entries in the generated postgresql.conf file. Per report from Kyotaro Horiguchi. Back-patch to v16

pgsql: Fix initdb's -c option to treat the GUC name case-insensitively.

2024-03-04 Thread Tom Lane
Fix initdb's -c option to treat the GUC name case-insensitively. The backend treats GUC names case-insensitively, so this code should too. This avoids ending up with a confusing set of redundant entries in the generated postgresql.conf file. Per report from Kyotaro Horiguchi. Back-patch to v16

pgsql: Rework locking code in GetMultiXactIdMembers

2024-03-04 Thread Alvaro Herrera
Rework locking code in GetMultiXactIdMembers After commit 53c2a97a9266, the code flow around the "retry" goto label in GetMultiXactIdMembers was confused about what was possible: we never return there with a held lock, so there's no point in testing for one. This realization lets us simplify the

pgsql: Simplify coding in slru.c

2024-03-04 Thread Alvaro Herrera
Simplify coding in slru.c New code in 53c2a97a9266 uses direct array access to shared->bank_locks[bankno].lock which can be made a little bit more legible by using the SimpleLruGetBankLock helper function. Nothing terribly serious, but let's add some clarity. Discussion:

Re: pgsql: Remove the adminpack contrib extension

2024-03-04 Thread Tom Lane
Daniel Gustafsson writes: > I see that my fix didn't solve it for 11 and 9.x on crake and drongo, will > rebuild more old trees and test to find the correct fix. The oldest branches didn't make that DB, so you need an "IF EXISTS". I pushed a fix after quickly checking it here.

pgsql: Further fix pg_upgrade crossversion test for adminpack.

2024-03-04 Thread Tom Lane
Further fix pg_upgrade crossversion test for adminpack. The DROP DATABASE step needs an "if exists" option, as the oldest branches we test don't have the contrib_regression_adminpack DB. Also remove unnecessary command to drop the extension from the regression database; no version has installed

Re: pgsql: Remove the adminpack contrib extension

2024-03-04 Thread Daniel Gustafsson
> On 4 Mar 2024, at 16:27, Alvaro Herrera wrote: > > On 2024-Mar-04, Daniel Gustafsson wrote: > >> The pg_upgrade Xversion test on crake failed on this, I'm trying to reproduce >> the cross-version test locally to verify the below diff but it's right now >> failing on an unrelated thing. > >

Re: pgsql: Remove the adminpack contrib extension

2024-03-04 Thread Alvaro Herrera
On 2024-Mar-04, Daniel Gustafsson wrote: > The pg_upgrade Xversion test on crake failed on this, I'm trying to reproduce > the cross-version test locally to verify the below diff but it's right now > failing on an unrelated thing. What unrelated thing? I suggest to try to initdb the old version

pgsql: Fix crossversion test for unsupported versions

2024-03-04 Thread Daniel Gustafsson
Fix crossversion test for unsupported versions The fix in be78006741 only accounted for supported versions of postgres but the crossversion test use 11 as the source version, which is an EOL version. Fix by removing the lower bound in the adminpack cleanup. Discussion:

pgsql: Adjust pg_upgrade crossversion test for adminpack

2024-03-04 Thread Daniel Gustafsson
Adjust pg_upgrade crossversion test for adminpack Commit cc09e6549f which removed the adminpack extension failed to instrument the crossversion pg_upgrade test to drop the extension before attempting an upgrade to v17. Discussion: https://postgr.es/m/0cfb76d0-0510-48b2-9916-1199f93bc...@yesql.se

Re: pgsql: Remove the adminpack contrib extension

2024-03-04 Thread Daniel Gustafsson
> On 4 Mar 2024, at 12:43, Daniel Gustafsson wrote: > > Remove the adminpack contrib extension The pg_upgrade Xversion test on crake failed on this, I'm trying to reproduce the cross-version test locally to verify the below diff but it's right now failing on an unrelated thing. If anyone has a

pgsql: Put back required #include

2024-03-04 Thread Peter Eisentraut
Put back required #include Fix for dbbca2cf29: "storage/shmem.h" is required with -Dspinlocks=false. Branch -- master Details --- https://git.postgresql.org/pg/commitdiff/43a8875f4919e05ea25f88c3b94563f45a5bdb9e Modified Files -- src/backend/storage/lmgr/spin.c | 1 + 1 file

pgsql: Remove the adminpack contrib extension

2024-03-04 Thread Daniel Gustafsson
Remove the adminpack contrib extension The adminpack extension was only used to support pgAdmin III, which in turn was declared EOL many years ago. Removing the extension also allows us to remove functions from core as well which were only used to support old version of adminpack. Reviewed-by:

pgsql: Remove unused #include's from backend .c files

2024-03-04 Thread Peter Eisentraut
Remove unused #include's from backend .c files as determined by include-what-you-use (IWYU) While IWYU also suggests to *add* a bunch of #include's (which is its main purpose), this patch does not do that. In some cases, a more specific #include replaces another less specific one. Some manual

pgsql: Remove unused ParallelWorkerInfo.pid field

2024-03-04 Thread Heikki Linnakangas
Remove unused ParallelWorkerInfo.pid field The pid was originally used in error context of messages propagated from parallel workers, but commit 292794f82b removed that. If the need arises in the future, you can also get the pid with "shm_mq_get_sender(pcxt->worker[i].error_mqh)->pid". Branch

pgsql: Remove unused 'countincludesself' argument to pq_sendcountedtext

2024-03-04 Thread Heikki Linnakangas
Remove unused 'countincludesself' argument to pq_sendcountedtext() It has been unused since we removed support for protocol version 2. Branch -- master Details --- https://git.postgresql.org/pg/commitdiff/24eebc65c26cfcc0ea5b8a95b61fa2fda6118e68 Modified Files --

pgsql: Fix doc omission for MERGE into updatable views.

2024-03-04 Thread Dean Rasheed
Fix doc omission for MERGE into updatable views. Commit 5f2e179bd3 missed one place in rules.sgml that should have mentioned MERGE. Also, be more specific when saying that MERGE doesn't support rules, since it does support SELECT rules. Branch -- master Details ---

pgsql: doc: Fix datatype for postgres_fdw option

2024-03-04 Thread Daniel Gustafsson
doc: Fix datatype for postgres_fdw option The datatype for analyze_sampling had accidentally been set to text and not string. Backpatch to v16 where analyze_sampling first was introduced. Author: Shinya Kato Reviewed-by: Laurenz Albe Discussion:

pgsql: doc: Fix datatype for postgres_fdw option

2024-03-04 Thread Daniel Gustafsson
doc: Fix datatype for postgres_fdw option The datatype for analyze_sampling had accidentally been set to text and not string. Backpatch to v16 where analyze_sampling first was introduced. Author: Shinya Kato Reviewed-by: Laurenz Albe Discussion:

pgsql: Remove MyAuxProcType, use MyBackendType instead

2024-03-04 Thread Heikki Linnakangas
Remove MyAuxProcType, use MyBackendType instead MyAuxProcType was redundant with MyBackendType. Reviewed-by: Reid Thompson, Andres Freund Discussion: https://www.postgresql.org/message-id/f3ecd4cb-85ee-4e54-8278-5fabfb3a4...@iki.fi Branch -- master Details ---

pgsql: Use MyBackendType in more places to check what process this is

2024-03-04 Thread Heikki Linnakangas
Use MyBackendType in more places to check what process this is Remove IsBackgroundWorker, IsAutoVacuumLauncherProcess(), IsAutoVacuumWorkerProcess(), and IsLogicalSlotSyncWorker() in favor of new Am*Process() macros that use MyBackendType. For consistency with the existing Am*Process() macros.