Re: [PATCH 2/3] x86: introduce xstate_zero

2024-03-05 Thread Jan Beulich
On 04.03.2024 10:13, Fouad Hilly wrote: > +void xstate_zero(uint64_t mask) > +{ > +bool ok; > +struct xsave_struct tmp; > + > +tmp.fpu_sse.mxcsr = MXCSR_DEFAULT; This is a clear indication that the function name is wrong. Perhaps it is "reset" that was meant? > +

[PATCH 2/3] x86: introduce xstate_zero

2024-03-04 Thread Fouad Hilly
From: Wei Liu Factor out xrstor__ and introduce xstate_zero, which zeros all the state components specified in the mask. Signed-off-by: Wei Liu Signed-off-by: Fouad Hilly --- CC: Jan Beulich CC: Andrew Cooper CC: "Roger Pau Monné" CC: Wei Liu --- xen/arch/x86/include/asm/xstate.h | 1 +