Re: [PATCH v12 03/15] vpci: add hooks for PCI device assign/de-assign

2024-01-30 Thread Stewart Hildebrand
On 1/9/24 16:51, Stewart Hildebrand wrote: > diff --git a/xen/drivers/passthrough/pci.c b/xen/drivers/passthrough/pci.c > index 3a973324bca1..a902de6a8693 100644 > --- a/xen/drivers/passthrough/pci.c > +++ b/xen/drivers/passthrough/pci.c > @@ -1476,6 +1485,10 @@ static int assign_device(struct

Re: [PATCH v12 03/15] vpci: add hooks for PCI device assign/de-assign

2024-01-23 Thread Jan Beulich
On 09.01.2024 22:51, Stewart Hildebrand wrote: > From: Oleksandr Andrushchenko > > When a PCI device gets assigned/de-assigned we need to > initialize/de-initialize vPCI state for the device. > > Also, rename vpci_add_handlers() to vpci_assign_device() and > vpci_remove_device() to

[PATCH v12 03/15] vpci: add hooks for PCI device assign/de-assign

2024-01-09 Thread Stewart Hildebrand
From: Oleksandr Andrushchenko When a PCI device gets assigned/de-assigned we need to initialize/de-initialize vPCI state for the device. Also, rename vpci_add_handlers() to vpci_assign_device() and vpci_remove_device() to vpci_deassign_device() to better reflect role of the functions.