On Thu, 21 Jan 2010 10:31:04 -0800, Eric Anholt <e...@anholt.net> wrote:

> -    if (!drawable->eventMask & GLX_BUFFER_SWAP_COMPLETE_INTEL_MASK)
> +    if (!(drawable->eventMask & GLX_BUFFER_SWAP_COMPLETE_INTEL_MASK))

Reviewed-by: Keith Packard <kei...@keithp.com>

I'll note that using 'drawable' as a name here is sub-optimal. Also the
code in glxcmds.c that sets eventMask has an inaccurate comment, and
also fails to validate the event mask to make sure it doesn't include
bits which aren't allowed.

-- 
keith.pack...@intel.com

Attachment: pgptA1WcY1uAu.pgp
Description: PGP signature

_______________________________________________
xorg mailing list
xorg@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/xorg

Reply via email to