On Fri, 24 Mar 2023 06:39:18 GMT, David Holmes <dhol...@openjdk.org> wrote:

>> Roman Kennke has updated the pull request incrementally with two additional 
>> commits since the last revision:
>> 
>>  - Merge remote-tracking branch 'origin/JDK-8291555-v2' into JDK-8291555-v2
>>  - Set condition flags correctly after fast-lock call on aarch64
>
> src/hotspot/share/runtime/synchronizer.cpp line 516:
> 
>> 514:       // No room on the lock_stack so fall-through to inflate-enter.
>> 515:     } else {
>> 516:       markWord mark = obj->mark();
> 
> why is it `mark` here but `header` above?

Oh I don't know. We are very inconsistent in our nomenclature here and use mark 
in some places and header in some others (e.g. OM::set_header() or the 
displaced_header() methods). The name mark is not really fitting and only still 
exists for historical reasons I believe (when one of the primary functions of 
the object header is to indicate GC marking?) However, the central data type is 
still called markWord so I changed my new code paths to use *mark as well. This 
probably warrants a round of codebase cleanup and consolidation later.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/10907#discussion_r1149630607

Reply via email to