On Tue, 16 Apr 2024 16:09:21 GMT, Vladimir Kozlov <k...@openjdk.org> wrote:

>> src/hotspot/share/code/nmethod.cpp line 1441:
>> 
>>> 1439:     int deps_size     = align_up((int)dependencies->size_in_bytes(), 
>>> oopSize);
>>> 1440:     int sum_size      = oops_size + metadata_size + deps_size;
>>> 1441:     assert((sum_size >> 16) == 0, "data size is bigger than 64Kb: 
>>> %d", sum_size);
>> 
>> I suggest using checked_cast for the assignment below, rather than 
>> special-purpose checks here.
>
> Okay. But I will put above code under `#ifdef ASSERT` then.

The ASSERT block above looks unnecessary, now that field assignments below are 
using checked_cast.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/18768#discussion_r1569496753

Reply via email to