On 24.04.24 09:43, lukas.funke-...@weidmueller.com wrote:
From: Lukas Funke <lukas.fu...@weidmueller.com>

Rename spl_soc_init() to spl_dram_init() because the generic function
name does not reflect what the function actually does. Also
spl_dram_init() is commonly used for dram initialization and should be
called from board_init_f().

Signed-off-by: Lukas Funke <lukas.fu...@weidmueller.com>

Reviewed-by: Heinrich Schuchardt <xypron.g...@gmx.de>

---

Changes in v3:
  - Reorganize patches such that each patch can be built individually

Changes in v2:
  - capitalized acronym DRAM

  arch/riscv/cpu/jh7110/spl.c              | 2 +-
  arch/riscv/include/asm/arch-jh7110/spl.h | 2 +-
  board/starfive/visionfive2/spl.c         | 4 ++--
  3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/arch/riscv/cpu/jh7110/spl.c b/arch/riscv/cpu/jh7110/spl.c
index 6bdf8b9c72..87aaf86524 100644
--- a/arch/riscv/cpu/jh7110/spl.c
+++ b/arch/riscv/cpu/jh7110/spl.c
@@ -28,7 +28,7 @@ static bool check_ddr_size(phys_size_t size)
        }
  }

-int spl_soc_init(void)
+int spl_dram_init(void)
  {
        int ret;
        struct udevice *dev;
diff --git a/arch/riscv/include/asm/arch-jh7110/spl.h 
b/arch/riscv/include/asm/arch-jh7110/spl.h
index 23ce8871b3..d73355bf35 100644
--- a/arch/riscv/include/asm/arch-jh7110/spl.h
+++ b/arch/riscv/include/asm/arch-jh7110/spl.h
@@ -7,6 +7,6 @@
  #ifndef _SPL_STARFIVE_H
  #define _SPL_STARFIVE_H

-int spl_soc_init(void);
+int spl_dram_init(void);

  #endif /* _SPL_STARFIVE_H */
diff --git a/board/starfive/visionfive2/spl.c b/board/starfive/visionfive2/spl.c
index 45848db6d8..ca61b5be22 100644
--- a/board/starfive/visionfive2/spl.c
+++ b/board/starfive/visionfive2/spl.c
@@ -285,9 +285,9 @@ int spl_board_init_f(void)

        jh7110_jtag_init();

-       ret = spl_soc_init();
+       ret = spl_dram_init();
        if (ret) {
-               debug("JH7110 SPL init failed: %d\n", ret);
+               debug("JH7110 DRAM init failed: %d\n", ret);
                return ret;
        }


Reply via email to