There's no reason why it can't be named "create..." and return a retained object,

My personal preference is to use Create... for naming functions which return alloc/malloc memory, inline with the CoreFoundation memory management rules. I tend to use -(id)new... for methods, again for the same reason.

This ensures that your functions and methods follow the established API grammar and increases readability.

Keith
_______________________________________________

Cocoa-dev mailing list (Cocoa-dev@lists.apple.com)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:
http://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com

This email sent to [EMAIL PROTECTED]

Reply via email to