[ 
https://issues.apache.org/jira/browse/CASSANDRA-17221?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17539171#comment-17539171
 ] 

Ekaterina Dimitrova commented on CASSANDRA-17221:
-------------------------------------------------

Great job! Thanks!

Actually from now on any rebase should be easy. 

I guess you already have added the Apache repo as a remote, in case you haven't 
done that yet you can do it like that (assigning it a remote name "origin"):

 
{code:java}
git remote add origin https://github.com/apache/cassandra.git{code}
 

Then every time you want to rebase a branch:
 * you checkout the branch you work on and want to rebase
 * 
{code:java}
git fetch origin{code}

 * 
{code:java}
git rebase/trunk{code}
          (trunk or whatever version branch you work on at the moment)

In some cases there might be some merge conflicts to solve. Git tells you what 
to do when that happens.

About this patch - unfortunately I am swamped this week before being off next 
one but I will try to get back to this work as soon as possible.

 

 

 

> Add Math functions 
> -------------------
>
>                 Key: CASSANDRA-17221
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-17221
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: CQL/Syntax
>            Reporter: Benjamin Lerer
>            Assignee: Simon Chess
>            Priority: Normal
>              Labels: AdventCalendar2021, lhf
>             Fix For: 4.x
>
>
> We should add native Maths functions for the most common operations:
> * {{abs\(x)}} returns the absolute value of the x
> * {{exp\(x)}} returns the value of e (the base of natural logarithms) raised 
> to the power of x
> * {{log\(x)}} returns the natural logarithm (base e) of x
> * {{log10\(x)}} returns the base-10 logarithm of x
> * {{round\(x)}} returns the closest integer to x
> +Additional information for newcomers:+
> The new functions should be put in a new class {{MathFcts}} similar to 
> {{TimeFcts}}.
> The {{MathsFcts.all()}} method should be called in 
> {{SystemKeyspace.functions}}
> The unit tests for the functions should be put in a {{MathFctsTest}} similar 
> to {{TimeFctsTest}} 



--
This message was sent by Atlassian Jira
(v8.20.7#820007)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org
For additional commands, e-mail: commits-h...@cassandra.apache.org

Reply via email to