I prefer "Feature" with some sufix like "Descriptor"
public interface Unit {
>>>>>>>>>>>>>>>>>>>>>>>>>>>>    
    /**
     * Get the Map of string to string attributes.
     * 
     * @return string/string attribute Map
     */
I think we need to remove this method
    Map getAttributeMap();
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>    
    /**
     * Get the count of attributes.
     * This should be checked rather than getAttributes().size() to
     * allow for lazily instantiated attribute maps.
     * 
     * @return the number of attributes
     */

    int getAttributeCount();
    /**
     * Get an attribute by key.
     * 
     * @param key  the key to get
     * @return attribute value by key, null if not found
     */
I prefer "Object" as return value
    String getAttribute(String key);
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>    
    /**
     * Set an attribute key and value.
     * 
     * @param key  the key to set
     * @param value  the value to set
     */ 
"Object" for attribute type
    void setAttribute(String key, String value);
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

I want to add this:

List getAttributeNames();    


}



--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@;jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@;jakarta.apache.org>

Reply via email to