I think it's a good idea, but I like method that returns void also, because it may save memory by modifying the input array.

Maybe your suggested method should be renamed to:

Object[] copyReverse(final Object[] array)

and be modified to not operate on the argument, but instead create a copy of it and return the reverse of the copy.

What do you think?




Gary Gregory wrote:


Hello,

How about returning the argument instead of void for these APIs such that
they can be used in expressions?

Now ArrayUtils:

public static void reverse(final Object[] array) {

Proposal:

public static Object[] reverse(final Object[] array) {


I ran into this with the Object[] version of the API but this applies to all other ArrayUtils.reverse APIs.

This change should backwards compatible with a recompile of client code.

Thanks,
Gary




--------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]



Reply via email to