In general I think this particular approach is not developer friendly enough.
The function expression name is fairly irrelevant, so you could have a standard style guideline
foo : function callee() {
    callee.base.apply ...
}

This is actually a really interesting idea. I'll try to use it. In SproutCore's particular case we have a pre-processor that can insert this also, just like PTW says for OpenLazlo. It's still annoying for those developers without a pre-processor to help them but better.

--

I'm curious, why not just give anonymous functions a default name like "callee". Or perhaps have "callee" defined in a function scope to represent the function? That seems to be exactly the same as the above; it just makes it easier for developers. Is there a perf issue here?

-Charles


_______________________________________________
es-discuss mailing list
es-discuss@mozilla.org
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to