[ 
https://issues.apache.org/jira/browse/HBASE-4199?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13086317#comment-13086317
 ] 

Ted Yu commented on HBASE-4199:
-------------------------------

Please use better table names below:
{code}
+  private static final String TEST_TABLE = "testFamily";
+  private static final String TEST_TABLE2 = "testFamily2";
{code}
Javadoc for BlockCacheSummaryEntry should mention entry:
{code}
+/**
+ * Represents a summary of the blockCache by Table and ColumnFamily  
+ *
+ */
+public class BlockCacheSummaryEntry implements Writable, 
Comparable<BlockCacheSummaryEntry> {
{code}
I think the code below:
{code}
+      bcse = new BlockCacheSummaryEntry();
+      bcse.setTable(s[ s.length - 4]);   // 4th from the end
+      bcse.setColumnFamily(s[ s.length - 2]);   // 2nd from the end
{code}
should be replaced with calling the two parameter ctor. The default ctor should 
be made package private.

> blockCache summary - backend
> ----------------------------
>
>                 Key: HBASE-4199
>                 URL: https://issues.apache.org/jira/browse/HBASE-4199
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Doug Meil
>            Assignee: Doug Meil
>            Priority: Minor
>         Attachments: java_HBASE_4199.patch, java_HBASE_4199_v2.patch
>
>
> This is the backend work for the blockCache summary.  Change to BlockCache 
> interface, Summarization in LruBlockCache, BlockCacheSummaryEntry, addition 
> to HRegionInterface, and HRegionServer.
> This will NOT include any of the web UI or anything else like that.  That is 
> for another sub-task.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to