I'm developing BandedMatrices.jl, which currently uses `bzeros`, `beye`, 
`brand` etc. to construct BandedMatrix analogues of `zeros`/`spzeros`, 
`eye`/`speye` and `rand`/`speye`.   But I just saw in ArrayFire.jl an 
alternative syntax, rand(AFArray{Float64}, 100, 100) constructs a 100 x 100 
AFArray{Float64}.  


Should this syntax become standard?  That is, there could be 
`rand(Matrix{Float64},100,100)`, `rand(SparseMatrixCSC{Float64},100,100)`   
and  `rand(BandedMatrix{Float64},100,100)`.  There could also be 
 `zero(Matrix{Float64},10,10)` be defined to be equivalent to 
`zeros(Float64,10,10)`.


Reply via email to