And don't forget to allocate linecard memory for LAG interfaces:

set chassis aggregated-devices ethernet device-count 8

8 is a safe number.
Don't overallocate by inflating "the device-count" - once allocated, this memory is not accessible to other linecard processes if Your actual device count is below what's configured.
HTH
Thx
Alex

On 13/11/2015 21:35, Chuck Anderson wrote:
You also need to configure the physical interface(s) in the LAG:

interfaces {
     xe-x/y/z {
         gigether-options {
             802.3ad ae0;
         }
     }
}
interfaces {
     xe-x/y/w {
         gigether-options {
             802.3ad ae0;
         }
     }
}
...

Otherwise, it looks fine.

On Fri, Nov 13, 2015 at 04:12:48PM -0500, Josh Baird wrote:
Hi,

I apologize for the basic question as I'm a new Junos user.  I'm attempting
to convert the following basic config from a Cisco NPE-G1:

interface GigabitEthernet0/3
  desc 'Physical link to EX'

interface GigabitEthernet0/3.41
   encapsulation dot1q
   ip address 1.1.1.2/30

On the MX, I am trying to configure an agg between the MX and other device
(EX), so this is the config that I have came up with:

# interfaces
ae0 {
     flexible-vlan-tagging;
     encapsulation flexible-ethernet-services;
     aggregated-ether-options {
         lacp {
             active;
             periodic fast;
         }
     }
     unit 41 {
         encapsulation vlan-bridge;
         vlan-id 41;
     }
}

# interfaces irb
irb {
     unit 41 {
         family inet {
             address 1.1.1.2/30
         }
     }
}


# bridge-domain
bridge-domains {
     vlan41 {
         vlan-id 41;
         interface ae0.41;
         routing-interface irb.41;
     }
}

Does this configuration look correct?  Is all of this necessary?  I realize
there are several different ways to handle this in Junos.

Thanks for any suggestions or input.

Josh
_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp

_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp

Reply via email to