On 8/20/19 2:58 PM, Ján Tomko wrote:
Ján Tomko (19):
   qemuBuildSerialChrDeviceStr: rename cmd to buf
   qemuBuildNumaArgStr: split variable declarations
   qemuBuildHotpluggableCPUProps: use VIR_RETURN_PTR
   qemuxml2xmltest: switch TPM tests to use latest caps
   qemu: move TPM vaildation to qemuDomainDeviceDefValidateTPM
   qemuBuildTPMBackendStr: format device and alias separately
   qemu_command: switch to VIR_AUTOCLEAN for virBuffer
   qemu_command: use VIR_AUTOPTR for virJSONValue
   qemu_command: use VIR_AUTOFREE for variables used once
   qemuBuildNetworkDriveURI: use VIR_AUTOPTR for virURI
   qemuBuildControllersByTypeCommandLine: use VIR_AUTOFREE
   qemuBuildRNGCommandLine: use VIR_AUTOFREE
   qemuBuildSmpCommandLine: use virCommandAddArgBuffer directly
   qemuBuildShmemCommandLine: add chardev variable
   qemuBuildShmemCommandLine: use VIR_AUTOFREE for devstr
   qemu_command: use VIR_AUTOUNREF
   qemu_command: remove unnecessary labels and ret variables
   qemuBuildCommandLine: use VIR_AUTO*
   qemuBuildCommandLine: remove unnecessary error label

  src/qemu/qemu_command.c                       | 1388 ++++++-----------
  src/qemu/qemu_domain.c                        |   29 +-
  ...> tpm-emulator-tpm2-enc.x86_64-latest.xml} |    4 +-
  ...ml => tpm-emulator-tpm2.x86_64-latest.xml} |    4 +-
  ...tor.xml => tpm-emulator.x86_64-latest.xml} |    4 +-
  ... => tpm-passthrough-crb.x86_64-latest.xml} |    4 +-
  ....xml => tpm-passthrough.x86_64-latest.xml} |    4 +-
  tests/qemuxml2xmltest.c                       |   10 +-
  8 files changed, 545 insertions(+), 902 deletions(-)
  rename tests/qemuxml2xmloutdata/{tpm-emulator-tpm2-enc.xml => 
tpm-emulator-tpm2-enc.x86_64-latest.xml} (89%)
  rename tests/qemuxml2xmloutdata/{tpm-emulator-tpm2.xml => 
tpm-emulator-tpm2.x86_64-latest.xml} (89%)
  rename tests/qemuxml2xmloutdata/{tpm-emulator.xml => 
tpm-emulator.x86_64-latest.xml} (89%)
  rename tests/qemuxml2xmloutdata/{tpm-passthrough-crb.xml => 
tpm-passthrough-crb.x86_64-latest.xml} (89%)
  rename tests/qemuxml2xmloutdata/{tpm-passthrough.xml => 
tpm-passthrough.x86_64-latest.xml} (89%)



Reviewed-by: Michal Privoznik <mpriv...@redhat.com>

I've put some comments for individual patches though. In some I'm pointing out some missing changes that you do in later patches. So maybe, if you'd reorder them then they're golden? Or don't.

Michal

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list

Reply via email to