On Sun, Jul 24, 2011 at 9:43 PM,  <rpear...@systemfabricworks.com> wrote:
> +static char *resp_state_name[] = {
> +     [RESPST_NONE]                           = "NONE",

Shouldn't that be "const char * const" instead of "char *" ?

> +/* rxe_recv calls here to add a request packet to the input queue */
> +void rxe_resp_queue_pkt(struct rxe_dev *rxe, struct rxe_qp *qp,
> +                     struct sk_buff *skb)
> +{
> +     int must_sched;

Shouldn't that be "bool" instead of "int" ?

> +     default:
> +             WARN_ON(1);
> +             break;

Shouldn't that be "__WARN()" instead of "WARN_ON(1)" ?

> +static struct sk_buff *prepare_ack_packet(struct rxe_qp *qp,
> +                                       struct rxe_pkt_info *pkt,
> +                                       int opcode,
> +                                       int payload,
> +                                       u32 psn,
> +                                       u8 syndrome)
> +{
> +     struct rxe_dev *rxe = to_rdev(qp->ibqp.device);
> +     struct sk_buff *skb;
> +     struct rxe_pkt_info *ack;
> +     int paylen;
> +     int pad;
> +
> +     /*
> +      * allocate packet
> +      */
> +     pad = (-payload) & 0x3;

Something like "pad = ALIGN(payload, 4) - payload" is probably easier to read.

Bart.
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to