Daniel Grunblatt wrote:

I would do a cisc.jit and a risc.jit to avoid the #ifdef forest.

Good idea.


The problem is when you want to implement an opcode like div, which is easy in ppc but not in arm.... ideas?

I don't know arm, but this belongs to jit_emit.h, how it's done there is a different issue.


I was sort of going in that direction, mips/core.jit is almost like ppc/core.jit (If everything is on schedule I'll find some time to finish it on december).

Ah fine.
But can we have a united syntax for {c,r}isc.jit. The problem currently is, that moves or other ops are sometimes written as op(src, dest), sometimes exactly the other way round.

I really want this have sorted out. I'm currently writing tests (jit/i386 is failing a lot of them, due to wrong move directions: e.g. add_i_i_i, sub_i_i_i)


Proposed naming of ops:

  jit_emit_<op>_<rmi>_<in>(...)

  <op> operations mov, add, sub, mul, ...
  <rmi> register, memory, immediate, for all parameters
       (source, dest) or (source, source, dest)
We could do it like parrot (dest, src, src) too, but I want really a unique naming convention.

leo



Reply via email to