Re: [PATCH 3/7] Remove trailing period from various diagnostic messages (PR translation/79923)
On 10/03/17 23:36, David Malcolm wrote: On Fri, 2017-03-10 at 09:24 +, Kyrill Tkachov wrote: On 10/03/17 06:24, Jakub Jelinek wrote: On Thu, Mar 09, 2017 at 12:45:25PM -0500, David Malcolm wrote: gcc/ChangeLog: PR translation/79923 * auto-profile.c (get_combined_location): Convert leading character of diagnostics to lower case and remove trailing period. (read_profile): Likewise for various diagnostics. * config/arm/arm-builtins.c (arm_expand_builtin): Remove trailing period from various diagnostics. * config/arm/arm.c (arm_option_override): Likewise. * config/msp430/msp430.c (msp430_expand_delay_cycles): Likewise. (msp430_expand_delay_cycles): Likewise. Mostly ok, but for --- a/gcc/config/arm/arm-builtins.c +++ b/gcc/config/arm/arm-builtins.c @@ -2990,60 +2990,60 @@ arm_expand_builtin (tree exp, && (imm < 0 || imm > 32)) { if (fcode == ARM_BUILTIN_WRORHI) - error ("the range of count should be in 0 to 32. please check the intrinsic _mm_rori_pi16 in code."); + error ("the range of count should be in 0 to 32. please check the intrinsic _mm_rori_pi16 in code"); I wonder if this shouldn't use a semicolon space in the middle instead of dot space space (many times in the same file). Is there a convention in GCC to use semicolons? I'm okay with changing it to a semicolon (it's slightly better IMO) as long as it's consistent with the style GCC uses. Also, for the benefit of translators, this might be better done as error ("the range of count should be in 0 to 32; please check the intrinsic %s in code", "_mm_rori_pi16"); so that there are fewer of these messages. Adding some ARM folks on this. These iWMMXt builtins haven't been touched in ages and could do with some TLC in general. For example, I'm not a fan of having all these "please check the intrinsic ..." messages. If we've got a reference to the tree we're expanding, isn't there some kind of error function that will point to the location in the source that's causing the error? I'd rather use that than hardcoding the intrinsic names. This would also allow us to collapse all these if (fcode == <...>) error (...); else if (fcode == <...>) error (...); else if ... constructs. While we're at it: if (fcode == ARM_BUILTIN_WSRLHI) - error ("the count should be no less than 0. please check the intrinsic _mm_srli_pi16 in code."); + error ("the count should be no less than 0. please check the intrinsic _mm_srli_pi16 in code"); Let's use "the count should be a non-negative integer" to be consistent with the error reporting for UInteger error messages. Perhaps commit everything except arm-builtins.c separately and deal with this part with the ARM folks? I agree. David, if you want to clean up the error reporting in these intrinsics as a separate patch I'd be grateful. Otherwise, could you please open a bugzilla ticket so we can track this? I started looking at this, but realized I don't have the arm ISA expertise to touch this code (sorry), so I filed https://gcc.gnu.org/bugzilla/show_bug.cgi?id=79995 instead. No worries, thanks for looking at this in the first place. Kyrill
Re: [PATCH 3/7] Remove trailing period from various diagnostic messages (PR translation/79923)
On Fri, 2017-03-10 at 09:24 +, Kyrill Tkachov wrote: > On 10/03/17 06:24, Jakub Jelinek wrote: > > On Thu, Mar 09, 2017 at 12:45:25PM -0500, David Malcolm wrote: > > > gcc/ChangeLog: > > > PR translation/79923 > > > * auto-profile.c (get_combined_location): Convert leading > > > character of diagnostics to lower case and remove trailing > > > period. > > > (read_profile): Likewise for various diagnostics. > > > * config/arm/arm-builtins.c (arm_expand_builtin): Remove > > > trailing > > > period from various diagnostics. > > > * config/arm/arm.c (arm_option_override): Likewise. > > > * config/msp430/msp430.c (msp430_expand_delay_cycles): > > > Likewise. > > > (msp430_expand_delay_cycles): Likewise. > > Mostly ok, but for > > > > > --- a/gcc/config/arm/arm-builtins.c > > > +++ b/gcc/config/arm/arm-builtins.c > > > @@ -2990,60 +2990,60 @@ arm_expand_builtin (tree exp, > > > && (imm < 0 || imm > 32)) > > > { > > > if (fcode == ARM_BUILTIN_WRORHI) > > > - error ("the range of count should be in 0 to 32. > > > please check the intrinsic _mm_rori_pi16 in code."); > > > + error ("the range of count should be in 0 to 32. > > > please check the intrinsic _mm_rori_pi16 in code"); > > I wonder if this shouldn't use a semicolon space in the middle > > instead of dot space space (many times in the same file). > > Is there a convention in GCC to use semicolons? > I'm okay with changing it to a semicolon (it's slightly better IMO) > as long as it's consistent > with the style GCC uses. > > > Also, for the benefit of translators, this might be better done as > > error ("the range of count should be in 0 to 32; please > > check the intrinsic %s in code", > >"_mm_rori_pi16"); > > so that there are fewer of these messages. > > Adding some ARM folks on this. > > These iWMMXt builtins haven't been touched in ages and could do with > some TLC in general. > For example, I'm not a fan of having all these "please check the > intrinsic ..." messages. > If we've got a reference to the tree we're expanding, isn't there > some kind of error function > that will point to the location in the source that's causing the > error? I'd rather use that than > hardcoding the intrinsic names. This would also allow us to collapse > all these > if (fcode == <...>) >error (...); > else if (fcode == <...>) >error (...); > else if ... > > constructs. > > While we're at it: > > if (fcode == ARM_BUILTIN_WSRLHI) > - error ("the count should be no less than 0. please > check the intrinsic _mm_srli_pi16 in code."); > + error ("the count should be no less than 0. please > check the intrinsic _mm_srli_pi16 in code"); > > > Let's use "the count should be a non-negative integer" to be > consistent with the error reporting > for UInteger error messages. > > > Perhaps commit everything except arm-builtins.c separately and deal > > with > > this part with the ARM folks? > > I agree. David, if you want to clean up the error reporting in these > intrinsics as a separate patch I'd be grateful. > Otherwise, could you please open a bugzilla ticket so we can track > this? I started looking at this, but realized I don't have the arm ISA expertise to touch this code (sorry), so I filed https://gcc.gnu.org/bugzilla/show_bug.cgi?id=79995 instead.
Re: [PATCH 3/7] Remove trailing period from various diagnostic messages (PR translation/79923)
On 10/03/17 09:30, Jakub Jelinek wrote: On Fri, Mar 10, 2017 at 09:24:18AM +, Kyrill Tkachov wrote: On 10/03/17 06:24, Jakub Jelinek wrote: On Thu, Mar 09, 2017 at 12:45:25PM -0500, David Malcolm wrote: gcc/ChangeLog: PR translation/79923 * auto-profile.c (get_combined_location): Convert leading character of diagnostics to lower case and remove trailing period. (read_profile): Likewise for various diagnostics. * config/arm/arm-builtins.c (arm_expand_builtin): Remove trailing period from various diagnostics. * config/arm/arm.c (arm_option_override): Likewise. * config/msp430/msp430.c (msp430_expand_delay_cycles): Likewise. (msp430_expand_delay_cycles): Likewise. Mostly ok, but for --- a/gcc/config/arm/arm-builtins.c +++ b/gcc/config/arm/arm-builtins.c @@ -2990,60 +2990,60 @@ arm_expand_builtin (tree exp, && (imm < 0 || imm > 32)) { if (fcode == ARM_BUILTIN_WRORHI) - error ("the range of count should be in 0 to 32. please check the intrinsic _mm_rori_pi16 in code."); + error ("the range of count should be in 0 to 32. please check the intrinsic _mm_rori_pi16 in code"); I wonder if this shouldn't use a semicolon space in the middle instead of dot space space (many times in the same file). Is there a convention in GCC to use semicolons? I'm okay with changing it to a semicolon (it's slightly better IMO) as long as it's consistent with the style GCC uses. We have tons of messages like: invalid --param name %qs; did you mean %qs? Thanks, then using a semicolon here is the right thing to do. Kyrill Jakub
Re: [PATCH 3/7] Remove trailing period from various diagnostic messages (PR translation/79923)
On Fri, Mar 10, 2017 at 09:24:18AM +, Kyrill Tkachov wrote: > > On 10/03/17 06:24, Jakub Jelinek wrote: > > On Thu, Mar 09, 2017 at 12:45:25PM -0500, David Malcolm wrote: > > > gcc/ChangeLog: > > > PR translation/79923 > > > * auto-profile.c (get_combined_location): Convert leading > > > character of diagnostics to lower case and remove trailing period. > > > (read_profile): Likewise for various diagnostics. > > > * config/arm/arm-builtins.c (arm_expand_builtin): Remove trailing > > > period from various diagnostics. > > > * config/arm/arm.c (arm_option_override): Likewise. > > > * config/msp430/msp430.c (msp430_expand_delay_cycles): Likewise. > > > (msp430_expand_delay_cycles): Likewise. > > Mostly ok, but for > > > > > --- a/gcc/config/arm/arm-builtins.c > > > +++ b/gcc/config/arm/arm-builtins.c > > > @@ -2990,60 +2990,60 @@ arm_expand_builtin (tree exp, > > > && (imm < 0 || imm > 32)) > > > { > > > if (fcode == ARM_BUILTIN_WRORHI) > > > - error ("the range of count should be in 0 to 32. please check > > > the intrinsic _mm_rori_pi16 in code."); > > > + error ("the range of count should be in 0 to 32. please check > > > the intrinsic _mm_rori_pi16 in code"); > > I wonder if this shouldn't use a semicolon space in the middle > > instead of dot space space (many times in the same file). > > Is there a convention in GCC to use semicolons? > I'm okay with changing it to a semicolon (it's slightly better IMO) as long > as it's consistent > with the style GCC uses. We have tons of messages like: invalid --param name %qs; did you mean %qs? Jakub
Re: [PATCH 3/7] Remove trailing period from various diagnostic messages (PR translation/79923)
On 10/03/17 06:24, Jakub Jelinek wrote: On Thu, Mar 09, 2017 at 12:45:25PM -0500, David Malcolm wrote: gcc/ChangeLog: PR translation/79923 * auto-profile.c (get_combined_location): Convert leading character of diagnostics to lower case and remove trailing period. (read_profile): Likewise for various diagnostics. * config/arm/arm-builtins.c (arm_expand_builtin): Remove trailing period from various diagnostics. * config/arm/arm.c (arm_option_override): Likewise. * config/msp430/msp430.c (msp430_expand_delay_cycles): Likewise. (msp430_expand_delay_cycles): Likewise. Mostly ok, but for --- a/gcc/config/arm/arm-builtins.c +++ b/gcc/config/arm/arm-builtins.c @@ -2990,60 +2990,60 @@ arm_expand_builtin (tree exp, && (imm < 0 || imm > 32)) { if (fcode == ARM_BUILTIN_WRORHI) - error ("the range of count should be in 0 to 32. please check the intrinsic _mm_rori_pi16 in code."); + error ("the range of count should be in 0 to 32. please check the intrinsic _mm_rori_pi16 in code"); I wonder if this shouldn't use a semicolon space in the middle instead of dot space space (many times in the same file). Is there a convention in GCC to use semicolons? I'm okay with changing it to a semicolon (it's slightly better IMO) as long as it's consistent with the style GCC uses. Also, for the benefit of translators, this might be better done as error ("the range of count should be in 0 to 32; please check the intrinsic %s in code", "_mm_rori_pi16"); so that there are fewer of these messages. Adding some ARM folks on this. These iWMMXt builtins haven't been touched in ages and could do with some TLC in general. For example, I'm not a fan of having all these "please check the intrinsic ..." messages. If we've got a reference to the tree we're expanding, isn't there some kind of error function that will point to the location in the source that's causing the error? I'd rather use that than hardcoding the intrinsic names. This would also allow us to collapse all these if (fcode == <...>) error (...); else if (fcode == <...>) error (...); else if ... constructs. While we're at it: if (fcode == ARM_BUILTIN_WSRLHI) - error ("the count should be no less than 0. please check the intrinsic _mm_srli_pi16 in code."); + error ("the count should be no less than 0. please check the intrinsic _mm_srli_pi16 in code"); Let's use "the count should be a non-negative integer" to be consistent with the error reporting for UInteger error messages. Perhaps commit everything except arm-builtins.c separately and deal with this part with the ARM folks? I agree. David, if you want to clean up the error reporting in these intrinsics as a separate patch I'd be grateful. Otherwise, could you please open a bugzilla ticket so we can track this? Thanks, Kyrill Jakub
Re: [PATCH 3/7] Remove trailing period from various diagnostic messages (PR translation/79923)
On Thu, Mar 09, 2017 at 12:45:25PM -0500, David Malcolm wrote: > gcc/ChangeLog: > PR translation/79923 > * auto-profile.c (get_combined_location): Convert leading > character of diagnostics to lower case and remove trailing period. > (read_profile): Likewise for various diagnostics. > * config/arm/arm-builtins.c (arm_expand_builtin): Remove trailing > period from various diagnostics. > * config/arm/arm.c (arm_option_override): Likewise. > * config/msp430/msp430.c (msp430_expand_delay_cycles): Likewise. > (msp430_expand_delay_cycles): Likewise. Mostly ok, but for > --- a/gcc/config/arm/arm-builtins.c > +++ b/gcc/config/arm/arm-builtins.c > @@ -2990,60 +2990,60 @@ arm_expand_builtin (tree exp, > && (imm < 0 || imm > 32)) > { > if (fcode == ARM_BUILTIN_WRORHI) > - error ("the range of count should be in 0 to 32. please check > the intrinsic _mm_rori_pi16 in code."); > + error ("the range of count should be in 0 to 32. please check > the intrinsic _mm_rori_pi16 in code"); I wonder if this shouldn't use a semicolon space in the middle instead of dot space space (many times in the same file). Also, for the benefit of translators, this might be better done as error ("the range of count should be in 0 to 32; please check the intrinsic %s in code", "_mm_rori_pi16"); so that there are fewer of these messages. Adding some ARM folks on this. Perhaps commit everything except arm-builtins.c separately and deal with this part with the ARM folks? Jakub
[PATCH 3/7] Remove trailing period from various diagnostic messages (PR translation/79923)
gcc/ChangeLog: PR translation/79923 * auto-profile.c (get_combined_location): Convert leading character of diagnostics to lower case and remove trailing period. (read_profile): Likewise for various diagnostics. * config/arm/arm-builtins.c (arm_expand_builtin): Remove trailing period from various diagnostics. * config/arm/arm.c (arm_option_override): Likewise. * config/msp430/msp430.c (msp430_expand_delay_cycles): Likewise. (msp430_expand_delay_cycles): Likewise. --- gcc/auto-profile.c| 14 ++--- gcc/config/arm/arm-builtins.c | 48 +-- gcc/config/arm/arm.c | 2 +- gcc/config/msp430/msp430.c| 4 ++-- 4 files changed, 34 insertions(+), 34 deletions(-) diff --git a/gcc/auto-profile.c b/gcc/auto-profile.c index 6255f94..4b21340 100644 --- a/gcc/auto-profile.c +++ b/gcc/auto-profile.c @@ -344,7 +344,7 @@ get_combined_location (location_t loc, tree decl) { /* TODO: allow more bits for line and less bits for discriminator. */ if (LOCATION_LINE (loc) - DECL_SOURCE_LINE (decl) >= (1<<16)) -warning_at (loc, OPT_Woverflow, "Offset exceeds 16 bytes."); +warning_at (loc, OPT_Woverflow, "offset exceeds 16 bytes"); return ((LOCATION_LINE (loc) - DECL_SOURCE_LINE (decl)) << 16); } @@ -917,13 +917,13 @@ read_profile (void) { if (gcov_open (auto_profile_file, 1) == 0) { - error ("Cannot open profile file %s.", auto_profile_file); + error ("cannot open profile file %s", auto_profile_file); return; } if (gcov_read_unsigned () != GCOV_DATA_MAGIC) { - error ("AutoFDO profile magic number does not match."); + error ("AutoFDO profile magic number does not match"); return; } @@ -931,7 +931,7 @@ read_profile (void) unsigned version = gcov_read_unsigned (); if (version != AUTO_PROFILE_VERSION) { - error ("AutoFDO profile version %u does match %u.", + error ("AutoFDO profile version %u does match %u", version, AUTO_PROFILE_VERSION); return; } @@ -943,7 +943,7 @@ read_profile (void) afdo_string_table = new string_table (); if (!afdo_string_table->read()) { - error ("Cannot read string table from %s.", auto_profile_file); + error ("cannot read string table from %s", auto_profile_file); return; } @@ -951,7 +951,7 @@ read_profile (void) afdo_source_profile = autofdo_source_profile::create (); if (afdo_source_profile == NULL) { - error ("Cannot read function profile from %s.", auto_profile_file); + error ("cannot read function profile from %s", auto_profile_file); return; } @@ -961,7 +961,7 @@ read_profile (void) /* Read in the working set. */ if (gcov_read_unsigned () != GCOV_TAG_AFDO_WORKING_SET) { - error ("Cannot read working set from %s.", auto_profile_file); + error ("cannot read working set from %s", auto_profile_file); return; } diff --git a/gcc/config/arm/arm-builtins.c b/gcc/config/arm/arm-builtins.c index 689219c..661c028 100644 --- a/gcc/config/arm/arm-builtins.c +++ b/gcc/config/arm/arm-builtins.c @@ -2990,60 +2990,60 @@ arm_expand_builtin (tree exp, && (imm < 0 || imm > 32)) { if (fcode == ARM_BUILTIN_WRORHI) - error ("the range of count should be in 0 to 32. please check the intrinsic _mm_rori_pi16 in code."); + error ("the range of count should be in 0 to 32. please check the intrinsic _mm_rori_pi16 in code"); else if (fcode == ARM_BUILTIN_WRORWI) - error ("the range of count should be in 0 to 32. please check the intrinsic _mm_rori_pi32 in code."); + error ("the range of count should be in 0 to 32. please check the intrinsic _mm_rori_pi32 in code"); else if (fcode == ARM_BUILTIN_WRORH) - error ("the range of count should be in 0 to 32. please check the intrinsic _mm_ror_pi16 in code."); + error ("the range of count should be in 0 to 32. please check the intrinsic _mm_ror_pi16 in code"); else - error ("the range of count should be in 0 to 32. please check the intrinsic _mm_ror_pi32 in code."); + error ("the range of count should be in 0 to 32. please check the intrinsic _mm_ror_pi32 in code"); } else if ((fcode == ARM_BUILTIN_WRORDI || fcode == ARM_BUILTIN_WRORD) && (imm < 0 || imm > 64)) { if (fcode == ARM_BUILTIN_WRORDI) - error ("the range of count should be in 0 to 64. please check the intrinsic _mm_rori_si64 in code."); + error ("the range of count should be in 0 to 64. please check the intrinsic _mm_rori_si64 in code"); else - error ("the range of count should be in 0 to 64. please check the intrinsic _mm