Re: [alsa-devel] [PATCH v3 2/5] ASoC: tda998x: add a codec driver for the TDA998x

2014-02-04 Thread Mark Brown
On Tue, Feb 04, 2014 at 02:36:50PM +0100, Lars-Peter Clausen wrote:
> On 02/04/2014 02:30 PM, Mark Brown wrote:

> >>+static const struct snd_soc_dapm_route tda_routes[] = {
> >>+   { "hdmi-out", NULL, "HDMI I2S Playback" },
> >>+   { "hdmi-out", NULL, "HDMI SPDIF Playback" },
> >>+};

> >S/PDIF.

> Won't this cause issues with the debugfs widget entries? It's
> fixable by escaping it (replace it by a dash or something) in the
> debugfs widget filename, but I don't think we do this right now.

Oh, bother, so it will.


signature.asc
Description: Digital signature


Re: [alsa-devel] [PATCH v3 2/5] ASoC: tda998x: add a codec driver for the TDA998x

2014-02-04 Thread Lars-Peter Clausen

On 02/04/2014 02:30 PM, Mark Brown wrote:
[...]


What does this actually do?  No information is being passed in to the
core function here, not even any information on if it's starting or
stopping.  Looking at the rest of the code I can't help thinking it
might be clearer to inline this possibly with a lookup helper, the code
is very small and the lack of parameters makes it hard to follow.


+static const struct snd_soc_dapm_route tda_routes[] = {
+   { "hdmi-out", NULL, "HDMI I2S Playback" },
+   { "hdmi-out", NULL, "HDMI SPDIF Playback" },
+};


S/PDIF.


Won't this cause issues with the debugfs widget entries? It's fixable by 
escaping it (replace it by a dash or something) in the debugfs widget 
filename, but I don't think we do this right now.


- Lars

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/