Blake Eggleston created CASSANDRA-13830:
-------------------------------------------

             Summary: Simplify MerkleTree.difference/differenceHelper
                 Key: CASSANDRA-13830
                 URL: https://issues.apache.org/jira/browse/CASSANDRA-13830
             Project: Cassandra
          Issue Type: Bug
            Reporter: Blake Eggleston
            Assignee: Blake Eggleston


As brought up in CASSANDRA-13603, {{MerkleTree.differenceHelper}} is overly 
complex and difficult to follow for what it's doing. It also shares some of 
it's responsibilities with {{difference}}, and assumes that the trees it's 
given have differences, which makes it a potential source of future bugs.

Since we're just trying to recursively compare these trees and record the 
largest contiguous out of sync ranges, I think this could be simplified a bit. 
I propose that we refactor {{difference}} / {{differenceHelper}} so that 
{{difference}} is only concerned with supplying the range, and dealing with the 
{{FULLY_INCONSISTENT}} case, and move everything else into a recursable helper 
method.

I put together an alternate implementation 
[here|https://github.com/bdeggleston/cassandra/tree/differencer-cleanup].



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org
For additional commands, e-mail: commits-h...@cassandra.apache.org

Reply via email to