svn commit: r1333665 - /ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/HashCrypt.java

2012-05-03 Thread doogie
Author: doogie Date: Thu May 3 22:20:30 2012 New Revision: 1333665 URL: http://svn.apache.org/viewvc?rev=1333665&view=rev Log: OPTIMIZE: Move the oldFunnyHex logic into a single internal helper function. Modified: ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/HashCrypt.java Modified:

svn commit: r1333664 - in /ofbiz/trunk: applications/securityext/src/org/ofbiz/securityext/login/ framework/base/src/org/ofbiz/base/crypto/ framework/common/src/org/ofbiz/common/login/ specialpurpose/

2012-05-03 Thread doogie
Author: doogie Date: Thu May 3 22:20:24 2012 New Revision: 1333664 URL: http://svn.apache.org/viewvc?rev=1333664&view=rev Log: OPTIMIZE: Remove cryptPassword(String, String); it is not nescessary to go thru a deprecation cycle for this, as this method was only recently added, and has never been o

svn commit: r1333663 - /ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/HashCrypt.java

2012-05-03 Thread doogie
Author: doogie Date: Thu May 3 22:20:11 2012 New Revision: 1333663 URL: http://svn.apache.org/viewvc?rev=1333663&view=rev Log: OPTIMIZE: s/getCrypted/getCryptedValue/; this is an internal function only. Functions that deal with byte[] should be named as fooBytes. Modified: ofbiz/trunk/frame

svn commit: r1333662 - /ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/HashCrypt.java

2012-05-03 Thread doogie
Author: doogie Date: Thu May 3 22:20:05 2012 New Revision: 1333662 URL: http://svn.apache.org/viewvc?rev=1333662&view=rev Log: OPTIMIZE: Move the 3 if/elseif/else bodies into separate functions. Modified: ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/HashCrypt.java Modified: ofbiz/tr

svn commit: r1333661 - /ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/HashCrypt.java

2012-05-03 Thread doogie
Author: doogie Date: Thu May 3 22:19:58 2012 New Revision: 1333661 URL: http://svn.apache.org/viewvc?rev=1333661&view=rev Log: OPTIMIZE: Add a getMessageDigest static helper function. Modified: ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/HashCrypt.java Modified: ofbiz/trunk/framewo

svn commit: r1333655 - /ofbiz/trunk/framework/base/src/org/ofbiz/base/util/UtilObject.java

2012-05-03 Thread doogie
Author: doogie Date: Thu May 3 22:13:11 2012 New Revision: 1333655 URL: http://svn.apache.org/viewvc?rev=1333655&view=rev Log: OPTIMIZE/FEATURE: Factor getObject into another helper, getObjectException; the latter doesn't catch any exceptions, and doesn't log them. Modified: ofbiz/trunk/fram

svn commit: r1333654 - /ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/HashCrypt.java

2012-05-03 Thread doogie
Author: doogie Date: Thu May 3 22:13:04 2012 New Revision: 1333654 URL: http://svn.apache.org/viewvc?rev=1333654&view=rev Log: OPTIMIZE: Switch internal getCrypted to take a byte array, and use String.getBytes(Charset) to fetch the bytes. Also switches the one case of getBytes("UTF-8") to the Ch

svn commit: r1333623 - /ofbiz/trunk/framework/entity/src/org/ofbiz/entity/GenericDelegator.java

2012-05-03 Thread doogie
Author: doogie Date: Thu May 3 21:13:33 2012 New Revision: 1333623 URL: http://svn.apache.org/viewvc?rev=1333623&view=rev Log: OPTIMIZE: s/encHex/encValue/, this is a more accurate variable name. Modified: ofbiz/trunk/framework/entity/src/org/ofbiz/entity/GenericDelegator.java Modified: of

svn commit: r1333622 - /ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/Main.java

2012-05-03 Thread doogie
Author: doogie Date: Thu May 3 21:13:27 2012 New Revision: 1333622 URL: http://svn.apache.org/viewvc?rev=1333622&view=rev Log: FEATURE: Add a -digest variant, that uses the deprecated password digesting code. Modified: ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/Main.java Modified:

svn commit: r1333621 - /ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/HashCrypt.java

2012-05-03 Thread doogie
Author: doogie Date: Thu May 3 21:13:21 2012 New Revision: 1333621 URL: http://svn.apache.org/viewvc?rev=1333621&view=rev Log: FEATURE: Improve warning when an oldFunnyHex hash is detected on a password. Modified: ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/HashCrypt.java Modified:

svn commit: r1333620 - /ofbiz/trunk/framework/entity/src/org/ofbiz/entity/GenericDelegator.java

2012-05-03 Thread doogie
Author: doogie Date: Thu May 3 21:13:14 2012 New Revision: 1333620 URL: http://svn.apache.org/viewvc?rev=1333620&view=rev Log: OPTIMIZE: Remove andCacheFieldSets from GenericDelegator; this variable hasn't been used in like forever, man. Modified: ofbiz/trunk/framework/entity/src/org/ofbiz/e

svn commit: r1333619 - /ofbiz/trunk/framework/base/src/org/ofbiz/base/crypto/Main.java

2012-05-03 Thread doogie
Author: doogie Date: Thu May 3 21:13:08 2012 New Revision: 1333619 URL: http://svn.apache.org/viewvc?rev=1333619&view=rev Log: FIX: Oops, my bad. Originally, this was never meant to actually be committed upstream. However, I decided that it might be generally useful, so committed it anyways. I

svn commit: r1333492 - /ofbiz/trunk/framework/minilang/src/org/ofbiz/minilang/method/envops/SetOperation.java

2012-05-03 Thread adrianc
Author: adrianc Date: Thu May 3 15:01:01 2012 New Revision: 1333492 URL: http://svn.apache.org/viewvc?rev=1333492&view=rev Log: Minor code change in Mini-language element. No Functional change. Modified: ofbiz/trunk/framework/minilang/src/org/ofbiz/minilang/method/envops/SetOperation.java

svn commit: r1333491 - in /ofbiz/trunk/framework/minilang: dtd/ src/org/ofbiz/minilang/ src/org/ofbiz/minilang/method/ src/org/ofbiz/minilang/method/callops/

2012-05-03 Thread adrianc
Author: adrianc Date: Thu May 3 14:59:56 2012 New Revision: 1333491 URL: http://svn.apache.org/viewvc?rev=1333491&view=rev Log: Overhauled Mini-languageand elements. Modified: ofbiz/trunk/framework/minilang/dtd/simple-methods-v2.xsd ofbiz/trunk/framework/minilang/src/org/ofbiz/mini

svn commit: r1333489 - in /ofbiz/trunk/framework/minilang/src/org/ofbiz/minilang: MiniLangElement.java MiniLangException.java MiniLangRuntimeException.java method/MethodOperation.java

2012-05-03 Thread adrianc
Author: adrianc Date: Thu May 3 14:57:40 2012 New Revision: 1333489 URL: http://svn.apache.org/viewvc?rev=1333489&view=rev Log: Created a base class - MiniLangElement - for all Mini-language elements, modified exception handling to accommodate the new base class. This change will provide a mean

svn commit: r1333439 [1/2] - /ofbiz/trunk/applications/accounting/config/AccountingEntityLabels.xml

2012-05-03 Thread chrisg
Author: chrisg Date: Thu May 3 12:54:27 2012 New Revision: 1333439 URL: http://svn.apache.org/viewvc?rev=1333439&view=rev Log: German translation for AccountingEntityLabels Modified: ofbiz/trunk/applications/accounting/config/AccountingEntityLabels.xml