RE: [functor] Iterator and Generator

2003-07-18 Thread Jason Horman
I think there are a few reasons that generators may be better than or a compliment to iterators. They are somewhat easier to write. You literally just write a loop that calls a function on each iteration. Writing a generator as an anon inner class is easier since there is only 1 method to implem

RE: [lang] Proposal (2): isEmpty

2003-07-18 Thread Henri Yandell
On Fri, 18 Jul 2003, Gary Gregory wrote: > I like #2. Boo! ;) Seriously for a moment. I think the usage of commons-lang is beginning to hit the up-curve. It's creeping into projects and people are starting to talk about it [along with other Commons things] outside of the usual circles. A 2.0 s

Re: [lang] Proposal (2): isEmpty

2003-07-18 Thread Henri Yandell
On Fri, 18 Jul 2003, Lavandowska wrote: > I could live with #1, though I'd rather the current contract (the > trim() functionality) didn't change (whine whine whine). isBlank! Just think of the joy you'll have as you switch to it. It's such a sexier name. > Or #2 is fine also, but I'd suggest

Re: [lang] Proposal (2): isEmpty

2003-07-18 Thread Henri Yandell
The comments at http://raibledesigns.com/comments/rd/minimal/commons_lang_stringutils are a good reason for how surprisingly nice people find isEmpty. On Fri, 18 Jul 2003, Stephen Colebourne wrote: > Proposal for methods: > > - isEmpty() - true for "" or null > - isNotEmpty() - opposite > - is

Re: [functor] Iterator and Generator

2003-07-18 Thread Mark R. Diggory
At first blush (and not having any experience actually using Generators directly) I guess the questionability for me lies in the issue of how often would someone want to create a Generator that is not an Iterator. -Mark Rodney Waldhoff wrote: As far as I can tell, the role of generator is essen

Re: Daemon Project; set_caps patch and Daemon interface bug notice.

2003-07-18 Thread Bill Barker
"Kevin O'Donnell" <[EMAIL PROTECTED]> wrote in message news:[EMAIL PROTECTED] > Hi Commons - great work on the Daemon sandbox project. I just put it > into production in my environment today. I thought I would give some > feedback on a few issues I had: > > * I have no idea what "set_caps()"

cvs commit: jakarta-commons/lang/src/java/org/apache/commons/lang/builder CompareToBuilder.java

2003-07-18 Thread ggregory
ggregory2003/07/18 20:25:39 Modified:lang/src/java/org/apache/commons/lang/builder CompareToBuilder.java Log: Severity Description ResourceIn Folder Location Creation Time The static method setAccessible(AccessibleObject[

RE: [lang] Proposal (2): isEmpty

2003-07-18 Thread Gary Gregory
I like #2. A clarification please: I do not see why any isWhitespace methods are needed since the isBlank methods trim()'s their arguments. isBlank(null) returns true isWS(null) returns true isBlank("") returns true isWS("") returns true isBlank(" ") returns true isWS(" ") returns true isBlank

Re: [lang] StringUtils isEmpty summary(2)

2003-07-18 Thread Lavandowska
I likewise disagree on d (I rather liked isNotNullOrEmpty - despite being long. Oops, isNotEmptyOrNull). Also, I wanted to clarify my position as depicted in b: not that all whitespace is removed, but as a String.trim() removes whitespace on either end. If the String is all whitespace, the result

Re: [lang] Proposal (2): isEmpty

2003-07-18 Thread Lavandowska
I could live with #1, though I'd rather the current contract (the trim() functionality) didn't change (whine whine whine). Or #2 is fine also, but I'd suggest another name (StringTests connotes Unit tests to me), maybe StringChecks or CheckString? Lance --- Stephen Colebourne <[EMAIL PROTECTED]>

cvs commit: jakarta-commons/collections/src/java/org/apache/commons/collections CollectionUtils.java

2003-07-18 Thread scolebourne
scolebourne2003/07/18 17:30:08 Modified:collections/src/java/org/apache/commons/collections CollectionUtils.java Log: Javadoc improvement prompted by K.C. Baltz Revision ChangesPath 1.33 +5 -3 jakarta-commons/collections/src/java/org/a

RE: [Modeler] Next Release plan? (1.1?)

2003-07-18 Thread Davanum Srinivas
Am trying to chase this down... Thanks, dims --- "Shapira, Yoav" <[EMAIL PROTECTED]> wrote: > > Howdy, > I was never given karma as a modeler (or commons) committer, so I was > never able to go ahead with the release. It's still a bottleneck for > tomcat 5 ;( I have no idea why this happened,

cvs commit: jakarta-commons/lang/src/java/org/apache/commons/lang StringUtils.java

2003-07-18 Thread scolebourne
scolebourne2003/07/18 17:22:51 Modified:lang/src/test/org/apache/commons/lang StringUtilsTest.java lang/src/java/org/apache/commons/lang StringUtils.java Log: Minor performance tweaks, and some extra tests Revision ChangesPath 1.28 +20 -1 jakarta-

[functor] Iterator and Generator

2003-07-18 Thread Rodney Waldhoff
As far as I can tell, the role of generator is essentially that of an Iterator, it provides a mechanism for doing something to each element in a "collection" (not necessarily a Collection). The major differences being: * Generator has a "close" method (currently stop()). This is used for things

cvs commit: jakarta-commons/lang/src/java/org/apache/commons/lang StringUtils.java

2003-07-18 Thread scolebourne
scolebourne2003/07/18 16:57:43 Modified:lang/src/test/org/apache/commons/lang StringUtilsTest.java lang/src/java/org/apache/commons/lang StringUtils.java Log: Fixed leftPad() and rightPad() to correctly handle multi letter pad strings Revision ChangesPath 1

[lang] Proposal (2): isEmpty

2003-07-18 Thread Stephen Colebourne
Proposal for methods: - isEmpty() - true for "" or null - isNotEmpty() - opposite - isEmptyNN() - true for "" - isBlank() - trims - true for " ", "" or null - isNotBlank() - opposite - isBlankNN() - trims - true for " " or "" - isWhitespace() - true for all whitespace, "" or null - isNotWhites

Re: [lang] StringUtils isEmpty summary(2)

2003-07-18 Thread __matthewHawthorne
I disagree with items d) and e)... I don't think either method name is too long, and as you said, the meaning is clear. Stephen Colebourne wrote: Well the position changes again, but the desire to release remains constant. Here's what we know now: Currently isEmpty() means trim, true for " ",

[lang] StringUtils isEmpty summary(2)

2003-07-18 Thread Stephen Colebourne
Well the position changes again, but the desire to release remains constant. Here's what we know now: Currently isEmpty() means trim, true for " ", "" or null Currently isNotEmpty() means not "" and not null (no trim) An incompatability on trim that we are trying to solve. a) Changing the curren

Daemon Project; set_caps patch and Daemon interface bug notice.

2003-07-18 Thread Kevin O'Donnell
Hi Commons - great work on the Daemon sandbox project. I just put it into production in my environment today. I thought I would give some feedback on a few issues I had: * I have no idea what "set_caps()" is for, but in my environment it was breaking everything. I just commented it ou

RE: [lang] Pre 2.0 StringUtils NPE changes

2003-07-18 Thread Gary Gregory
Actually, I like have both: isEmpty(s) which means 'is "" or not' and hasValue or isSomething which means 'is a not a white space string or null' Gary -Original Message- From: Lavandowska [mailto:[EMAIL PROTECTED] Sent: Friday, July 18, 2003 13:46 To: Jakarta Commons Developers List S

cvs commit: jakarta-commons/discovery/src/java/org/apache/commons/discovery/resource/names DiscoverServiceNames.java

2003-07-18 Thread rsitze
rsitze 2003/07/18 13:53:51 Modified:discovery/src/java/org/apache/commons/discovery/resource/names DiscoverServiceNames.java Log: import cleanup Revision ChangesPath 1.3 +0 -1 jakarta-commons/discovery/src/java/org/apache/commons/disco

RE: [lang] Pre 2.0 StringUtils NPE changes

2003-07-18 Thread Lavandowska
I think (and my personal experience) is that the isEmpty() acts as a short-cut for "has a value"; where value is not a whitespace character and is not null (thus the trim - whitespaces are not 'valued'). This is so subjective though, I'm sure hasValue() would quickly be shot down ;-) --- Janek Bo

RE: [lang] StringUtils isEmpty change

2003-07-18 Thread Howard M. Lewis Ship
I would prefer to keep it the way it is. If someone needs to explicitly check for null, let them. I missed the discussion about why this change is needed ... from my point of view, it looks like change for change's sake. -- Howard M. Lewis Ship Creator, Tapestry: Java Web Components http://jaka

RE: [Modeler] Next Release plan? (1.1?)

2003-07-18 Thread Shapira, Yoav
Howdy, I was never given karma as a modeler (or commons) committer, so I was never able to go ahead with the release. It's still a bottleneck for tomcat 5 ;( I have no idea why this happened, as the vote took place and I emailed the requisite people (PMC etc.), but no luck ;( Yoav Shapira Mille

[Modeler] Next Release plan? (1.1?)

2003-07-18 Thread Davanum Srinivas
Yoav, others modeler-folks, Is there a date for 1.1 release of Modeler? Thanks, dims = Davanum Srinivas - http://webservices.apache.org/~dims/ __ Do you Yahoo!? SBC Yahoo! DSL - Now only $29.95 per month! http://sbc.yahoo.com

[lang] build.xml fails in test.lang

2003-07-18 Thread Gary Gregory
Title: [lang] build.xml fails in test.lang I've got the latest from CVS and I get: test.lang: [echo] Running lang package tests ... [java] . [java] . [java] ...

RE: [lang] StringUtils isEmpty change

2003-07-18 Thread Gary Gregory
When I read: StringUtils.isBlank(s) I translate that to: s.trim().length() == 0 Nulls are a separate beast to me. Gary -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] Sent: Friday, July 18, 2003 09:15 To: [EMAIL PROTECTED] Cc: [EMAIL PROTECTED]; [EMAIL PROTECTED

cvs commit: jakarta-commons/lang/src/test/org/apache/commons/lang/time DurationFormatUtilsTest.java

2003-07-18 Thread ggregory
ggregory2003/07/18 10:05:54 Modified:lang/src/test/org/apache/commons/lang/time DurationFormatUtilsTest.java Log: Added an ISO 8601 formatter for the date time extended format used in durations, with XML Schema durations particularly in mind. Note that the

cvs commit: jakarta-commons/lang/src/java/org/apache/commons/lang/time DurationFormatUtils.java

2003-07-18 Thread ggregory
ggregory2003/07/18 10:04:31 Modified:lang/src/java/org/apache/commons/lang/time DurationFormatUtils.java Log: Added an ISO 8601 formatter for the date time extended format used in durations, with XML Schema durations particularly in mind. Note that this is

RE: [lang] 2.0RC SystemUtils.IS_OS_OS2's JavaDoc is wrong.

2003-07-18 Thread Gary Gregory
Tetsuya, Patch applied and recorded here: http://issues.apache.org/bugzilla/show_bug.cgi?id=21715 Thank you, Gary -Original Message- From: KANEUCHI Tetsuya [mailto:[EMAIL PROTECTED] Sent: Friday, July 18, 2003 08:12 To: [EMAIL PROTECTED] Subject: [lang] 2.0RC SystemUtils.IS_OS_OS2's Jav

Re: [lang] Pre 2.0 - StringUtils.isEmpty(), isNotEmpty() and stri ngsa with somespaces

2003-07-18 Thread __matthewHawthorne
I think it would be easier to have different extensions or wrappers for StringUtils, such as: NullFriendlyStringUtils or TrimmedStringUtils Or, maybe a type of StringUtilsFactory that could take the params you suggested and return a corresponding instance. This situation seems so controversial,

DO NOT REPLY [Bug 21715] - SystemUtils.IS_OS_OS2 Javadoc is wrong

2003-07-18 Thread bugzilla
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT . ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND INSERTED IN THE BUG DATABASE. http://nagoya.apache.org/bugzilla/show_bu

cvs commit: jakarta-commons/lang/src/java/org/apache/commons/lang SystemUtils.java

2003-07-18 Thread ggregory
ggregory2003/07/18 09:48:25 Modified:lang/src/java/org/apache/commons/lang SystemUtils.java Log: PR: 21715 Obtained from: commons-dev Submitted by: KANEUCHI Tetsuya [mailto:[EMAIL PROTECTED] Reviewed by: Gary Gregory Revision ChangesPath 1.18 +2 -2 jaka

DO NOT REPLY [Bug 21715] New: - SystemUtils.IS_OS_OS2 Javadoc is wrong

2003-07-18 Thread bugzilla
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT . ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND INSERTED IN THE BUG DATABASE. http://nagoya.apache.org/bugzilla/show_bu

Re: [Friday] General question on OO database design

2003-07-18 Thread Janek Bogucki
On Fri, 2003-07-18 at 16:15, Yansheng Lin wrote: > > Is there a standard spec on OO database modeling? Is there a project that > facilitates OO database access layer in Commons? It would be so good if we can > do something like getPerson(id) to a database directly instead of structured SQL > que

RE: [lang] Pre 2.0 - StringUtils.isEmpty(), isNotEmpty() and stri ngsa with somespaces

2003-07-18 Thread Gary Gregory
What if you could instantiate StringUtils if you did not like the default behavior: new StringUtils(StringUtils.ALWAYS_TRIM, StringUtils.DISCARD_NULL); ? Just a random thought. Gary -Original Message- From: Lavandowska [mailto:[EMAIL PROTECTED] Sent: Friday, July 18, 2003 07:30 To: Ja

RE: [lang] Pre 2.0 StringUtils NPE changes

2003-07-18 Thread Janek Bogucki
On Fri, 2003-07-18 at 13:49, Hope, Matthew wrote: > interesting problem... > > "empty string" has a very clear meaning in java, it is a non null String > object of zero length. > > Does the entrenched user base merit retaining a non standard naming > convention. > > or is Empty sufficiently ent

[Friday] General question on OO database design

2003-07-18 Thread Yansheng Lin
Is there a standard spec on OO database modeling? Is there a project that facilitates OO database access layer in Commons? It would be so good if we can do something like getPerson(id) to a database directly instead of structured SQL queries. Thanks! --

[lang] StringUtils isEmpty change

2003-07-18 Thread scolebourne
Howard, Henning, Others, Can you confirm or deny if the method isEmptyOrNull() is an acceptably named replacement to isEmpty()? We are trying to be more explicit in naming. Otherwise can you find a word that means 'empty or null'? Perhaps we could have isBlank() as a synonym of isEmptyOrNull?

[lang] 2.0RC SystemUtils.IS_OS_OS2's JavaDoc is wrong.

2003-07-18 Thread KANEUCHI Tetsuya
I found small mistake in Commons Lang 2.0RC1. SystemUtils.IS_OS_OS2's javadoc says "if this is Mac." It should be "OS/2". RCS file: /home/cvspublic/jakarta-commons/lang/src/java/org/apache/commons/lang/ SystemUtils.java,v retrieving revision 1.17 diff -u -r1.17 SystemUtils.jav

Re: [lang] Pre 2.0 - StringUtils.isEmpty(), isNotEmpty() and stri ngsa with somespaces

2003-07-18 Thread Lavandowska
I missed this one earlier, so I guess 2.0 would still work for me, though I find isEmptyTrimmedOrNull() extremely cumbersome. I'd likely just move to isEmpty( trim( str ) ) myself, rather than use the added method signatures. Lance --- Todd Jonker <[EMAIL PROTECTED]> wrote: > On 7/15/03 8:12 PM

RE: [lang] Pre 2.0 StringUtils NPE changes

2003-07-18 Thread Lavandowska
Matthew speaks truth here, but if the proposed changes are made StringUtils (2.0) will no longer suit my needs. Years before StringUtils I had my own StringUtil with isEmpty() and isNotEmpty(), which performed a trim(). So I've long had the need to treat " " == null (to paraphrase Howard). I t

cvs commit: jakarta-commons/logging .cvsignore

2003-07-18 Thread rsitze
rsitze 2003/07/18 07:15:50 Modified:logging .cvsignore Log: Revision ChangesPath 1.5 +3 -2 jakarta-commons/logging/.cvsignore Index: .cvsignore === RCS file: /home/cvs/jakarta-commons/l

cvs commit: jakarta-commons/logging/src/java/org/apache/commons/logging/impl Log4JCategoryLog.java Log4jFactory.java Log4JLogger.java

2003-07-18 Thread rsitze
rsitze 2003/07/18 07:14:16 Modified:logging/src/java/org/apache/commons/logging/impl Log4JCategoryLog.java Log4jFactory.java Log4JLogger.java Log: Cleanup imports. Revision ChangesPath 1.11 +6 -6 jakarta-commons/

cvs commit: jakarta-commons/logging/src/test/org/apache/commons/logging LogTest.java LoadTest.java

2003-07-18 Thread rsitze
rsitze 2003/07/18 07:11:45 Modified:logging/src/test/org/apache/commons/logging/log4j CustomConfigTestCase.java DefaultConfigTestCase.java logging/src/test/org/apache/commons/logging/jdk14 DefaultConf

RE: [lang] Pre 2.0 StringUtils NPE changes

2003-07-18 Thread Hope, Matthew
interesting problem... "empty string" has a very clear meaning in java, it is a non null String object of zero length. Does the entrenched user base merit retaining a non standard naming convention. or is Empty sufficiently entrenched to also mean null? (I don't think it is) I appreciate the d