Re: [lang] StringUtils.sliceFirstRemainder behavior

2003-07-24 Thread Stephen Colebourne
This is checked in now. Actually today I came across the JSTL method names substringAfter() and substringBefore(). Maybe these are better names? Of course you'd need substringAfterLast() and substringBeforeLast(), but maybe its more expressive than slice. Not sure. Stephen - Original Message

DO NOT REPLY [Bug 21841] - [lang] Rationalize StringUtils slice functions

2003-07-24 Thread bugzilla
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT . ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND INSERTED IN THE BUG DATABASE. http://nagoya.apache.org/bugzilla/show_bu

DO NOT REPLY [Bug 21841] - [lang] Rationalize StringUtils slice functions

2003-07-24 Thread bugzilla
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT . ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND INSERTED IN THE BUG DATABASE. http://nagoya.apache.org/bugzilla/show_bu

cvs commit: jakarta-commons/lang/src/java/org/apache/commons/lang StringUtils.java

2003-07-24 Thread scolebourne
scolebourne2003/07/24 17:50:01 Modified:lang/src/test/org/apache/commons/lang StringUtilsTest.java lang/src/java/org/apache/commons/lang StringUtils.java Log: Update slice methods to be more consistent from Phil Steitz Revision ChangesPath 1.38 +5 -7

Re: [collections][submission] NotifyingCollections

2003-07-24 Thread Neil O'Toole
> I can't access your server at present, so I can't compare. Sourceforge was down for a while. It's back up now. http://nettool.sourceforge.net/nc > > My goals for [collections] is to add something small and simple that > doesn't > prevent a user adding something more complex. NotifyingCollec

Re: [collections][submission] NotifyingCollections

2003-07-24 Thread Stephen Colebourne
See http://www.scolebourne.eurobell.co.uk/Observed2.zip This contains a simple observing collections decorator. My goals for [collections] is to add something small and simple that doesn't prevent a user adding something more complex. There are relatively few classes involved here, and no tests.

Re: [DBCP] Event/Listener proposal (was .. RE: [DBCP] AbandonedTrace - Connection Recovery)

2003-07-24 Thread Juozas Baliuka
Sorry, if somebody found something personal in my messages, I was not going to personalize "connection leak" problem. My suggestion is very clear, to remove workarounds from pool and to implement resource management component. Doe's somebody proposed the way to detect connection leak ? Is it bad

RE: [DBCP] Event/Listener proposal (was .. RE: [DBCP] AbandonedTrace - Connection Recovery)

2003-07-24 Thread Danny Angus
Juozas, I don't intend to continue to "debate" this issue with you, you are obviously not open to considering anything other than your own point of view, your comments are rude and show little respect to the other participants in the discussion. I have already suggested that you provide some sugge

[VFS] [PATCH] FtpFileObject.java

2003-07-24 Thread Dyrdahl, Steve
This addresses my earlier posting of not having permissions to do directory listings above a directory. Index: FtpFileObject.java === RCS file: /home/cvspublic/jakarta-commons-sandbox/vfs/src/java/org/apache/commons/ vfs/provider/ftp/

Re: [DBCP] Event/Listener proposal (was .. RE: [DBCP] AbandonedTrace - Connection Recovery)

2003-07-24 Thread Juozas Baliuka
-1 I do not think it is possible to detect connection leak in pool. !ownerThread.isAlive() && isOpen or weakReference is in referenceQueue is 100% connection leak, I have tested this workaround in my crappy applications, I found it is a very dangerous "feature" and doe's not help to fix applicat

Re: [collections][submission] NotifyingCollections

2003-07-24 Thread Neil O'Toole
--- Stephen Colebourne <[EMAIL PROTECTED]> wrote: > I haven't forgotten this, and will release some code I've been > working on > for comparison soon. > Stephen Great, do you have a rough idea when you'll have that code out? N. > - Original Message - > From: "Neil O'Toole" <[EMAIL PRO

DO NOT REPLY [Bug 18087] - Add BeanFactory class for dynamic factories.

2003-07-24 Thread bugzilla
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT . ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND INSERTED IN THE BUG DATABASE. http://nagoya.apache.org/bugzilla/show_bu

Re: [modeler] Introspection only for primitives?

2003-07-24 Thread Costin Manolache
Davanum Srinivas wrote: > Costin, > > Am +1 on fewer dependencies...Yes, i am writing a small program for > "register the mbeans, introspection it and write the descriptor". That's > when i found the missing constructor info. I don't know if you noticed the small ant task that writes the .ser de

Re: [DBCP] Event/Listener proposal (was .. RE: [DBCP] AbandonedTrace - Connection Recovery)

2003-07-24 Thread David Graham
+1 on a listener model but let's not rule out using the Strategy pattern as well. They both may come in handy. David --- Danny Angus <[EMAIL PROTECTED]> wrote: > Well I never, > There's been a lot of talk generated by my innocent proposal of using > the > Observer pattern, or in more java-esque

DO NOT REPLY [Bug 21851] New: - BeanUtils.populate fails with DoubleLocaleConverter on integer values

2003-07-24 Thread bugzilla
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT . ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND INSERTED IN THE BUG DATABASE. http://nagoya.apache.org/bugzilla/show_bu

cvs commit: jakarta-commons-sandbox/graph2/src/java/org/apache/commons/graph/algorithm/search VisitorAdapter.java

2003-07-24 Thread ddp
ddp 2003/07/24 05:35:15 Added: graph2/src/java/org/apache/commons/graph/algorithm/search VisitorAdapter.java Log: Tomasz Skutnik's idea. Here is VisitorAdapter class, which is dummy (no operation) implementation of Visitor interface. You know wha

Re: [collections][submission] NotifyingCollections

2003-07-24 Thread Stephen Colebourne
I haven't forgotten this, and will release some code I've been working on for comparison soon. Stephen - Original Message - From: "Neil O'Toole" <[EMAIL PROTECTED]> To: "Jakarta Commons Developers List" <[EMAIL PROTECTED]>; <[EMAIL PROTECTED]> Sent: Monday, July 21, 2003 9:01 PM Subject: Re

RE: [DBCP] AbandonedTrace - Connection Recovery

2003-07-24 Thread Hope, Matthew
> -Original Message- > From: Juozas Baliuka [mailto:[EMAIL PROTECTED] > Sent: 23 July 2003 12:52 > To: Jakarta Commons Developers List > Subject: Re: [DBCP] AbandonedTrace - Connection Recovery > > Logging is useless in this case, Such a statement seems ludicrous The relative merits o

[DBCP] Event/Listener proposal (was .. RE: [DBCP] AbandonedTrace - Connection Recovery)

2003-07-24 Thread Danny Angus
Well I never, There's been a lot of talk generated by my innocent proposal of using the Observer pattern, or in more java-esque terms events and listeners to arrive at a compromise in the Connection Recovery War. I'd like to clarify some points raised. In the first place to address the criticism o