Matthew Toseland schrieb:

> fix stupid bug in stupid windozebug bugfix :)
> 
> Index: Main.java
> ===================================================================

> -           if((!outfile.delete()) || (!temp.renameTo(outfile))) {
> +           if((!outfile.delete()) && (!temp.renameTo(outfile))) {
>                 Core.logger.log(Main.class, "Cannot rename "+temp+" to "+outfile,

Hmm, if it can delete the file, but cannot rename the other one (for
some reasons), you don't have a file afterwards, so it's something to be
logged.

but in that case, you will get (!true) && (!false) <---> false && true
<---> false; so it is *not* logged.

Was that intended?

Or did you mean that here:

if (!(outfile.delete() && temp.renameTo(outfile))) {


mihi
_______________________________________________
devl mailing list
[EMAIL PROTECTED]
http://hawk.freenetproject.org:8080/cgi-bin/mailman/listinfo/devl

Reply via email to