Re: [PATCH 5/5] staging: fsl-mc: Management Complex restool driver

2015-10-25 Thread Dan Carpenter
A few style issues and error handling bugs. See below. On Sun, Oct 25, 2015 at 05:41:23PM -0500, Lijun Pan wrote: > +static int fsl_mc_restool_dev_open(struct inode *inode, struct file *filep) > +{ > + struct fsl_mc_device *root_mc_dev; > + int error = 0; > + struct fsl_mc_io *dynamic

Re: [PATCH] staging: ft1000: Remove boolean comparisons

2015-10-25 Thread Luis de Bethencourt
On 25/10/15 02:20, Greg KH wrote: > On Sun, Oct 18, 2015 at 09:58:15PM +0100, Luis de Bethencourt wrote: >> Boolean tests do not need explicit comparison to true or false. >> >> Signed-off-by: Luis de Bethencourt >> --- >> drivers/staging/ft1000/ft1000-pcmcia/ft1000_hw.c | 4 ++-- >> drivers/stag

[RESEND PATCH] staging: wilc1000: return -ENOMEM when kmalloc failed

2015-10-25 Thread Luis de Bethencourt
The driver is using -1 instead of the -ENOMEM defined macro to specify that a buffer allocation failed. Fixes smatch warning and similars: drivers/staging/wilc1000/host_interface.c:1757 Handle_Key() warn: returning -1 instead of -ENOMEM is sloppy Signed-off-by: Luis de Bethencourt --- Hi, Rese

Re: [PATCH v2 01/22] staging/rdma/hfi1: Fix regression in send performance

2015-10-25 Thread ira.weiny
On Wed, Oct 21, 2015 at 04:18:06PM +0300, Dan Carpenter wrote: > On Mon, Oct 19, 2015 at 10:11:16PM -0400, ira.we...@intel.com wrote: > > From: Mike Marciniszyn > > > > This additional call is a regression from qib. For small messages the > > progress > > routine always builds one and clears ou

Re: [PATCH 02/28] staging: wicl1000: isr_uh_routine: use netdev private wilc

2015-10-25 Thread glen lee
On 2015년 10월 25일 10:29, Greg KH wrote: On Fri, Oct 23, 2015 at 02:28:18PM +0900, Glen Lee wrote: Use netdev private member wilc instead of g_linux_wlan and Change argument wilc with dev in the function request_threaded_irq to pass back to handler the function isr_uh_routine. Signed-off-by: Gl

[PATCH 3/4] staging: wilc1000: rename u8Index in host_int_set_WEPDefaultKeyID

2015-10-25 Thread Chaehyun Lim
This patch changes second parameter of host_int_set_WEPDefaultKeyID from u8Index to index to avoid camelcase. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 4 ++-- drivers/staging/wilc1000/host_interface.h | 2 +- 2 files changed, 3 insertions(+), 3 deletions(-) di

[PATCH 4/4] staging: wilc1000: rename host_int_set_WEPDefaultKeyID

2015-10-25 Thread Chaehyun Lim
This patch replaces host_int_set_WEPDefaultKeyID with host_int_set_wep_default_key to avoid camelcase. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 2 +- drivers/staging/wilc1000/host_interface.h | 2 +- drivers/staging/wilc1000/wilc_wfi_cfgoperat

[PATCH 2/4] staging: wilc1000: fix parameter name of function declaration

2015-10-25 Thread Chaehyun Lim
This patch changes struct host_if_drv of host_int_set_WEPDefaultKeyID function declaration from hWFIDrv to hif_drv in host_interface.h With this change, first parameter name of this function declaration and definition has same name as hif_drv. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc

[PATCH 1/4] staging: wilc1000: fix return type of host_int_set_WEPDefaultKeyID

2015-10-25 Thread Chaehyun Lim
This patch changes return type of host_int_set_WEPDefaultKeyID from s32 to int. The result variable gets return value from wilc_mq_send that has return type of int. It should be changed return type int as well as data type of result variable. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1

Re: [PATCH 2/5] staging: fsl-mc: define a macro to differentiate root dprc

2015-10-25 Thread Greg KH
On Sun, Oct 25, 2015 at 05:41:20PM -0500, Lijun Pan wrote: > Define is_root_dprc(dev) to tell whether a device is > root dprc or not via platform_bus_type. > > Signed-off-by: Lijun Pan > --- > drivers/staging/fsl-mc/include/mc.h | 10 ++ > 1 file changed, 10 insertions(+) > > diff --git

[PATCH 2/5] staging: fsl-mc: define a macro to differentiate root dprc

2015-10-25 Thread Lijun Pan
Define is_root_dprc(dev) to tell whether a device is root dprc or not via platform_bus_type. Signed-off-by: Lijun Pan --- drivers/staging/fsl-mc/include/mc.h | 10 ++ 1 file changed, 10 insertions(+) diff --git a/drivers/staging/fsl-mc/include/mc.h b/drivers/staging/fsl-mc/include/mc.h

[PATCH 3/5] staging: fsl-mc: root dprc rescan attribute to sync kernel with MC

2015-10-25 Thread Lijun Pan
Introduce the rescan attribute as a device attribute to synchronize the fsl-mc bus objects and the MC firmware. To rescan the root dprc only, e.g. echo 1 > /sys/bus/fsl-mc/devices/dprc.1/rescan Signed-off-by: Lijun Pan --- drivers/staging/fsl-mc/bus/mc-bus.c | 44 +++

[PATCH 4/5] staging: fsl-mc: bus rescan attribute to sync kernel with MC

2015-10-25 Thread Lijun Pan
Introduce the rescan attribute as a bus attribute to synchronize the fsl-mc bus objects and the MC firmware. To rescan the fsl-mc bus, e.g., echo 1 > /sys/bus/fsl-mc/rescan Signed-off-by: Lijun Pan --- drivers/staging/fsl-mc/bus/mc-bus.c | 46 + 1 file change

[PATCH 0/5] Management Complex restool driver

2015-10-25 Thread Lijun Pan
This series of patches are based on http://git.kernel.org/cgit/linux/kernel/git/gregkh/staging.git/commit/?h=staging-next&id=63f2be5c3b358db031f86eafa9cd450f6558a55b patch 1/5 solves the section mismatch bug in fsl-mc bus patches 2/5 - 4/5 add sysfs rescan atrributes, which is used in the user spac

[PATCH 1/5] staging: fsl-mc: section mismatch bug fix

2015-10-25 Thread Lijun Pan
WARNING: drivers/staging/built-in.o(.init.text+0xdc): Section mismatch in reference from the function fsl_mc_bus_driver_init() to the function .exit.text:dprc_driver_exit() The function __init fsl_mc_bus_driver_init() references a function __exit dprc_driver_exit(). This is often seen when error

[PATCH 5/5] staging: fsl-mc: Management Complex restool driver

2015-10-25 Thread Lijun Pan
The kernel support for the restool (a user space resource management tool) is a driver for the /dev/dprc.N device file. Its purpose is to provide an ioctl interface, which the restool uses to interact with the MC bus driver and with the MC firmware. We allocate a dpmcp at driver initialization, and

[PATCH] Staging: android: uapi: fixed comment block coding style error in ion.h

2015-10-25 Thread Dzonatans Melgalvis
Fixed checkpatch.pl warning about comment block coding style. Signed-off-by: Dzonatans Melgalvis --- drivers/staging/android/uapi/ion.h | 14 -- 1 file changed, 8 insertions(+), 6 deletions(-) diff --git a/drivers/staging/android/uapi/ion.h b/drivers/staging/android/uapi/ion.h inde

Re: [PATCH 1/3] staging: wilc1000: Remove reference preceded by free

2015-10-25 Thread Greg KH
On Mon, Oct 26, 2015 at 01:29:42AM +0530, punit vara wrote: > On Mon, Oct 26, 2015 at 1:01 AM, punit vara wrote: > > On Mon, Oct 26, 2015 at 12:42 AM, Greg KH > > wrote: > >> On Sun, Oct 25, 2015 at 04:01:23AM +0530, Punit Vara wrote: > >>> This patch is to the wilc_wfi_cfgoperations.c file that

Re: [PATCH 1/3] staging: wilc1000: Remove reference preceded by free

2015-10-25 Thread punit vara
On Mon, Oct 26, 2015 at 1:01 AM, punit vara wrote: > On Mon, Oct 26, 2015 at 12:42 AM, Greg KH wrote: >> On Sun, Oct 25, 2015 at 04:01:23AM +0530, Punit Vara wrote: >>> This patch is to the wilc_wfi_cfgoperations.c file that fixes up >>> following error reported by coccicheck: >>> >>> ERROR: refe

Re: [PATCH 1/3] staging: wilc1000: Remove reference preceded by free

2015-10-25 Thread punit vara
On Mon, Oct 26, 2015 at 12:42 AM, Greg KH wrote: > On Sun, Oct 25, 2015 at 04:01:23AM +0530, Punit Vara wrote: >> This patch is to the wilc_wfi_cfgoperations.c file that fixes up >> following error reported by coccicheck: >> >> ERROR: reference preceded by free on line 1219 >> >> For (params->seq_

Re: [PATCH 1/3] staging: wilc1000: Remove reference preceded by free

2015-10-25 Thread Greg KH
On Sun, Oct 25, 2015 at 04:01:23AM +0530, Punit Vara wrote: > This patch is to the wilc_wfi_cfgoperations.c file that fixes up > following error reported by coccicheck: > > ERROR: reference preceded by free on line 1219 > > For (params->seq_len) <= 0 memory is already freed when > (params->seq_le

Re: [PATCH 2/3] Staging: wilc1000: Remove comparision of field address to NULL

2015-10-25 Thread Greg KH
On Sun, Oct 25, 2015 at 04:01:24AM +0530, Punit Vara wrote: > This is patch to the linux_wlan file that fixes up following error > reported by coccicheck : > > ERROR: test of a variable/field address > > Signed-off-by: Punit Vara > --- > drivers/staging/wilc1000/linux_wlan.c | 8 > 1 f

Re: [PATCH 21/21] pwrGrpCnt variable removed in store_pwrindex_offset function

2015-10-25 Thread Greg Kroah-Hartman
On Sat, Oct 24, 2015 at 10:37:21PM +0700, Ivan Safonov wrote: > This variable used only once in the beginning of the function, > it can be removed. > > Signed-off-by: Ivan Safonov > --- > drivers/staging/rtl8188eu/hal/bb_cfg.c | 3 +-- > 1 file changed, 1 insertion(+), 2 deletions(-) Where are

Respond...

2015-10-25 Thread Mr . Neil
This is Neil Trotter,the Euro Million lottery winner for 2014.I will like you to help me make some donations to cancer pateints.please Contact me on: neiltrotter...@163.com for more details or read the attachment for more info. ___ devel mailing list d

Re: [PATCH 2195/2195] Staging: rdma: amso1100: Fix multiple assignments on single line.

2015-10-25 Thread Greg KH
On Sun, Oct 25, 2015 at 04:50:06AM -0600, Weston Silbaugh wrote: > Multiple assignments should be avoided. > > For example: > > cm_event.ird = cm_event.ord = 128; > > Should be: > > cm_event.ird = 128; > cm_event.ord = 128; > > Signed-off-by: Weston Silbaugh Where are the 2194 other patches

Re: [PATCH] staging: iio: select IRQ_WORK for IIO_DUMMY_EVGEN

2015-10-25 Thread Jonathan Cameron
On 19/10/15 09:16, Daniel Baluta wrote: > On Sat, Oct 17, 2015 at 1:29 AM, Arnd Bergmann wrote: >> The iio dummy code was recently changed to use irq_work_queue, but >> that code is compiled into the kernel only if IRQ_WORK is set, so >> we can get a link error here: >> >> drivers/built-in.o: In f

Re: [PATCH 1/4 v2] staging: ipath: ipath_driver: Use setup_timer

2015-10-25 Thread Leon Romanovsky
On Sun, Oct 25, 2015 at 12:17 PM, Muhammad Falak R Wani wrote: Please follow standard naming convention for the patches. It should be [PATCH v2 1/4] and not [PATCH 1/4 v2]. ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverp

Re: [PATCH 2195/2195] Staging: rdma: amso1100: Fix multiple assignments on single line.

2015-10-25 Thread Leon Romanovsky
On Sun, Oct 25, 2015 at 12:50 PM, Weston Silbaugh wrote: > Multiple assignments should be avoided. > > For example: > > cm_event.ird = cm_event.ord = 128; > > Should be: > > cm_event.ird = 128; > cm_event.ord = 128; > > Signed-off-by: Weston Silbaugh > --- > drivers/staging/rdma/amso1100/c2_ae.c

[PATCH 2195/2195] Staging: rdma: amso1100: Fix multiple assignments on single line.

2015-10-25 Thread Weston Silbaugh
Multiple assignments should be avoided. For example: cm_event.ird = cm_event.ord = 128; Should be: cm_event.ird = 128; cm_event.ord = 128; Signed-off-by: Weston Silbaugh --- drivers/staging/rdma/amso1100/c2_ae.c | 6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/driver

[PATCH 2195/2195] Staging: rdma: amso1100: Fix multiple assignments on single line.

2015-10-25 Thread Weston Silbaugh
Multiple assignments should be avoided. For example: cm_event.ird = cm_event.ord = 128; Should be: cm_event.ird = 128; cm_event.ord = 128; Signed-off-by: Weston Silbaugh --- drivers/staging/rdma/amso1100/c2_ae.c | 6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/driver

[PATCH 3/3] staging: hfi1: sdma: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use the timer API function setup_timer instead of init_timer, removing the structure field assignments. Signed-off-by: Muhammad Falak R Wani --- v2 changes ->make subject line more specific drivers/staging/rdma/hfi1/sdma.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) dif

[PATCH 2/3] staging: hfi1: driver: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use the timer API function setup_timer instead of init_timer, removing the structure field assignments. @timer@ expression e1,e2,e3,fn_ptr; @@ -init_timer(&e1); +setup_timer(&e1, fn_ptr, e2); ... when != fn_ptr = e3 -e1.function = fn_ptr; -e1.data = e2; Signed-off-by: Muhammad Falak R Wani -

[PATCH 1/3] staging: rdma: hfi1: chip: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use the timer API function setup_timer instead of init_timer, removing the structure field assignments. @timer@ expression e1,e2,e3,fn_ptr; @@ -init_timer(&e1); +setup_timer(&e1, fn_ptr, e2); ... when != fn_ptr = e3 -e1.function = fn_ptr; -e1.data = e2; Signed-off-by: Muhammad Falak R Wani -

[PATCH 1/4 v2] staging: ipath: ipath_driver: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use the timer API function setup_timer instead of init_timer, removing the structure field assignments. The simplified semantic patch used is :- @timer@ expression e1,e2,e3,fn_ptr; @@ -init_timer(&e1); +setup_timer(&e1, fn_ptr, e2); ... when != fn_ptr = e3 -e1.function = fn_ptr; -e1.data = e2;

[PATCH 2/4 v2] staging: ipath: ipath_init_chip: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use of the timer API function setup_timer instead of init_timer, removing the structure field assignments, and make the codeflow more readable. The simplified sematic patch used is :- @timer@ expression e1,e2,e3,fn_ptr; @@ -init_timer(&e1); +setup_timer(&e1, fn_ptr, e2); ... when != fn_ptr = e3 -

[PATCH 3/4 v2] staging: ipath: ipath_sdma: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use the timer API function setup_timer instead of init_timer, removing the structure field assignments. Signed-off-by: Muhammad Falak R Wani --- v2 changes: -> Change the subject line to a be more specific mfrw drivers/staging/rdma/ipath/ipath_sdma.c | 6 +++--- 1 file changed, 3 inser

[PATCH 4/4 v2] staging: ipath: ipath_verbs: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use the timer API function setup_timer instead of init_timer, removing the structure field assignments. Signed-off-by: Muhammad Falak R Wani --- v2 changes: -> Change the subject line to a be more specific mfrw drivers/staging/rdma/ipath/ipath_verbs.c | 5 ++--- 1 file changed, 2 inser

Re: [PATCH] staging: dgnc: Remove explicit NULL comparison

2015-10-25 Thread Greg Kroah-Hartman
On Mon, Oct 19, 2015 at 11:14:35PM +0530, Muhammad Falak R Wani wrote: > Rewrite explicit NULL comparison in its simpler form. > > @NULL_REPLACE@ > expression e; > @@ > > -e == NULL > + !e > > > Signed-off-by: Muhammad Falak R Wani > --- > drivers/staging/dgnc/dgnc_tty.c | 2 +- > 1 file chan

Re: [PATCH] staging: ft1000: Remove boolean comparisons

2015-10-25 Thread Greg KH
On Sun, Oct 18, 2015 at 09:58:15PM +0100, Luis de Bethencourt wrote: > Boolean tests do not need explicit comparison to true or false. > > Signed-off-by: Luis de Bethencourt > --- > drivers/staging/ft1000/ft1000-pcmcia/ft1000_hw.c | 4 ++-- > drivers/staging/ft1000/ft1000-usb/ft1000_hw.c| 2

Re: [PATCH] staging: most: fix possible overflow

2015-10-25 Thread Greg KH
On Tue, Oct 20, 2015 at 04:16:11PM +0200, Christian Gromm wrote: > This patch fixes a possible overflow in module hdm-dim2. > > Signed-off-by: Christian Gromm > --- > drivers/staging/most/hdm-dim2/dim2_hdm.c |7 --- > 1 file changed, 4 insertions(+), 3 deletions(-) > > diff --git a/driv

Re: [PATCH v2 2/2] staging: IB/ipath: remove sched.h header

2015-10-25 Thread Greg Kroah-Hartman
On Sat, Oct 24, 2015 at 07:05:32PM -0700, Greg Kroah-Hartman wrote: > On Sun, Oct 18, 2015 at 09:57:09PM +0800, Geliang Tang wrote: > > sched.h header in ipath_*.c is now unnecessary, since I have added > > sched.h in ipath_kernel.h. So remove it. > > Overall, it's best to split this type of thing

Re: [PATCH v2 2/2] staging: IB/ipath: remove sched.h header

2015-10-25 Thread Greg Kroah-Hartman
On Sun, Oct 18, 2015 at 09:57:09PM +0800, Geliang Tang wrote: > sched.h header in ipath_*.c is now unnecessary, since I have added > sched.h in ipath_kernel.h. So remove it. Overall, it's best to split this type of thing out, don't "hide" .h includes in another .h file, so I'm not going to take th

Re: [PATCH 1/3] staging: rdma: hfi1: Use setup_timer

2015-10-25 Thread Greg Kroah-Hartman
On Sat, Oct 24, 2015 at 07:58:05AM +0530, Muhammad Falak R Wani wrote: > Use the timer API function setup_timer instead of init_timer, removing > the structure field assignments. > > > > @timer@ > expression e1,e2,e3,fn_ptr; > @@ > -init_timer(&e1); > +setup_timer(&e1, fn_ptr, e2); > ... when !=

Re: [PATCH 1/4] staging: rdma: ipath: Use setup_timer

2015-10-25 Thread Greg Kroah-Hartman
On Sat, Oct 24, 2015 at 07:49:28AM +0530, Muhammad Falak R Wani wrote: > Use the timer API function setup_timer instead of init_timer, removing > the structure field assignments. > > > > @timer@ > expression e1,e2,e3,fn_ptr; > @@ > -init_timer(&e1); > +setup_timer(&e1, fn_ptr, e2); > ... when !=

Re: [PATCH] Staging: lustre: lustre_log: Remove unused functions

2015-10-25 Thread Greg KH
On Thu, Oct 22, 2015 at 08:51:18AM +0530, Shraddha Barke wrote: > Remove the functions which are defined but not used anywhere > > Signed-off-by: Shraddha Barke > --- > drivers/staging/lustre/lustre/include/lustre_log.h | 90 > -- > 1 file changed, 90 deletions(-) You sent

Re: [PATCH 0/5] staging:lustre: split kernel comm between user and kernel

2015-10-25 Thread Greg Kroah-Hartman
On Fri, Oct 23, 2015 at 03:59:12PM -0400, James Simmons wrote: > The kernel communication code used for HSM and changelog is > entangled. Move the user space bits into the liblustreapi. This will > also help for a possible relicensing. The kernel portion is also moved > from libcfs to obdclass. >

Re: [PATCH] lustre: obdclass: fix sparse warning

2015-10-25 Thread Greg KH
On Sat, Oct 24, 2015 at 12:58:20PM +0530, Paul Davies C wrote: > This patch fixes the following warnings given by the sparse: > > drivers/staging/lustre/lustre/obdclass/linux/linux-module.c:424:5: warning: > symbol 'class_procfs_init' was not declared. Should it be static? > drivers/staging/lustr

Re: [PATCH v2 07/22] staging/rdma/hfi1: Fix sparse error in sdma.h file

2015-10-25 Thread gre...@linuxfoundation.org
On Thu, Oct 22, 2015 at 01:01:25PM +0300, Dan Carpenter wrote: > On Wed, Oct 21, 2015 at 04:29:35PM +, Weiny, Ira wrote: > > > > > > On Mon, Oct 19, 2015 at 10:11:22PM -0400, ira.we...@intel.com wrote: > > > > From: Niranjana Vishwanathapura > > > > > > > > Use NULL instead of 0 for pointer a

Re: [PATCH 02/28] staging: wicl1000: isr_uh_routine: use netdev private wilc

2015-10-25 Thread Greg KH
On Fri, Oct 23, 2015 at 02:28:18PM +0900, Glen Lee wrote: > Use netdev private member wilc instead of g_linux_wlan and Change argument > wilc > with dev in the function request_threaded_irq to pass back to handler > the function isr_uh_routine. > > Signed-off-by: Glen Lee > --- > drivers/stagin

Re: [PATCH] staging: wilc1000: return -ENOMEM when kmalloc failed

2015-10-25 Thread Greg KH
On Thu, Oct 22, 2015 at 12:07:36AM +0100, Luis de Bethencourt wrote: > The driver is using -1 instead of the -ENOMEM defined macro to specify that > a buffer allocation failed. > > Fixes smatch warning and similars: > drivers/staging/wilc1000/host_interface.c:1782 Handle_Key() warn: > returning -1

Re: [PATCH 01/19] staging/wilc1000: remove unused functions

2015-10-25 Thread Greg KH
On Wed, Oct 21, 2015 at 12:47:20AM +0200, Arnd Bergmann wrote: > A number of symbols in the wilc1000 driver are completely unused > and can be removed. > This includes two variables that are only written but not read. > > Signed-off-by: Arnd Bergmann Due to other patches that were sent before yo