[GIT PULL] Staging/IIO driver fixes for 5.2-rc3

2019-05-30 Thread Greg KH
The following changes since commit a188339ca5a396acc588e5851ed7e19f66b0ebd9: Linux 5.2-rc1 (2019-05-19 15:47:09 -0700) are available in the Git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git tags/staging-5.2-rc3 for you to fetch changes up to e61ff0fba72d98

RE: [PATCH 1/4] staging: kpc2000: add spaces around operators in core.c

2019-05-30 Thread Matt Sickler
>From: devel On Behalf Of >Greg KH >On Fri, May 24, 2019 at 01:07:59PM +0200, Simon Sandström wrote: >> --- a/drivers/staging/kpc2000/kpc2000/core.c >> +++ b/drivers/staging/kpc2000/kpc2000/core.c >> @@ -276,18 +276,18 @@ static ssize_t kp2000_cdev_read(struct file *filp, > >This whole function ju

Re: [PATCH 1/4] staging: kpc2000: add spaces around operators in core.c

2019-05-30 Thread Greg KH
On Thu, May 30, 2019 at 10:57:09PM +, Matt Sickler wrote: > >From: devel On Behalf Of > >Greg KH > >On Fri, May 24, 2019 at 01:07:59PM +0200, Simon Sandström wrote: > >> --- a/drivers/staging/kpc2000/kpc2000/core.c > >> +++ b/drivers/staging/kpc2000/kpc2000/core.c > >> @@ -276,18 +276,18 @@ st

[PATCH] staging: mt7621-dma: sizeof via pointer dereference

2019-05-30 Thread Benjamin Sherman
Pass the size of a struct into kzalloc by pointer dereference. This complies with the Linux kernel coding style and removes the possibility for a bug if the pointer's type is changed. Signed-off-by: Benjamin Sherman --- drivers/staging/mt7621-dma/mtk-hsdma.c | 2 +- 1 file changed, 1 insertion(

Re: [PATCH 22/22] docs: fix broken documentation links

2019-05-30 Thread Michael S. Tsirkin
On Thu, May 30, 2019 at 10:17:32PM +0200, Federico Vaga wrote: > On Thursday, May 30, 2019 1:23:53 AM CEST Mauro Carvalho Chehab wrote: > > Mostly due to x86 and acpi conversion, several documentation > > links are still pointing to the old file. Fix them. > > For the Italian documentation I just

Re: [PATCH] staging: media: davinci_vpfe: Remove variable vpfe_dev

2019-05-30 Thread Greg KH
On Fri, May 31, 2019 at 02:39:23AM +0530, Nishka Dasgupta wrote: > On 31/05/19 2:25 AM, Greg KH wrote: > > On Fri, May 31, 2019 at 02:17:18AM +0530, Nishka Dasgupta wrote: > > > Remove variable vpfe_dev and replace it with its value (since the > > > function otherwise uses values directly instead o

Re: [PATCH] staging: kpc2000: Fix build failure caused by wrong include file

2019-05-30 Thread Greg Kroah-Hartman
On Thu, May 30, 2019 at 04:33:42AM -0700, Guenter Roeck wrote: > xtensa:allmodconfig fails to build. > > arch/xtensa/include/asm/uaccess.h: In function 'clear_user': > arch/xtensa/include/asm/uaccess.h:40:22: error: > implicit declaration of function 'uaccess_kernel' > > uaccess_kernel() is

[PATCH 4/7] media: cedrus: Remove dst_bufs from context

2019-05-30 Thread Jernej Skrabec
This array is just duplicated capture buffer queue. Remove it and adjust code to look into capture buffer queue instead. Signed-off-by: Jernej Skrabec --- drivers/staging/media/sunxi/cedrus/cedrus.h | 4 +--- .../staging/media/sunxi/cedrus/cedrus_h264.c | 4 ++-- .../staging/media/sunxi/ced

[PATCH 3/7] media: cedrus: Fix decoding for some H264 videos

2019-05-30 Thread Jernej Skrabec
It seems that for some H264 videos at least one bitstream parsing trigger must be called in order to be decoded correctly. There is no explanation why this helps, but it was observed that two sample videos with this fix are now decoded correctly and there is no regression with others. Signed-off-b

[PATCH 7/7] media: cedrus: Improve H264 memory efficiency

2019-05-30 Thread Jernej Skrabec
H264 decoder driver preallocated pretty big worst case mv col buffer pool. It turns out that pool is most of the time much bigger than it needs to be. Solution implemented here is to allocate memory only if capture buffer is actually used and only as much as it is really necessary. This is also p

[PATCH 6/7] media: cedrus: Add infra for extra buffers connected to capture buffers

2019-05-30 Thread Jernej Skrabec
H264 and HEVC engines need additional buffers for each capture buffer. H264 engine has this currently solved by allocating fixed size pool, which is not ideal. Most of the time pool size is much bigger than it needs to be. Ideally, extra buffer should be allocated at buffer initialization, but tha

[PATCH 1/7] media: cedrus: Disable engine after each slice decoding

2019-05-30 Thread Jernej Skrabec
libvdpau-sunxi always disables engine after each decoded slice. Do same in Cedrus driver. Presumably this also lowers power consumption which is always nice. Signed-off-by: Jernej Skrabec --- drivers/staging/media/sunxi/cedrus/cedrus_hw.c | 1 + 1 file changed, 1 insertion(+) diff --git a/driv

[PATCH 5/7] media: cedrus: Don't set chroma size for scale & rotation

2019-05-30 Thread Jernej Skrabec
Scale and rotation are currently not implemented, so it makes no sense to set chroma size for it. Signed-off-by: Jernej Skrabec --- drivers/staging/media/sunxi/cedrus/cedrus_hw.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/staging/media/sunxi/cedrus/cedrus_hw.c b/drivers/stagi

[PATCH 0/7] media: cedrus: Improvements/cleanup

2019-05-30 Thread Jernej Skrabec
Here is first batch of random Cedrus improvements/cleanups. Only patch 2 has a change which raises a question about H264 controls. Changes were tested on H3 SoC using modified ffmpeg and Kodi. Please take a look. Best regards, Jernej Jernej Skrabec (7): media: cedrus: Disable engine after eac

[PATCH 2/7] media: cedrus: Fix H264 default reference index count

2019-05-30 Thread Jernej Skrabec
Reference index count in VE_H264_PPS reg should come from PPS control. However, this is not really important because reference index count is in our case always overridden by that from slice header. Cc: nico...@ndufresne.ca Cc: boris.brezil...@collabora.com Cc: jo...@kwiboo.se Signed-off-by: Jern

Re: [PATCH] staging: vt6655: Change return type of function and remove variable

2019-05-30 Thread Greg KH
On Wed, May 29, 2019 at 07:15:29PM +0530, Nishka Dasgupta wrote: > As the function CARDbRadioPowerOff always returns true, and this value > does not appear to be used anywhere, the return variable can be entirely > removed and the function converted to type void. > Issue found with Coccinelle. > >

Re: [PATCH] staging: pi433: cleanup to adhere with linux coding style

2019-05-30 Thread shobhit kukreti
Thank you for the feedback. I dropped the patch.  Best, Shobhit Kukreti On Thursday, May 23, 2019, 12:30:20 AM PDT, Greg Kroah-Hartman wrote: On Wed, May 22, 2019 at 06:06:22PM -0700, Shobhit Kukreti wrote: > The linux coding style emphasizes on a limit of 80 characters > per line. Cleaned

Re: [PATCH] staging: rtl8712: Remove unnecessary variable in rtl8712_recv.c

2019-05-30 Thread Greg KH
On Wed, May 29, 2019 at 06:50:31PM +0530, Nishka Dasgupta wrote: > Remove unnecessary variable last_evm in rtl8712_recv.c and use its value > directly. > Issue found with Coccinelle. > > Signed-off-by: Nishka Dasgupta > --- > drivers/staging/rtl8712/rtl8712_recv.c | 5 ++--- > drivers/staging/rt

Re: [Patch v3] staging: rtl8723bs: core: rtw_mlme_ext: fix warning Unneeded variable: "ret"

2019-05-30 Thread Greg Kroah-Hartman
On Thu, May 23, 2019 at 11:09:41PM +0530, Hariprasad Kelam wrote: > This patch fixes below warnings reported by coccicheck > > drivers/staging/rtl8723bs/core/rtw_mlme_ext.c:1888:14-17: Unneeded > variable: "ret". Return "_FAIL" on line 1920 > drivers/staging/rtl8723bs/core/rtw_mlme_ext.c:466:5-8:

Re: [PATCH] staging: media: davinci_vpfe: Remove variable vpfe_dev

2019-05-30 Thread Nishka Dasgupta
On 31/05/19 2:25 AM, Greg KH wrote: On Fri, May 31, 2019 at 02:17:18AM +0530, Nishka Dasgupta wrote: Remove variable vpfe_dev and replace it with its value (since the function otherwise uses values directly instead of local variables). This says _what_ you do. But we can see that in the patch

[PATCH] staging: rtl8712: Change _SUCCESS/_FAIL to 0/-ENOMEM

2019-05-30 Thread Nishka Dasgupta
Change return values _SUCCESS and _FAIL to 0 and -ENOMEM respectively, to match the convention in the drivers (and also because the return value of this changed function is never checked anyway). Change return type of the function to int (from u8) to allow the return of -ENOMEM. Signed-off-by: Nis

Re: [PATCH 1/4] staging: kpc2000: add spaces around operators in core.c

2019-05-30 Thread Greg KH
On Fri, May 24, 2019 at 01:07:59PM +0200, Simon Sandström wrote: > Fixes checkpatch.pl check "spaces preferred around that ". > > Signed-off-by: Simon Sandström > --- > drivers/staging/kpc2000/kpc2000/core.c | 24 > 1 file changed, 12 insertions(+), 12 deletions(-) > >

[PATCH] staging: rtl8712: ieee80211.c: Remove leading p from variable names

2019-05-30 Thread Nishka Dasgupta
Remove leading p from the names of the following pointer variables: - pregistrypriv - pdev_network - pie - pbuf. Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta --- drivers/staging/rtl8712/ieee80211.c | 50 ++--- 1 file changed, 25 insertions(+), 25 deletions(

[PATCH] staging: rtl8712: Remove function alloc_network

2019-05-30 Thread Nishka Dasgupta
Remove function alloc_network as it does nothing except call _r8712_alloc_network. Further, to maintain consistency with the names of other functions, rename _r8712_alloc_network as r8712_alloc_network. Also change the corresponding calls to either function accordingly. Signed-off-by: Nishka Dasgu

Re: [PATCH 2/2] staging: kpc2000: add missing dependencies for kpc2000

2019-05-30 Thread Greg KH
On Sat, May 25, 2019 at 11:24:04AM +0200, Simon Sandström wrote: > On Sat, May 25, 2019 at 10:39:18AM +0200, Simon Sandström wrote: > > On Sat, May 25, 2019 at 07:00:17AM +0200, Greg KH wrote: > > > > > > This is already in linux-next (in a different form), are you sure you > > > are working again

[PATCH] staging: rtl8712: Replace function r8712_free_network_queue

2019-05-30 Thread Nishka Dasgupta
Remove function r8712_free_network_queue as it does nothing except call _free_network_queue. Rename _free_network_queue to r8712_free_network_queue (and change its type to static) for continued use of the original functionality. Signed-off-by: Nishka Dasgupta --- drivers/staging/rtl8712/rtl871x_

Re: [PATCH] staging: media: davinci_vpfe: Remove variable vpfe_dev

2019-05-30 Thread Greg KH
On Fri, May 31, 2019 at 02:17:18AM +0530, Nishka Dasgupta wrote: > Remove variable vpfe_dev and replace it with its value (since the > function otherwise uses values directly instead of local variables). This says _what_ you do. But we can see that in the patch itself. You need to say _why_ you

[PATCH] staging: rtl8712: Replace function r8712_init_mlme_priv

2019-05-30 Thread Nishka Dasgupta
Delete r8712_init_mlme_priv as it does nothing except call _init_mlme_priv, and rename _init_mlme_priv to r8712_init_mlme_priv. Change the type of the new r8712_init_mlme_priv (formerly _init_mlme_priv) to (non-static) int, from static sint. Signed-off-by: Nishka Dasgupta --- drivers/staging/rtl

[PATCH] staging: comedi: Remove variable runflags

2019-05-30 Thread Nishka Dasgupta
Remove variable runflags and use its value directly. Issue found with checkpatch. Signed-off-by: Nishka Dasgupta --- drivers/staging/comedi/comedi_fops.c | 8 ++-- 1 file changed, 2 insertions(+), 6 deletions(-) diff --git a/drivers/staging/comedi/comedi_fops.c b/drivers/staging/comedi/com

[PATCH] staging: media: davinci_vpfe: Remove variable vpfe_dev

2019-05-30 Thread Nishka Dasgupta
Remove variable vpfe_dev and replace it with its value (since the function otherwise uses values directly instead of local variables). Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta --- drivers/staging/media/davinci_vpfe/vpfe_video.c | 6 ++ 1 file changed, 2 insertions(+), 4 de

Re: [PATCH] staging: media: tegra-vde: Remove variable

2019-05-30 Thread Greg KH
On Fri, May 31, 2019 at 02:14:39AM +0530, Nishka Dasgupta wrote: > Remove unnecessary variable iram_tables and use its value directly. > Issue found using Coccinelle. > > Signed-off-by: Nishka Dasgupta > --- > drivers/staging/media/tegra-vde/tegra-vde.c | 6 ++ > 1 file changed, 2 insertions

[PATCH] staging: media: tegra-vde: Remove variable

2019-05-30 Thread Nishka Dasgupta
Remove unnecessary variable iram_tables and use its value directly. Issue found using Coccinelle. Signed-off-by: Nishka Dasgupta --- drivers/staging/media/tegra-vde/tegra-vde.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/drivers/staging/media/tegra-vde/tegra-vde.c

[PATCH] staging: rtl8723bs: core: fix warning Comparison to NULL

2019-05-30 Thread Hariprasad Kelam
this patch fixes "Comparison to NULL" warnings reported by checkpatch Signed-off-by: Hariprasad Kelam --- drivers/staging/rtl8723bs/core/rtw_xmit.c | 54 +++ 1 file changed, 27 insertions(+), 27 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_xmit.c b/d

In A Nutshell

2019-05-30 Thread Emissary
Hello, We have a private business proposition for you,contact me for more details. Thank you, Datuk. 5.30.19/135p/28wwe.5 ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-deve

[PATCH] staging: kpc2000: Fix build failure caused by wrong include file

2019-05-30 Thread Guenter Roeck
xtensa:allmodconfig fails to build. arch/xtensa/include/asm/uaccess.h: In function 'clear_user': arch/xtensa/include/asm/uaccess.h:40:22: error: implicit declaration of function 'uaccess_kernel' uaccess_kernel() is declared in linux/uaccess.h, not asm/uaccess.h. Fixes: 7df95299b94a ("sta