Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-06-03 Thread Sergio Paracuellos
Hi Greg, On Tue, Jun 4, 2019 at 3:31 AM Greg Ungerer wrote: > > Hi Sergio, > > On 4/6/19 5:59 am, Sergio Paracuellos wrote: > > On Mon, Jun 3, 2019 at 2:32 PM Greg Ungerer wrote: > >> On 3/6/19 3:34 pm, Sergio Paracuellos wrote: > >>> On Mon, Jun 3, 2019 at 3:26 AM Greg Ungerer wrote: > On

Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-06-03 Thread Greg Ungerer
Hi Sergio, On 4/6/19 5:59 am, Sergio Paracuellos wrote: On Mon, Jun 3, 2019 at 2:32 PM Greg Ungerer wrote: On 3/6/19 3:34 pm, Sergio Paracuellos wrote: On Mon, Jun 3, 2019 at 3:26 AM Greg Ungerer wrote: On 31/5/19 10:37 pm, Sergio Paracuellos wrote: On Thu, May 30, 2019 at 3:46 AM Greg Ung

[PATCH 5/7] staging: kpc2000: remove unnecessary include in core.c

2019-06-03 Thread Simon Sandström
Fixes checkpatch.pl warning "Use #include instead of ". Signed-off-by: Simon Sandström --- drivers/staging/kpc2000/kpc2000/core.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/kpc2000/kpc2000/core.c b/drivers/staging/kpc2000/kpc2000/core.c index 6d4fc1f37c9f..3f17566a9d03

[PATCH 6/7] staging: kpc2000: use sizeof(var) in kzalloc call

2019-06-03 Thread Simon Sandström
Fixes checkpatch.pl warning "Prefer kzalloc(sizeof(*pcard)...) over kzalloc(sizeof(struct kp2000_device)...)". Signed-off-by: Simon Sandström --- drivers/staging/kpc2000/kpc2000/core.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/kpc2000/kpc2000/core.c b/d

[PATCH 1/7] staging: kpc2000: simplify comparisons to NULL in core.c

2019-06-03 Thread Simon Sandström
Fixes checkpatch.pl warnings "Comparison to NULL could be written [...]" and "Comparisons should place the constant on the right side of the test". Signed-off-by: Simon Sandström --- drivers/staging/kpc2000/kpc2000/core.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff -

[PATCH 7/7] staging: kpc2000: fix incorrect code comment in core.c

2019-06-03 Thread Simon Sandström
Step 11 was removed from kp2000_pcie_probe in a previous commit but the comment was not changed to reflect this, so do it now. Signed-off-by: Simon Sandström --- drivers/staging/kpc2000/kpc2000/core.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/kpc2000/kpc

[PATCH 4/7] staging: kpc2000: use __func__ in debug messages in core.c

2019-06-03 Thread Simon Sandström
Fixes checkpatch.pl warning "Prefer using '"%s...", __func__' to using '', this function's name, in a string". Signed-off-by: Simon Sandström --- drivers/staging/kpc2000/kpc2000/core.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/kpc2000/kpc2000/

[PATCH 0/7] staging: kpc2000: various minor checkpatch fixes

2019-06-03 Thread Simon Sandström
Here is a bunch of checkpatch fixes for core.c in staging/kpc2000. Some of these were sent earlier but not applied. Now rebased on top of staging-testing (incl. Jeremy's kpc2000 misc device removal commits). - Simon Simon Sandström (7): staging: kpc2000: simplify comparisons to NULL in core.c

[PATCH 2/7] staging: kpc2000: remove unnecessary parentheses in core.c

2019-06-03 Thread Simon Sandström
Fixes checkpatch.pl check "Unnecessary parentheses around pdev->dev.kobj". Signed-off-by: Simon Sandström --- drivers/staging/kpc2000/kpc2000/core.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/kpc2000/kpc2000/core.c b/drivers/staging/kpc2000/kpc2000

[PATCH 3/7] staging: kpc2000: remove unnecessary oom message in core.c

2019-06-03 Thread Simon Sandström
Fixes checkpatch.pl warning "Possible unnecessary 'out of memory' message". Signed-off-by: Simon Sandström --- drivers/staging/kpc2000/kpc2000/core.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/drivers/staging/kpc2000/kpc2000/core.c b/drivers/staging/kpc2000/kpc2000/

Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-06-03 Thread Sergio Paracuellos
Hi Greg, On Mon, Jun 3, 2019 at 2:32 PM Greg Ungerer wrote: > > Hi Sergio, > > On 3/6/19 3:34 pm, Sergio Paracuellos wrote: > > On Mon, Jun 3, 2019 at 3:26 AM Greg Ungerer wrote: > >> On 31/5/19 10:37 pm, Sergio Paracuellos wrote: > >>> On Thu, May 30, 2019 at 3:46 AM Greg Ungerer wrote: >

Re: [PATCH] Staging: emxx_udc: fix warning "sum of probable bitmasks, consider |"

2019-06-03 Thread Greg Kroah-Hartman
On Tue, Jun 04, 2019 at 12:24:12AM +0530, Hariprasad Kelam wrote: > Knowing the fact that operator '|' is faster than '+'. > Its better we replace + with | in this case. > > Issue reported by coccicheck > drivers/staging/emxx_udc/emxx_udc.h:94:34-35: WARNING: sum of probable > bitmasks, consider |

[PATCH] Staging: emxx_udc: fix warning "sum of probable bitmasks, consider |"

2019-06-03 Thread Hariprasad Kelam
Knowing the fact that operator '|' is faster than '+'. Its better we replace + with | in this case. Issue reported by coccicheck drivers/staging/emxx_udc/emxx_udc.h:94:34-35: WARNING: sum of probable bitmasks, consider | Signed-off-by: Hariprasad Kelam --- drivers/staging/emxx_udc/emxx_udc.h |

WARNING: suspicious RCU usage in in_dev_dump_addr

2019-06-03 Thread syzbot
Hello, syzbot found the following crash on: HEAD commit:b33bc2b8 nexthop: Add entry to MAINTAINERS git tree: net-next console output: https://syzkaller.appspot.com/x/log.txt?x=13f46f52a0 kernel config: https://syzkaller.appspot.com/x/.config?x=1004db091673bbaf dashboard link: http

[PATCH] staging: rtl8723bs: hal: fix error "do not initialise globals to 0"

2019-06-03 Thread Hariprasad Kelam
this patch fixes below Errors reported by checkpatch ERROR: do not initialise globals to 0 +u8 g_fwdl_chksum_fail = 0; ERROR: do not initialise globals to 0 +u8 g_fwdl_wintint_rdy_fail = 0; Signed-off-by: Hariprasad Kelam --- drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c | 4 ++-- 1 file c

Re: [PATCH 7/7] media: cedrus: Improve H264 memory efficiency

2019-06-03 Thread Jernej Škrabec
Dne ponedeljek, 03. junij 2019 ob 14:23:28 CEST je Maxime Ripard napisal(a): > On Thu, May 30, 2019 at 11:15:16PM +0200, Jernej Skrabec wrote: > > H264 decoder driver preallocated pretty big worst case mv col buffer > > pool. It turns out that pool is most of the time much bigger than it > > needs

Re: [PATCH 6/7] media: cedrus: Add infra for extra buffers connected to capture buffers

2019-06-03 Thread Jernej Škrabec
Dne ponedeljek, 03. junij 2019 ob 14:18:59 CEST je Maxime Ripard napisal(a): > Hi, > > On Thu, May 30, 2019 at 11:15:15PM +0200, Jernej Skrabec wrote: > > H264 and HEVC engines need additional buffers for each capture buffer. > > H264 engine has this currently solved by allocating fixed size pool,

Re: [PATCH 3/7] media: cedrus: Fix decoding for some H264 videos

2019-06-03 Thread Jernej Škrabec
Dne ponedeljek, 03. junij 2019 ob 13:55:36 CEST je Maxime Ripard napisal(a): > Hi, > > On Thu, May 30, 2019 at 11:15:12PM +0200, Jernej Skrabec wrote: > > It seems that for some H264 videos at least one bitstream parsing > > trigger must be called in order to be decoded correctly. There is no > >

Re: [PATCH 2/7] media: cedrus: Fix H264 default reference index count

2019-06-03 Thread Jernej Škrabec
Dne ponedeljek, 03. junij 2019 ob 13:46:20 CEST je Maxime Ripard napisal(a): > On Thu, May 30, 2019 at 11:15:11PM +0200, Jernej Skrabec wrote: > > Reference index count in VE_H264_PPS reg should come from PPS control. > > However, this is not really important because reference index count is > > in

Re: [PATCH 3/3] drivers/staging/rtl8192u: Fix of checkpatch-errors

2019-06-03 Thread Joe Perches
On Mon, 2019-06-03 at 14:21 +0200, Christian Müller wrote: > Fix issues that lead to multiple checkpatch warnings and errors, most of > them regarding formatting of code and comments. > Comments that contain only commented out code are removed as well. Generally, the quantity of changes in this pa

Re: [PATCH 2/3] drivers/staging/rtl8192u: Remove comment-out code

2019-06-03 Thread Greg KH
On Mon, Jun 03, 2019 at 02:21:03PM +0200, Christian Müller wrote: > From: Felix Trommer > > Remove the majority of all commented-out code. Commented out code, that > was adressed by a comment itself is not removed. The code that we left > in as comments was mostly due to the "pseudo-code"-like na

Re: [PATCH 3/3] drivers/staging/rtl8192u: Fix of checkpatch-errors

2019-06-03 Thread Greg KH
On Mon, Jun 03, 2019 at 02:21:04PM +0200, Christian Müller wrote: > Fix issues that lead to multiple checkpatch warnings and errors, most of > them regarding formatting of code and comments. > Comments that contain only commented out code are removed as well. > > Signed-off-by: Felix Trommer > Si

Re: [PATCH 1/3] drivers/staging/rtl8192u: Reformat comments

2019-06-03 Thread Greg KH
On Mon, Jun 03, 2019 at 02:21:02PM +0200, Christian Müller wrote: > From: Felix Trommer > > Replace C99-Style comments with C89-Style comments. What does that mean? > if (MaxChnlNum >= pTriple->first_channel) { > - /* It is not in a monotonically increasing ord

Re: [net-next:master 391/455] drivers/staging/isdn/avm/b1.c:163:49: sparse: sparse: incorrect type in argument 2 (different address spaces)

2019-06-03 Thread Arnd Bergmann
On Mon, Jun 3, 2019 at 1:40 PM kbuild test robot wrote: > > Hi Arnd, > > First bad commit (maybe != root cause): Yep: > >> drivers/staging/isdn/avm/b1.c:163:49: sparse: sparse: incorrect type in > >> argument 2 (different address spaces) @@expected void const [noderef] > >> *from @@go

[PATCH 0/3] Fixing style errors in staging/drivers/rtl8192u

2019-06-03 Thread Christian Müller
This series of patches fixes various style errors in the rtl8192u staging driver. These fixes contain reformatting of code comments, changing of indentations, cleaning up commented out code within the source-code and fixes for individual errors indicated by the checkpatch tool. Christian Müller (1

Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-06-03 Thread Greg Ungerer
Hi Sergio, On 3/6/19 3:34 pm, Sergio Paracuellos wrote: On Mon, Jun 3, 2019 at 3:26 AM Greg Ungerer wrote: On 31/5/19 10:37 pm, Sergio Paracuellos wrote: On Thu, May 30, 2019 at 3:46 AM Greg Ungerer wrote: On 30/5/19 10:44 am, Greg Ungerer wrote: On 29/5/19 6:08 pm, Sergio Paracuellos wrot

[PATCH 3/3] drivers/staging/rtl8192u: Fix of checkpatch-errors

2019-06-03 Thread Christian Müller
Fix issues that lead to multiple checkpatch warnings and errors, most of them regarding formatting of code and comments. Comments that contain only commented out code are removed as well. Signed-off-by: Felix Trommer Signed-off-by: Christian Müller --- .../staging/rtl8192u/ieee80211/ieee80211.h

[PATCH 2/3] drivers/staging/rtl8192u: Remove comment-out code

2019-06-03 Thread Christian Müller
From: Felix Trommer Remove the majority of all commented-out code. Commented out code, that was adressed by a comment itself is not removed. The code that we left in as comments was mostly due to the "pseudo-code"-like nature of the code that helped to clarify certain functionalities. Signed-off

Re: [PATCH 7/7] media: cedrus: Improve H264 memory efficiency

2019-06-03 Thread Maxime Ripard
On Thu, May 30, 2019 at 11:15:16PM +0200, Jernej Skrabec wrote: > H264 decoder driver preallocated pretty big worst case mv col buffer > pool. It turns out that pool is most of the time much bigger than it > needs to be. > > Solution implemented here is to allocate memory only if capture buffer > i

Re: [PATCH] staging: rtl8712: Change _SUCCESS/_FAIL to 0/-ENOMEM

2019-06-03 Thread Greg KH
On Fri, May 31, 2019 at 02:36:38AM +0530, Nishka Dasgupta wrote: > Change return values _SUCCESS and _FAIL to 0 and -ENOMEM respectively, > to match the convention in the drivers (and also because the return > value of this changed function is never checked anyway). > Change return type of the func

Re: [PATCH] staging: rtl8712: Remove function alloc_network

2019-06-03 Thread Greg KH
On Fri, May 31, 2019 at 02:31:41AM +0530, Nishka Dasgupta wrote: > Remove function alloc_network as it does nothing except call > _r8712_alloc_network. Further, to maintain consistency with > the names of other functions, rename _r8712_alloc_network as > r8712_alloc_network. > Also change the corre

Re: [PATCH 6/7] media: cedrus: Add infra for extra buffers connected to capture buffers

2019-06-03 Thread Maxime Ripard
Hi, On Thu, May 30, 2019 at 11:15:15PM +0200, Jernej Skrabec wrote: > H264 and HEVC engines need additional buffers for each capture buffer. > H264 engine has this currently solved by allocating fixed size pool, > which is not ideal. Most of the time pool size is much bigger than it > needs to be.

Re: [PATCH] staging: rtl8712: Replace function r8712_free_network_queue

2019-06-03 Thread Greg KH
On Fri, May 31, 2019 at 02:27:55AM +0530, Nishka Dasgupta wrote: > Remove function r8712_free_network_queue as it does nothing except call > _free_network_queue. > Rename _free_network_queue to r8712_free_network_queue (and change its > type to static) for continued use of the original functionalit

Re: [PATCH 5/5] staging: kpc2000: kpc_spi: use devm_* API to manage mapped I/O space

2019-06-03 Thread Greg Kroah-Hartman
On Sun, Jun 02, 2019 at 03:58:37PM +, Geordan Neukum wrote: > The kpc_spi driver does not unmap its I/O space upon error cases in the > probe() function or upon remove(). Make the driver clean up after itself > more maintainably by migrating to using the managed resource API. > > Signed-off-by

Re: [PATCH 4/7] media: cedrus: Remove dst_bufs from context

2019-06-03 Thread Maxime Ripard
On Thu, May 30, 2019 at 11:15:13PM +0200, Jernej Skrabec wrote: > This array is just duplicated capture buffer queue. Remove it and adjust > code to look into capture buffer queue instead. > > Signed-off-by: Jernej Skrabec Acked-by: Maxime Ripard Maxime -- Maxime Ripard, Bootlin Embedded Linux

Re: [PATCH 1/2] staging: kpc2000: export more device attributes via sysfs.

2019-06-03 Thread Greg KH
On Mon, Jun 03, 2019 at 02:08:56PM +0200, Greg KH wrote: > On Fri, May 31, 2019 at 11:52:30AM +0100, Jeremy Sowden wrote: > > Added more read-only device attributes in order to expose all the > > information about the hardware which is available by calling read() or > > ioct() on the misc device as

Re: [PATCH 1/2] staging: kpc2000: export more device attributes via sysfs.

2019-06-03 Thread Greg KH
On Fri, May 31, 2019 at 11:52:30AM +0100, Jeremy Sowden wrote: > Added more read-only device attributes in order to expose all the > information about the hardware which is available by calling read() or > ioct() on the misc device associated with it. > > Signed-off-by: Jeremy Sowden > --- > dri

Re: [PATCH] Improve code style in drivers/staging/rts5208

2019-06-03 Thread Greg KH
On Mon, Jun 03, 2019 at 01:43:50PM +0200, Tobias Nießen wrote: > These changes to sd.c and xd.c slightly improve the code style and > reduce the overall line length. > > Signed-off-by: Tobias Nießen > Signed-off-by: Sabrina Gaube > --- > drivers/staging/rts5208/sd.c | 23 +++

Re: [PATCH 3/7] media: cedrus: Fix decoding for some H264 videos

2019-06-03 Thread Maxime Ripard
Hi, On Thu, May 30, 2019 at 11:15:12PM +0200, Jernej Skrabec wrote: > It seems that for some H264 videos at least one bitstream parsing > trigger must be called in order to be decoded correctly. There is no > explanation why this helps, but it was observed that two sample videos > with this fix ar

[PATCH] Improve code style in drivers/staging/rts5208

2019-06-03 Thread Tobias Nießen
These changes to sd.c and xd.c slightly improve the code style and reduce the overall line length. Signed-off-by: Tobias Nießen Signed-off-by: Sabrina Gaube --- drivers/staging/rts5208/sd.c | 23 +++ drivers/staging/rts5208/xd.c | 8 2 files changed, 15 insertions(

Re: [PATCH 2/7] media: cedrus: Fix H264 default reference index count

2019-06-03 Thread Maxime Ripard
On Thu, May 30, 2019 at 11:15:11PM +0200, Jernej Skrabec wrote: > Reference index count in VE_H264_PPS reg should come from PPS control. > However, this is not really important because reference index count is > in our case always overridden by that from slice header. > > Cc: nico...@ndufresne.ca >

Re: [PATCH 1/7] media: cedrus: Disable engine after each slice decoding

2019-06-03 Thread Maxime Ripard
Hi, On Thu, May 30, 2019 at 11:15:10PM +0200, Jernej Skrabec wrote: > libvdpau-sunxi always disables engine after each decoded slice. > Do same in Cedrus driver. > > Presumably this also lowers power consumption which is always nice. > > Signed-off-by: Jernej Skrabec Is it fixing anything though

Re: [GIT PULL net-next, resend] isdn: deprecate non-mISDN drivers

2019-06-03 Thread Werner Cornelius
Am Freitag, 31. Mai 2019 schrieb Arnd Bergmann: Just for information about the history and maybe state of parts of the old ISDN drivers. There are still some large private ISDN networks available and will stay available for several years. I am still serving solutions there, but without i4l or c