[PATCH] staging: sm750fb: Replace pr_*() with dev_*().

2016-10-31 Thread Elise Lennion
dev_*() functions print identifying information about the struct device and should be used instead of pr_*() whenever possible. Signed-off-by: Elise Lennion --- drivers/staging/sm750fb/sm750.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging

[PATCH 3/3] staging: rtl8188eu: Standardize test for NULL.

2016-10-28 Thread Elise Lennion
map \|usb_alloc_urb\|alloc_netdev\|dev_alloc_skb\) (...) ... when any when != id = e + if (!id) - if (\(NULL == id\|id == NULL\)) S ...+> } Signed-off-by: Elise Lennion --- drivers/staging/rtl8188eu/os_dep/usb_ops_linux.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/s

[PATCH 2/3] staging: rtl8192u: Standardize test for NULL.

2016-10-28 Thread Elise Lennion
map \|usb_alloc_urb\|alloc_netdev\|dev_alloc_skb\) (...) ... when any when != id = e + if (!id) - if (\(NULL == id\|id == NULL\)) S ...+> } Signed-off-by: Elise Lennion --- drivers/staging/rtl8192u/ieee80211/ieee80211_rx.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/s

[PATCH 1/3] staging: rtl8192e: Standardize test for NULL.

2016-10-28 Thread Elise Lennion
map \|usb_alloc_urb\|alloc_netdev\|dev_alloc_skb\) (...) ... when any when != id = e + if (!id) - if (\(NULL == id\|id == NULL\)) S ...+> } Signed-off-by: Elise Lennion --- drivers/staging/rtl8192e/rtl8192e/r8192E_cmdpkt.c | 2 +- drivers/staging/rtl8192e/rtllib_rx.c | 4 ++-- 2 files c

[PATCH 3/3] staging: sm750fb: Shorten local variables names.

2016-10-27 Thread Elise Lennion
Shorter names are preferred by C variables naming convention, they are easier to write and aren't more difficult to understand. Signed-off-by: Elise Lennion --- drivers/staging/sm750fb/ddk750_power.c | 26 +- 1 file changed, 13 insertions(+), 13 deletions(-) diff

[PATCH 2/3] staging: sm750fb: Replace functions CamelCase naming with underscores.

2016-10-27 Thread Elise Lennion
Replace CamelCase function names with underscores to comply with the standard kernel coding style. Signed-off-by: Elise Lennion --- drivers/staging/sm750fb/ddk750_chip.c| 4 ++-- drivers/staging/sm750fb/ddk750_display.c | 2 +- drivers/staging/sm750fb/ddk750_hwi2c.c | 4 ++-- drivers

[PATCH 1/3] staging: sm750fb: Refine code in set_current_gate().

2016-10-27 Thread Elise Lennion
The 'switch' statement in set_current_gate() had only two possible scenarios, so it was replaced with an 'if' statement to make the code shorter and easier to understand. Signed-off-by: Elise Lennion --- drivers/staging/sm750fb/ddk750_power.c | 24 ---

Re: [PATCH] staging: sm750fb: Refine the code and remove unused code.

2016-10-26 Thread Elise Lennion
On Wed, Oct 26, 2016 at 11:52:41AM +0300, Dan Carpenter wrote: > So, when I'm reviewing these, there are obviously a lot of patches that > go through staging and I try to do them as fast as possible and quite > often make mistakes. Feel free to speak up when that happens, I won't > be offended. >

[PATCH] staging: sm750fb: Refine the code and remove unused code.

2016-10-25 Thread Elise Lennion
within the 'else' statement, because it was never satisfied. The modified function was refined to better match the Kernel coding style. Signed-off-by: Elise Lennion --- drivers/staging/sm750fb/ddk750_display.c | 71 ++-- 1 file changed, 21 insertions(+), 50 dele