Re: [PATCH] block: convert tasklets to use new tasklet_setup() API

2020-08-19 Thread Jens Axboe
let() > > - out_cast() or outer_cast() > - from_member(). > - container_from() or from_container() > > from_container() sounds fine, would trimming it a bit work? like from_cont(). I like container_from() the most, since it's the closest to contain_of() which is a w

Re: [PATCH] block: convert tasklets to use new tasklet_setup() API

2020-08-19 Thread Jens Axboe
On 8/19/20 6:11 AM, Greg KH wrote: > On Wed, Aug 19, 2020 at 07:00:53AM -0600, Jens Axboe wrote: >> On 8/18/20 1:00 PM, James Bottomley wrote: >>> On Mon, 2020-08-17 at 13:02 -0700, Jens Axboe wrote: >>>> On 8/17/20 12:48 PM, Kees Cook wrote: >>>>> O

Re: [PATCH] block: convert tasklets to use new tasklet_setup() API

2020-08-19 Thread Jens Axboe
On 8/18/20 1:00 PM, James Bottomley wrote: > On Mon, 2020-08-17 at 13:02 -0700, Jens Axboe wrote: >> On 8/17/20 12:48 PM, Kees Cook wrote: >>> On Mon, Aug 17, 2020 at 12:44:34PM -0700, Jens Axboe wrote: >>>> On 8/17/20 12:29 PM, Kees Cook wrote: >>>>> O

Re: [PATCH] block: convert tasklets to use new tasklet_setup() API

2020-08-17 Thread Jens Axboe
On 8/17/20 12:48 PM, Kees Cook wrote: > On Mon, Aug 17, 2020 at 12:44:34PM -0700, Jens Axboe wrote: >> On 8/17/20 12:29 PM, Kees Cook wrote: >>> On Mon, Aug 17, 2020 at 06:56:47AM -0700, Jens Axboe wrote: >>>> On 8/17/20 2:15 AM, Allen Pais wrote: >>>>>

Re: [PATCH] block: convert tasklets to use new tasklet_setup() API

2020-08-17 Thread Jens Axboe
On 8/17/20 12:29 PM, Kees Cook wrote: > On Mon, Aug 17, 2020 at 06:56:47AM -0700, Jens Axboe wrote: >> On 8/17/20 2:15 AM, Allen Pais wrote: >>> From: Allen Pais >>> >>> In preparation for unconditionally passing the >>> struct tasklet_struct pointer

Re: [PATCH] block: convert tasklets to use new tasklet_setup() API

2020-08-17 Thread Jens Axboe
e up with the idea to add a macro 'from_tasklet' that is just container_of? container_of in the code would be _much_ more readable, and not leave anyone guessing wtf from_tasklet is doing. I'd fix that up now before everything else goes in... -- Jens Axboe

Re: [PATCH] mm/gup: Use put_user_page*() instead of put_page*()

2019-07-14 Thread Jens Axboe
_pages); > kvfree(imu->bvec); You handled just the failure case of the buffer registration, but not the actual free in io_sqe_buffer_unregister(). -- Jens Axboe ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH 13/31] timer: Remove meaningless .data/.function assignments

2017-09-01 Thread Jens Axboe
On 08/31/2017 05:29 PM, Kees Cook wrote: > Several timer users needlessly reset their .function/.data fields during > their timer callback, but nothing else changes them. Some users do not > use their .data field at all. Each instance is removed here. For amiflop: Acked-by: Jens Axboe

Re: [PATCH 1/1] [SCSI] Fix a bug in deriving the FLUSH_TIMEOUT from the basic I/O timeout

2014-06-06 Thread Jens Axboe
one earlier today: http://git.kernel.dk/?p=linux-block.git;a=commit;h=f6be4fb4bcb396fc3b1c134b7863351972de081f since I ran into the same thing on nvme. Either approach is fine with me, as they both allow override of the timeout before insertion. But we've always done the rq->timeout

Re: [PATCH] block: replace IS_ERR and PTR_ERR with PTR_ERR_OR_ZERO

2013-11-07 Thread Jens Axboe
On 11/06/2013 12:55 AM, Duan Jiong wrote: > This patch fixes coccinelle error regarding usage of IS_ERR and > PTR_ERR instead of PTR_ERR_OR_ZERO. Applied, thanks. -- Jens Axboe ___ devel mailing list de...@linuxdriverproject.or

Re: [PATCH] block: replace IS_ERR and PTR_ERR with PTR_ERR_OR_ZERO

2013-11-07 Thread Jens Axboe
On 11/06/2013 12:56 AM, Duan Jiong wrote: > This patch fixes coccinelle error regarding usage of IS_ERR and > PTR_ERR instead of PTR_ERR_OR_ZERO. Applied, thanks. -- Jens Axboe ___ devel mailing list de...@linuxdriverproject.or