[libvirt] [PATCH 4/5] parallels: obtain domain info with SDK

2014-10-14 Thread Dmitry Guryanov
From: Alexander Burluka Add code, which can fill virDomainDef structure by parallels sdk handle. prlsdkCreateDomainObj function is an analogue of parallelsLoadDomain from parallels_driver.c. Also use this new code in parallelsDomainGetXMLDesc to check it and remove build error about unused funct

[libvirt] [PATCH 5/5] parallels: change domains state with SDK

2014-10-14 Thread Dmitry Guryanov
Implement functions, which change domain state with SDK. We have to keep stored domains list up-to-date, so update domain info after calling prlsdkDomain*. When we remove cached domain list, we can remove functions parallelsDomain*, because they will be just calling corresponding functions from p

[libvirt] [PATCH 0/5] parallels: continue rewriting code to use sdk

2014-10-14 Thread Dmitry Guryanov
This patch series replaces a series of functions, which retieve different domains info and modifies domains state with new ones, which use parallels sdk instead of executing prlctl command. These functions don't use cached domains list _parallelsConn.domains, so when we rewrite all code, we will b

[libvirt] [PATCH 3/5] parallels: move IS_CT macro to parallels_utils.h

2014-10-14 Thread Dmitry Guryanov
This macro will be used in paralles_sdk.c so move it to common header. Signed-off-by: Dmitry Guryanov --- src/parallels/parallels_driver.c | 2 -- src/parallels/parallels_utils.h | 2 ++ 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/src/parallels/parallels_driver.c b/src/parall

[libvirt] [PATCH 2/5] parallels: implement lookup functions with SDK

2014-10-14 Thread Dmitry Guryanov
Implement functions parallelsDomainLookupByUUID and parallelsDomainLookupByName with SDK instead of running prlctl command. Signed-off-by: Dmitry Guryanov --- src/parallels/parallels_driver.c | 48 +-- src/parallels/parallels_sdk.c| 83

[libvirt] [PATCH 1/5] parallels: list domains with parallels SDK

2014-10-14 Thread Dmitry Guryanov
Use SDK to return a list of domains in parallelsConnectListAllDomains function instead of prlctl. Signed-off-by: Dmitry Guryanov --- src/parallels/parallels_driver.c | 9 +- src/parallels/parallels_sdk.c| 243 +++ src/parallels/parallels_sdk.h| 3 +

Re: [libvirt] [PATCH 1/9] conf: Improve adding of new address types

2014-10-14 Thread Peter Krempa
On 10/14/14 10:56, John Ferlan wrote: > > > On 10/14/2014 03:29 AM, Peter Krempa wrote: >> Use typecasted switch statement and note the type used to select the >> address type in a comment. >> --- >> src/conf/domain_conf.c | 36 >> src/conf/domain_conf.h | 2

Re: [libvirt] [PATCH 7/9] qemu: monitor: Add functions for object hot-add/remove

2014-10-14 Thread John Ferlan
On 10/14/2014 03:29 AM, Peter Krempa wrote: > To allow live modification of device backends in qemu libvirt needs to > be able to hot-add/remove "objects". Add monitor backend functions to > allow this. Could add a short list of "known" objects that could make use of this... IOThreads, RNG, etc.

Re: [libvirt] [PATCHv2 1/2] util: Functions to update host network device's multicast filter

2014-10-14 Thread Laine Stump
On 10/14/2014 02:41 PM, Laine Stump wrote: > I think you forgot to merge in your modifications from V1 - although the > commit log is changed, the code is still the V1 patch :-) Ah, I see that you sent the actual V2 patch last weekend, and only sent this update to move the "changes from V1" messag

Re: [libvirt] [PATCHv2 1/2] util: Functions to update host network device's multicast filter

2014-10-14 Thread Laine Stump
I think you forgot to merge in your modifications from V1 - although the commit log is changed, the code is still the V1 patch :-) On 10/13/2014 03:52 PM, akrow...@linux.vnet.ibm.com wrote: > From: Tony Krowiak > > This patch provides the utility functions to needed to synchronize the > changes

Re: [libvirt] [PATCH] "pclmuldq" was introduced with Westmere, not Sandy Bridge. This feature is important to get proper performance for aes-128-gcm in openssl, an important cipher for https communica

2014-10-14 Thread Daniel P. Berrange
On Tue, Oct 14, 2014 at 01:59:15PM +0300, Itamar Heim wrote: > On 10/14/2014 01:28 PM, Jan-Frode Myklebust wrote: > >On Wed, Oct 08, 2014 at 09:49:35AM +0200, Jiri Denemark wrote: > >> > >>Technically you are correct and even QEMU added this feature to Westmere > >>in April 2013. However, our goal

Re: [libvirt] [PATCH 9/9] conf: Move definition of virDomainParseMemory

2014-10-14 Thread John Ferlan
On 10/14/2014 03:29 AM, Peter Krempa wrote: > Shove it to the top of the file so that it can be reused earlier. > --- > src/conf/domain_conf.c | 60 > +- > 1 file changed, 30 insertions(+), 30 deletions(-) > Code motion ACK John -- libvir-list

Re: [libvirt] [PATCH 8/9] Implement empty post parse callbacks for all drivers

2014-10-14 Thread John Ferlan
On 10/14/2014 03:29 AM, Peter Krempa wrote: > To allow easy implementation of a callback check this patch adds empty > post parse callbacks to drivers that were missing them. > --- > src/bhyve/bhyve_domain.c | 10 ++ > src/parallels/parallels_driver.c | 21 + >

Re: [libvirt] [PATCH] "pclmuldq" was introduced with Westmere, not Sandy Bridge. This feature is important to get proper performance for aes-128-gcm in openssl, an important cipher for https communica

2014-10-14 Thread Itamar Heim
On 10/14/2014 01:28 PM, Jan-Frode Myklebust wrote: On Wed, Oct 08, 2014 at 09:49:35AM +0200, Jiri Denemark wrote: Technically you are correct and even QEMU added this feature to Westmere in April 2013. However, our goal is to provide stable virtual hardware that doesn't change when, e.g., a dom

Re: [libvirt] [PATCH 6/9] util: json: Improve handling and docs for adding JSON objects

2014-10-14 Thread John Ferlan
On 10/14/2014 03:29 AM, Peter Krempa wrote: > The JSON structure constructor has an option to add JSON arrays to the > constructed object. The description is inaccurate as it can add any json > object even a dict. Change the docs to cover this option and add > possibility to specify NULL object t

Re: [libvirt] [PATCH 5/9] util: json: Split out code to create json value objects

2014-10-14 Thread John Ferlan
On 10/14/2014 03:29 AM, Peter Krempa wrote: > Our qemu monitor code has a converter from key-value pairs to a json > value object. I want to re-use the code later and having it part of the > monitor command generator is inflexible. Split it out into a separate > helper. > --- > src/libvirt_priva

Re: [libvirt] [PATCH] libvirt: Document UNDEFINE_NVRAM in UndefineFlags doc

2014-10-14 Thread Martin Kletzander
On Tue, Oct 14, 2014 at 12:03:59PM +0200, Cole Robinson wrote: --- src/libvirt.c | 4 1 file changed, 4 insertions(+) diff --git a/src/libvirt.c b/src/libvirt.c index caacc2e..dfca4f6 100644 --- a/src/libvirt.c +++ b/src/libvirt.c @@ -8760,6 +8760,10 @@ virDomainUndefine(virDomainPtr domain)

Re: [libvirt] [PATCH] "pclmuldq" was introduced with Westmere, not Sandy Bridge. This feature is important to get proper performance for aes-128-gcm in openssl, an important cipher for https communica

2014-10-14 Thread Jan-Frode Myklebust
On Wed, Oct 08, 2014 at 09:49:35AM +0200, Jiri Denemark wrote: > > Technically you are correct and even QEMU added this feature to Westmere > in April 2013. However, our goal is to provide stable virtual hardware > that doesn't change when, e.g., a domain is migrated to another machine > (let's ig

[libvirt] [PATCH] libvirt: Document UNDEFINE_NVRAM in UndefineFlags doc

2014-10-14 Thread Cole Robinson
--- src/libvirt.c | 4 1 file changed, 4 insertions(+) diff --git a/src/libvirt.c b/src/libvirt.c index caacc2e..dfca4f6 100644 --- a/src/libvirt.c +++ b/src/libvirt.c @@ -8760,6 +8760,10 @@ virDomainUndefine(virDomainPtr domain) * whether this flag is present. On hypervisors where snapsh

Re: [libvirt] [PATCH 4/9] qemu: hotplug: Use typecasted switch statement when plugging new devices

2014-10-14 Thread John Ferlan
On 10/14/2014 03:29 AM, Peter Krempa wrote: > --- > src/qemu/qemu_driver.c | 17 +++-- > 1 file changed, 15 insertions(+), 2 deletions(-) > ACK John -- libvir-list mailing list libvir-list@redhat.com https://www.redhat.com/mailman/listinfo/libvir-list

Re: [libvirt] [PATCH 3/9] conf: Add compile time check that devices were checked for ABI stability

2014-10-14 Thread John Ferlan
On 10/14/2014 03:29 AM, Peter Krempa wrote: > As in the device info iterator add a switch that will force the compiler > to check that new device types are added to the ABI stability checker. > --- > src/conf/domain_conf.c | 33 + > 1 file changed, 33 insertions(+

Re: [libvirt] [PATCH 2/9] conf: shmem: Add ABI stability check

2014-10-14 Thread John Ferlan
On 10/14/2014 03:29 AM, Peter Krempa wrote: > Although the device will probably inhibit migration add checks to make > sure that the configuration change gets caught. > --- > src/conf/domain_conf.c | 50 > ++ > 1 file changed, 50 insertions(+) >

Re: [libvirt] [PATCH 1/9] conf: Improve adding of new address types

2014-10-14 Thread John Ferlan
On 10/14/2014 03:29 AM, Peter Krempa wrote: > Use typecasted switch statement and note the type used to select the > address type in a comment. > --- > src/conf/domain_conf.c | 36 > src/conf/domain_conf.h | 2 +- > 2 files changed, 25 insertions(+), 13 dele

Re: [libvirt] [PATCH 4/5] libxl: Implement basic video device selection

2014-10-14 Thread John Ferlan
Coverity complains... On 09/19/2014 03:23 PM, Jim Fehlig wrote: > From: Stefan Bader > > This started as an investigation into an issue where libvirt (using the > libxl driver) and the Xen host, like an old couple, could not agree on > who is responsible for selecting the VNC port to use. > > T

Re: [libvirt] [PATCH] virsh: domain: Use global constant for XML file size limit

2014-10-14 Thread Peter Krempa
On 10/14/14 10:25, Ján Tomko wrote: > On 10/14/2014 10:09 AM, Peter Krempa wrote: >> Few places still used hardcoded limit for maximum XML size for commands >> that accept XML files. The hardcoded limits ranged from 8k to 1M. Use >> VSH_MAX_XML_FILE to express this limit in a unified way. This will

Re: [libvirt] [PATCH] virsh: domain: Use global constant for XML file size limit

2014-10-14 Thread Ján Tomko
On 10/14/2014 10:09 AM, Peter Krempa wrote: > Few places still used hardcoded limit for maximum XML size for commands > that accept XML files. The hardcoded limits ranged from 8k to 1M. Use > VSH_MAX_XML_FILE to express this limit in a unified way. This will bump > the limit for the commands that u

[libvirt] [PATCH] virsh: domain: Use global constant for XML file size limit

2014-10-14 Thread Peter Krempa
Few places still used hardcoded limit for maximum XML size for commands that accept XML files. The hardcoded limits ranged from 8k to 1M. Use VSH_MAX_XML_FILE to express this limit in a unified way. This will bump the limit for the commands that used hardcoded string lengths to 10M. Resolves: http

Re: [libvirt] [PATCH v2 0/3] Resolve libvirtd crash matching scsi_host

2014-10-14 Thread John Ferlan
ping Tks, John On 10/06/2014 05:49 PM, John Ferlan wrote: > https://bugzilla.redhat.com/show_bug.cgi?id=1146837 > > Rewrite the v1 patch to take a different method to attack the problem. > Expose the getHostNumber from scsi check/startup/refresh in the form > of virGetSCSIHostNumber. Additiona

Re: [libvirt] [PATCH v3 0/7] hotplug: Fix libvirtd crash on qemu-attached guest

2014-10-14 Thread John Ferlan
ping? Tks, John On 10/08/2014 08:08 PM, John Ferlan wrote: > v2 is here: > > http://www.redhat.com/archives/libvir-list/2014-September/msg01575.html > > As Michal pointed out in his review - other devices could have the > same issue - so take care of each of them separately (I already knew > t

[libvirt] [PATCH] virsh: man: Fix description of --live/--config usage

2014-10-14 Thread Peter Krempa
dommemstat and blkdeviotune's man page incorrectly stated the usage of --live and --config. --- Notes: Pushed as trivial. tools/virsh.pod | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/tools/virsh.pod b/tools/virsh.pod index eae9195..cc55821 100644 --- a/tools/virsh.

[libvirt] [PATCH] qemu: command: Allow UEFI for non-x86

2014-10-14 Thread Cole Robinson
It's supported on aarch64 and armv7l as well, so just drop the restriction entirely since it doesn't add much. --- src/qemu/qemu_command.c | 8 1 file changed, 8 deletions(-) diff --git a/src/qemu/qemu_command.c b/src/qemu/qemu_command.c index 8cb0865..2872e47 100644 --- a/src/qemu/qemu_

[libvirt] [PATCH 6/9] util: json: Improve handling and docs for adding JSON objects

2014-10-14 Thread Peter Krempa
The JSON structure constructor has an option to add JSON arrays to the constructed object. The description is inaccurate as it can add any json object even a dict. Change the docs to cover this option and add possibility to specify NULL object to be added. These will be skipped as we have with othe

[libvirt] [PATCH 9/9] conf: Move definition of virDomainParseMemory

2014-10-14 Thread Peter Krempa
Shove it to the top of the file so that it can be reused earlier. --- src/conf/domain_conf.c | 60 +- 1 file changed, 30 insertions(+), 30 deletions(-) diff --git a/src/conf/domain_conf.c b/src/conf/domain_conf.c index 0634116..42c0223 100644 --- a/

[libvirt] [PATCH 5/9] util: json: Split out code to create json value objects

2014-10-14 Thread Peter Krempa
Our qemu monitor code has a converter from key-value pairs to a json value object. I want to re-use the code later and having it part of the monitor command generator is inflexible. Split it out into a separate helper. --- src/libvirt_private.syms | 2 + src/qemu/qemu_monitor_json.c | 161 +-

[libvirt] [PATCH 3/9] conf: Add compile time check that devices were checked for ABI stability

2014-10-14 Thread Peter Krempa
As in the device info iterator add a switch that will force the compiler to check that new device types are added to the ABI stability checker. --- src/conf/domain_conf.c | 33 + 1 file changed, 33 insertions(+) diff --git a/src/conf/domain_conf.c b/src/conf/domain

[libvirt] [PATCH 8/9] Implement empty post parse callbacks for all drivers

2014-10-14 Thread Peter Krempa
To allow easy implementation of a callback check this patch adds empty post parse callbacks to drivers that were missing them. --- src/bhyve/bhyve_domain.c | 10 ++ src/parallels/parallels_driver.c | 21 + src/phyp/phyp_driver.c | 29 ++

[libvirt] [PATCH 1/9] conf: Improve adding of new address types

2014-10-14 Thread Peter Krempa
Use typecasted switch statement and note the type used to select the address type in a comment. --- src/conf/domain_conf.c | 36 src/conf/domain_conf.h | 2 +- 2 files changed, 25 insertions(+), 13 deletions(-) diff --git a/src/conf/domain_conf.c b/src/conf/d

[libvirt] [PATCH 2/9] conf: shmem: Add ABI stability check

2014-10-14 Thread Peter Krempa
Although the device will probably inhibit migration add checks to make sure that the configuration change gets caught. --- src/conf/domain_conf.c | 50 ++ 1 file changed, 50 insertions(+) diff --git a/src/conf/domain_conf.c b/src/conf/domain_conf.c

[libvirt] [PATCH 4/9] qemu: hotplug: Use typecasted switch statement when plugging new devices

2014-10-14 Thread Peter Krempa
--- src/qemu/qemu_driver.c | 17 +++-- 1 file changed, 15 insertions(+), 2 deletions(-) diff --git a/src/qemu/qemu_driver.c b/src/qemu/qemu_driver.c index 7c9b1ab..e0fd4c0 100644 --- a/src/qemu/qemu_driver.c +++ b/src/qemu/qemu_driver.c @@ -6805,7 +6805,7 @@ qemuDomainAttachDeviceLive

[libvirt] [PATCH 7/9] qemu: monitor: Add functions for object hot-add/remove

2014-10-14 Thread Peter Krempa
To allow live modification of device backends in qemu libvirt needs to be able to hot-add/remove "objects". Add monitor backend functions to allow this. --- src/qemu/qemu_monitor.c | 48 + src/qemu/qemu_monitor.h | 8 +++ src/qemu/qemu_monitor_jso

[libvirt] [PATCH 0/9] ABI/JSON/other fixes

2014-10-14 Thread Peter Krempa
I've split out these patches from my work on supporting memory hotplug in qemu so that the resulting series is not extremely huge. Peter Krempa (9): conf: Improve adding of new address types conf: shmem: Add ABI stability check conf: Add compile time check that devices were checked for ABI