Re: [libvirt] [PATCH for 1.3.3 0/5] Fix parsing our own XMLs

2016-04-03 Thread Michal Privoznik
On 03.04.2016 21:27, Martin Kletzander wrote: > Laine found out that he can't do 'virsh nodedev-detach pci_dev' > because of some strange error message. That was caused by my commit, > but also by all the previous ones that skipped adding tests and > parsing of new functions. In order for this to

Re: [libvirt] [PATCH 3/3] qemu: Add qemuDomainClearPrivatePaths and use it

2016-04-03 Thread Martin Kletzander
On Mon, Apr 04, 2016 at 07:12:50AM +0200, Michal Privoznik wrote: On 03.04.2016 22:23, Martin Kletzander wrote: It's the counterpart of qemuDomainSetPrivatePaths(). Signed-off-by: Martin Kletzander --- src/qemu/qemu_domain.c | 10 ++ src/qemu/qemu_domain.h | 1 + src/qemu/qemu_proc

Re: [libvirt] [PATCH for 1.3.3 0/3] qemu: Regenerate per-domain paths on restart

2016-04-03 Thread Michal Privoznik
On 03.04.2016 22:23, Martin Kletzander wrote: > We forgot to clean up after the domain is torn down. And because they > are kept, we don't regenerate them upn another start and because of > that they contain old IDs in them. > > Again, the series is structured as with the previous one [1]. The >

Re: [libvirt] [PATCH 3/3] qemu: Add qemuDomainClearPrivatePaths and use it

2016-04-03 Thread Michal Privoznik
On 03.04.2016 22:23, Martin Kletzander wrote: > It's the counterpart of qemuDomainSetPrivatePaths(). > > Signed-off-by: Martin Kletzander > --- > src/qemu/qemu_domain.c | 10 ++ > src/qemu/qemu_domain.h | 1 + > src/qemu/qemu_process.c | 3 +-- > 3 files changed, 12 insertions(+), 2

Re: [libvirt] [PATCH 2/5] Change virPCIDeviceAddress to virDevicePCIAddress

2016-04-03 Thread Martin Kletzander
On Sun, Apr 03, 2016 at 10:18:16PM -0400, Laine Stump wrote: On 04/03/2016 03:27 PM, Martin Kletzander wrote: We had both and the only difference was that the latter also included information about multifunction setting. The problem with that was that we couldn't use functions made for only one

Re: [libvirt] [PATCH 2/5] Change virPCIDeviceAddress to virDevicePCIAddress

2016-04-03 Thread Laine Stump
On 04/03/2016 03:27 PM, Martin Kletzander wrote: We had both and the only difference was that the latter also included information about multifunction setting. The problem with that was that we couldn't use functions made for only one of the structs (e.g. parsing). To consolidate those two stru

Re: [libvirt] Availability of libvirt-1.3.3-rc2

2016-04-03 Thread Martin Kletzander
On Sun, Apr 03, 2016 at 09:50:11PM +0200, Martin Kletzander wrote: On Sat, Apr 02, 2016 at 09:35:17PM +0800, Daniel Veillard wrote: On Fri, Apr 01, 2016 at 05:39:36PM +0200, Martin Kletzander wrote: On Fri, Apr 01, 2016 at 11:54:30AM +0800, Daniel Veillard wrote: > I pushed the rc2 tag in git h

[libvirt] [PATCH for 1.3.3 0/3] qemu: Regenerate per-domain paths on restart

2016-04-03 Thread Martin Kletzander
We forgot to clean up after the domain is torn down. And because they are kept, we don't regenerate them upn another start and because of that they contain old IDs in them. Again, the series is structured as with the previous one [1]. The smallest part (firs patch only) is enough to fix it for t

[libvirt] [PATCH 3/3] qemu: Add qemuDomainClearPrivatePaths and use it

2016-04-03 Thread Martin Kletzander
It's the counterpart of qemuDomainSetPrivatePaths(). Signed-off-by: Martin Kletzander --- src/qemu/qemu_domain.c | 10 ++ src/qemu/qemu_domain.h | 1 + src/qemu/qemu_process.c | 3 +-- 3 files changed, 12 insertions(+), 2 deletions(-) diff --git a/src/qemu/qemu_domain.c b/src/qemu/q

[libvirt] [PATCH 2/3] qemu: Simplify calls to qemuDomainSetPrivatePaths

2016-04-03 Thread Martin Kletzander
Since commit 9dca74ee6f54, the function can take driver and a vm, no need to overcomplicate. Signed-off-by: Martin Kletzander --- src/qemu/qemu_domain.c | 30 ++ src/qemu/qemu_domain.h | 9 +++-- src/qemu/qemu_process.c | 7 +-- 3 files changed, 22 inserti

[libvirt] [PATCH 1/3] qemu: Clear generated private paths

2016-04-03 Thread Martin Kletzander
The paths have the domain ID in them. Without cleaning them, they would contain the same ID even after multiple restarts. That could cause various problems, e.g. with access. Reported-by: Guido Günther Signed-off-by: Martin Kletzander --- src/qemu/qemu_process.c | 3 +++ 1 file changed, 3 ins

Re: [libvirt] Availability of libvirt-1.3.3-rc2

2016-04-03 Thread Martin Kletzander
On Sat, Apr 02, 2016 at 09:35:17PM +0800, Daniel Veillard wrote: On Fri, Apr 01, 2016 at 05:39:36PM +0200, Martin Kletzander wrote: On Fri, Apr 01, 2016 at 11:54:30AM +0800, Daniel Veillard wrote: > I pushed the rc2 tag in git head and signed tarball and rpms to the >usual place: > > ftp://libv

[libvirt] [PATCH 5/5] conf: Parse more of our nodedev XML

2016-04-03 Thread Martin Kletzander
We were lacking tests that are checking for the completeness of our nodedev XMLs and also whether we output properly formatted ones. This patch adds parsing for the capability elements inside the element. Also bunch of tests are added to show everything works properly. Signed-off-by: Martin Kle

[libvirt] [PATCH 4/5] schemas: Update nodedev schema to match reality

2016-04-03 Thread Martin Kletzander
There were few things done in the nodedev code but we were lacking tests for it. And because of that we missed that the schema was not updated either. Fix the schema and add various test files to show the schema is correct. Signed-off-by: Martin Kletzander --- docs/schemas/nodedev.rng

[libvirt] [PATCH 2/5] Change virPCIDeviceAddress to virDevicePCIAddress

2016-04-03 Thread Martin Kletzander
We had both and the only difference was that the latter also included information about multifunction setting. The problem with that was that we couldn't use functions made for only one of the structs (e.g. parsing). To consolidate those two structs, move it to virpci.h and include that in domain

[libvirt] [PATCH for 1.3.3 0/5] Fix parsing our own XMLs

2016-04-03 Thread Martin Kletzander
Laine found out that he can't do 'virsh nodedev-detach pci_dev' because of some strange error message. That was caused by my commit, but also by all the previous ones that skipped adding tests and parsing of new functions. In order for this to work in 1.3.3, we need either a) only the first patch

[libvirt] [PATCH 3/5] Move capability formatting together

2016-04-03 Thread Martin Kletzander
All sub-PCI capabilities should be next to each other for clarity. Signed-off-by: Martin Kletzander --- docs/schemas/nodedev.rng | 22 +++--- src/conf/node_device_conf.c| 9 - .../pci__00_1c_0_header_type.xml

[libvirt] [PATCH 1/5] nodedev: Fix parsing of generated XMLs

2016-04-03 Thread Martin Kletzander
Commit d77ffb6876 added not only reporting of the PCI header type, but also parsing of that information. However, because there was no parsing done for the other sub-PCI capabilities, if there was any other capability then a valid header type name (like phys_function or virt_functions) the parsing

Re: [libvirt] Host device assignment driver name vfio/ kvm

2016-04-03 Thread Laine Stump
(please configure your email client to properly quote earlier messages, and reply inline rather as a top-post; it makes it easier for others to determine the context of replies.) On 04/03/2016 05:00 AM, Moshe Levi wrote: Hi, Ok, so here are the errors I get when using vfio/( kvm is working f

Re: [libvirt] Host device assignment driver name vfio/ kvm

2016-04-03 Thread Moshe Levi
Hi, Ok, so here are the errors I get when using vfio/( kvm is working fine) This is the Error [1] I am getting on resume when using vfio. And [2] is the ls output on the /dev/vfio/ Please note that I am trying to attach pci which is VF My setup is: Fedora 21 Libvirt 1.3.0 Qemu 2.5 Kernel 3.17.4