[libvirt] [PATCH v2] qemuhotplugtest: Add tests for ccw devices

2016-07-21 Thread Tomasz Flendrich
There's a plan to rework the address handling, so testcases that verify hotplugging ccw devices will help in avoiding regression. In this commit, some device files are duplicated because of the way qemuhotplug.c calculates the expected xml filenames. I plan on changing that to explicitly stating t

Re: [libvirt] [PATCH v2] qemuhotplugtest: Add tests for ccw devices

2016-07-21 Thread Tomasz Flendrich
>> […] > > But the problem is that you are not checking any assignment. The code > is not executed at all. That's because you specify 'target dev=' from > which we're trying to guess the right address. > > Because virDomainDeviceDefPostParseInternal() is ran for the device > definition and it c

[libvirt] [gconfig v6 4/5] gconfig: Add GVirConfigDomainAddressPci getters

2016-07-21 Thread Zeeshan Ali (Khattak)
From: Christophe Fergeau They will be useful to do more checks in the GVirDomainDeviceHostdev unit test. --- .../libvirt-gconfig-domain-address-pci.c | 45 ++ .../libvirt-gconfig-domain-address-pci.h | 5 +++ libvirt-gconfig/libvirt-gconfig.sym

[libvirt] [gconfig v6 5/5] Add test for GVirConfigDomainHostdevPci API

2016-07-21 Thread Zeeshan Ali (Khattak)
--- tests/test-gconfig.c| 43 + tests/xml/gconfig-domain-device-pci-hostdev.xml | 11 +++ 2 files changed, 54 insertions(+) create mode 100644 tests/xml/gconfig-domain-device-pci-hostdev.xml diff --git a/tests/test-gconfig.c b/tests/test-gc

[libvirt] [gconfig v6 2/5] Add GVirConfigDomainHostdev

2016-07-21 Thread Zeeshan Ali (Khattak)
Add API to read and write domain/devices/hostdev nodes. This patch only adds the baseclass and hence is not useful on it's own. A more specific subclass to represent PCI devices will be added in a following patch. --- libvirt-gconfig/Makefile.am| 2 + .../libvirt-gconfig-

[libvirt] [gconfig v6 1/5] gconfig: Add gvir_config_object_has_child

2016-07-21 Thread Zeeshan Ali (Khattak)
From: Christophe Fergeau --- libvirt-gconfig/libvirt-gconfig-object-private.h | 2 ++ libvirt-gconfig/libvirt-gconfig-object.c | 13 + 2 files changed, 15 insertions(+) diff --git a/libvirt-gconfig/libvirt-gconfig-object-private.h b/libvirt-gconfig/libvirt-gconfig-object-p

[libvirt] [gconfig v6 3/5] Add GVirConfigDomainHostdevPci

2016-07-21 Thread Zeeshan Ali (Khattak)
Add API to read and write PCI hostdev nodes. --- libvirt-gconfig/Makefile.am| 2 + .../libvirt-gconfig-domain-hostdev-pci.c | 232 + .../libvirt-gconfig-domain-hostdev-pci.h | 81 +++ libvirt-gconfig/libvirt-gconfig-domain-host

Re: [libvirt] [PATCHv5 2/5] Add GVirConfigDomainHostdev

2016-07-21 Thread Zeeshan Ali (Khattak)
Hi, On Mon, Jul 18, 2016 at 3:54 PM, Christophe Fergeau wrote: > Please add a gconfig: prefix to the subject line. I have a custom git command to add 'libvirt-glib' prefix but I keep forgetting that --subject-prefix gets overriden by the second --subject-prefix I manually specify for adding patc

[libvirt] Wiki page bad redirect

2016-07-21 Thread Aaron Shindman
The wiki page at http://wiki.libvirt.org/page/I_created_an_external_snapshot,_but_libvirt_won%27t_let_me_delete_or_revert_to_it does not load, with a browser error that the redirect request will never complete -- Aaron Shindman Cherniak Software 416-798-7948 x300 -- libvir-list mailing list l

Re: [libvirt] [RFC PATCH 0/2] nodeinfo: PPC64: Fix topology and siblings info on capabilities and nodeinfo

2016-07-21 Thread Daniel P. Berrange
On Thu, Jul 21, 2016 at 05:52:11PM +0200, Andrea Bolognani wrote: > On Wed, 2016-07-20 at 13:49 +0100, Daniel P. Berrange wrote: > > > Additionally, this doesn't tell us anything about whether any > > > host CPU can run a guest CPU: given the above configuration, > > > on ppc64, we know that CPU 1

Re: [libvirt] [RFC PATCH 0/2] nodeinfo: PPC64: Fix topology and siblings info on capabilities and nodeinfo

2016-07-21 Thread Andrea Bolognani
On Wed, 2016-07-20 at 13:49 +0100, Daniel P. Berrange wrote: > > IIRC doing something like this was proposed at some point in > > the past, but was rejected on the ground that existing tools > > assume that 1) CPUs listed in the NUMA topology are online > > and 2) you can pin vCPUs to them. So they

[libvirt] [PATCH RFC 4/5] lxc: adjusted libvirt-lxc process to add restore mode to it.

2016-07-21 Thread Katerina Koukiou
When doing lxc migration or simply restoring the container from a saved state, we need restore the container from CRIU img files that we have stored in disk. In this patch, we should extend lxcContainerStart into a more generic one, that either starts a container from scratch or restores it from a

[libvirt] [PATCH RFC 3/5] lxc: adds checkpoint and restore helper functions

2016-07-21 Thread Katerina Koukiou
This patch adds some helper functions for checkpointing/restoring linux containers. We use CRIU binary. Signed-off-by: Katerina Koukiou --- po/POTFILES.in | 1 + src/Makefile.am| 3 +- src/lxc/lxc_criu.c | 273 + src/lxc/lxc_criu.h

[libvirt] [PATCH RFC 0/5] lxc: Add save/restore support to lxc driver

2016-07-21 Thread Katerina Koukiou
This patch series adds support for saving an running lxc domain's state into files with lxcDomainSave and restore afterwards from files with lxcDomainRestore. Usage: virsh save [domain-name] [domain-id or domain-uuid] [directory name] I use CRIU tool (https://criu.org/Main_Page), that offers check

[libvirt] [PATCH RFC 5/5] lxc: adds save and restore support

2016-07-21 Thread Katerina Koukiou
Add support for saving an lxc domain's state into files with lxcDomainSave and restore from file with lxcDomainRestore. Usage: virsh save [domain-name] [domain-id or domain-uuid] [directory name] Signed-off-by: Katerina Koukiou --- src/lxc/lxc_driver.c | 234 +

[libvirt] [PATCH RFC 1/5] Include criu support in autotools

2016-07-21 Thread Katerina Koukiou
Check for CRIU binary in autotools. This binary is needed for checkpointing/restoring linux containers. Signed-off-by: Katerina Koukiou --- configure.ac | 8 1 file changed, 8 insertions(+) diff --git a/configure.ac b/configure.ac index 2c81c95..d061676 100644 --- a/configure.ac +++ b/

[libvirt] [PATCH RFC 2/5] lxc: make container's init process session leader

2016-07-21 Thread Katerina Koukiou
This patch forces container's init process, to become a session leader, that is its session ID is made the same as its process ID. That might seem unnecessary in general, but if we want to checkpoint a container with CRIU, which is needed for container migration, we must ensure that the SID of each

Re: [libvirt] [PATCH] qemu: Use legacy USB on ppc64

2016-07-21 Thread Daniel P. Berrange
On Thu, Jul 21, 2016 at 04:56:56PM +0200, Andrea Bolognani wrote: > On Wed, 2016-07-20 at 16:09 +0200, Andrea Bolognani wrote: > > > It seems that we could solve this by just changing the logic in > > > qemuDomainAssignDevicePCISlots() so that when it is auto-assigning > > > addresses, it always us

Re: [libvirt] [PATCH] qemu: Use legacy USB on ppc64

2016-07-21 Thread Andrea Bolognani
On Wed, 2016-07-20 at 16:09 +0200, Andrea Bolognani wrote: > > It seems that we could solve this by just changing the logic in > > qemuDomainAssignDevicePCISlots() so that when it is auto-assigning > > addresses, it always uses 00:00.0 for the USB controller when guest > > arch is ppc64. > >   > >

Re: [libvirt] [PATCH] Remove code duplication in domain_addr.c

2016-07-21 Thread Tomasz Flendrich
I forgot to mention that this patch should be applied on top of these two patches: https://www.redhat.com/archives/libvir-list/2016-July/msg00764.html https://www.redhat.com/archives/libvir-list/2016-July/msg00696.html Tomasz -- libvir-list mailing list libvir-list@redhat.com https://www.redhat.

[libvirt] [PATCH] Remove code duplication in domain_addr.c

2016-07-21 Thread Tomasz Flendrich
Two functions, virDomainValidateDevicePCISlotsQ35 and virDomainValidateDevicePCISlotsPIIX3, had almost exactly the same code for verifying the PCI address of the primary video device. The only difference between them was the slot number. To avoid code duplication, I moved it to a new function: vir

Re: [libvirt] [PATCH v2] qemuhotplugtest: Add tests for ccw devices

2016-07-21 Thread Martin Kletzander
On Mon, Jul 18, 2016 at 08:25:40PM +0200, Tomasz Flendrich wrote: Thank you for your reply! I know you weren't aiming for that, but this got me thinking, are we checking that unplug works with not fully specified XML? I mean that when unplugging, you don't need to specify everything. Whatever

Re: [libvirt] RFC: disk tray opened event and changing media API cooperation

2016-07-21 Thread Nikolay Shirokovskiy
ping On 29.06.2016 15:12, Nikolay Shirokovskiy wrote: > Hi, all. > > I want to remove media if disk is ejected from guest. I can leverage tray > opened event for it but this event generated if i change media thru API call > too. Thus I can't just remove media on any such event. However it woul

Re: [libvirt] [PATCH] qemu: hotplug: fix changeable media ejection

2016-07-21 Thread Bjoern Walk
John Ferlan [2016-07-21, 12:23PM +0200]: On 07/08/2016 06:30 AM, Bjoern Walk wrote: Since return code is checked globally at the end of the function, let's make sure that we set it correctly at any point. This fixes a regression introduced in commit 0aa19f35 where the first command to eject

Re: [libvirt] [PATCH] qemu: hotplug: fix changeable media ejection

2016-07-21 Thread John Ferlan
On 07/08/2016 06:30 AM, Bjoern Walk wrote: > Since return code is checked globally at the end of the function, let's > make sure that we set it correctly at any point. > > This fixes a regression introduced in commit 0aa19f35 where the first > command to eject changeable media would fail uncondi

[libvirt] [PATCH] qemu: Adjust the cur_ballon on coldplug/unplug of dimms

2016-07-21 Thread Shivaprasad G Bhat
The cur_balloon also increases/decreases with dimm hotplug/unplug. To be consistent, adjust the value for coldplug too. This was inconsistently taken care when cur_ballon != memory to begin with. The patch fixes it irrespective of that. Signed-off-by: Shivaprasad G Bhat --- src/conf/domain_conf.

Re: [libvirt] wireshark compilation warning

2016-07-21 Thread Daniel P. Berrange
On Wed, Jul 20, 2016 at 10:27:36AM -0400, Cole Robinson wrote: > I'm seeing this compilation warning on Fedora 24, with > wireshark-devel-2.1.0-3.fc24.x86_64 which has the header file fix that was > previously breaking compilation: > > CC wireshark/src/wireshark_src_libvirt_la-packet-libvi