Re: [libvirt] [PATCH 07/16] snapshot: Add accessors for updating snapshot list relations

2019-03-28 Thread Eric Blake
On 3/28/19 8:51 AM, Eric Blake wrote: > > So gcc isn't as smart as Coverity at seeing that it will always be > initialized. > >> >> This fixes it: >> >> diff --git a/src/conf/virdomainmomentobjlist.c >> b/src/conf/virdomainmomentobjlist.c >> index 92cf52dd..2e9343ff 100644 >> ---

Re: [libvirt] [PATCH 07/16] snapshot: Add accessors for updating snapshot list relations

2019-03-28 Thread Eric Blake
On 3/28/19 2:40 AM, Bjoern Walk wrote: > +/* Take all children of @from and convert them into children of @to. */ > +void > +virDomainSnapshotMoveChildren(virDomainSnapshotObjPtr from, > + virDomainSnapshotObjPtr to) > +{ > +virDomainSnapsho

Re: [libvirt] [PATCH 07/16] snapshot: Add accessors for updating snapshot list relations

2019-03-28 Thread Bjoern Walk
Bjoern Walk [2019-03-28, 08:31AM +0100]: > Eric Blake [2019-03-21, 01:03PM -0500]: > > On 3/20/19 4:28 PM, John Ferlan wrote: > > > > > > > > > On 3/20/19 1:40 AM, Eric Blake wrote: > > >> Rather than allowing a leaky abstraction where multiple drivers have > > >> to open-code operations that u

Re: [libvirt] [PATCH 07/16] snapshot: Add accessors for updating snapshot list relations

2019-03-28 Thread Bjoern Walk
Eric Blake [2019-03-21, 01:03PM -0500]: > On 3/20/19 4:28 PM, John Ferlan wrote: > > > > > > On 3/20/19 1:40 AM, Eric Blake wrote: > >> Rather than allowing a leaky abstraction where multiple drivers have > >> to open-code operations that update the relations in a > >> virDomainSnapshotObjList,

Re: [libvirt] [PATCH 07/16] snapshot: Add accessors for updating snapshot list relations

2019-03-21 Thread Eric Blake
On 3/20/19 4:28 PM, John Ferlan wrote: > > > On 3/20/19 1:40 AM, Eric Blake wrote: >> Rather than allowing a leaky abstraction where multiple drivers have >> to open-code operations that update the relations in a >> virDomainSnapshotObjList, it is better to add accessor functions so >> that updat

Re: [libvirt] [PATCH 07/16] snapshot: Add accessors for updating snapshot list relations

2019-03-20 Thread John Ferlan
On 3/20/19 1:40 AM, Eric Blake wrote: > Rather than allowing a leaky abstraction where multiple drivers have > to open-code operations that update the relations in a > virDomainSnapshotObjList, it is better to add accessor functions so > that updates to relations are maintained closer to the int

[libvirt] [PATCH 07/16] snapshot: Add accessors for updating snapshot list relations

2019-03-19 Thread Eric Blake
Rather than allowing a leaky abstraction where multiple drivers have to open-code operations that update the relations in a virDomainSnapshotObjList, it is better to add accessor functions so that updates to relations are maintained closer to the internals. The goal here is to avoid access to, nch